source: projects/specs/trunk/lib/libe/libexo/libexo-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define srcname exo
2
3Summary: extension library to Xfce
4Summary(ja): Xfceの拡張ライブラリ
5Name: libexo
6Version: 0.3.106
7Release: 1%{?_dist_release}
8Source0: http://www.xfce.org/archive/xfce-%{version}/src/%{srcname}-%{version}.tar.bz2
9License: LGPL
10Group: System Environment/Libraries
11URL: http://www.xfce.org/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gtk2-devel >= 2.6.1
15BuildRequires: libxfcegui4-devel >= 4.2.2
16BuildRequires: libxfce4util-devel >= 4.2.2
17BuildRequires: libnotify-devel >= 0.4.0
18BuildRequires: hal-devel >= 0.5.7
19BuildRequires: python-devel pygtk2-devel
20BuildRequires: perl-URI
21Requires(post): gtk2
22Requires(postun): gtk2
23
24Provides: %{srcname} = %{version}-%{release}
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30libexo is the extension library to Xfce developed by os-cillation.
31While Xfce ships with quite a few libraries that are primarly targeted
32at desktop development, libexo is targeted at application development,
33with a focus on applications for Xfce.
34
35%description -l ja
36libexoはos-cillationにより開発されたXfceの拡張ライブラリです。
37Xfceはデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
38と共に作成されていますが、libexoはアプリケーションの開発、それも
39Xfce用のアプリケーション開発に焦点を定めています。
40
41%package -n %{name}-devel
42Summary: Header files and libraries for developing apps which will use sqlite3
43Summary(ja): libexoの開発用ヘッダファイル及びライブラリ
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: gtk2-devel >= 2.6.1
47Requires: libxfce4util-devel >= 4.2.2
48Requires: hal-devel >= 0.5.7
49Provides: %{srcname}-devel = %{version}-%{release}
50
51%description -n %{name}-devel
52The libexo-devel package contains the header files and libraries needed
53to develop programs that use the libexo library.
54
55%description -n %{name}-devel -l ja
56libexo-develはlibexoライブラリを用いるプログラムの開発に
57必要なヘッダファイル及びライブラリを含むパッケージです。
58
59%prep
60%setup -q -n %{srcname}-%{version}
61
62%build
63%configure --disable-static
64%__make
65
66%install
67rm -rf $RPM_BUILD_ROOT
68%makeinstall
69
70rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
71rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
80fi
81/sbin/ldconfig
82
83%postun
84touch --no-create %{_datadir}/icons/hicolor
85if [ -x /usr/bin/gtk-update-icon-cache ]; then
86  /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
87fi
88/sbin/ldconfig
89
90%files
91%defattr(-,root,root)
92%doc AUTHORS COPYING ChangeLog HACKING README THANKS TODO
93%{_sysconfdir}/xdg/xfce4/helpers.rc
94%{_sysconfdir}/xdg/xfce4/mount.rc
95%{_bindir}/*
96%{_libdir}/lib*.so.*
97%{_libdir}/python?.?/site-packages/*
98%{_libexecdir}/*
99%{_datadir}/applications/*.desktop
100%{_datadir}/icons/hicolor/*/apps/*.png
101%{_datadir}/pixmaps/exo-0.3
102%{_datadir}/pygtk/2.0/*
103%{_datadir}/xfce4/doc/*/*
104%{_datadir}/xfce4/helpers
105%{_localedir}/*/LC_MESSAGES/lib*.mo
106%{_mandir}/man1/*
107
108%files -n %{name}-devel
109%defattr(-,root,root)
110#{_libdir}/lib*.a
111#{_libdir}/lib*.la
112%{_libdir}/lib*.so
113%{_libdir}/pkgconfig/*.pc
114%{_includedir}/exo-0.3
115%{_datadir}/gtk-doc/html/exo-0.3
116
117%changelog
118* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
119- new upstrem release
120- added BR: perl-URI
121
122* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
123- rebuilt with python-2.6.4
124
125* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
126- new upstrem release
127
128* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
129- new upstrem release
130- removed lib*.a from devel package
131
132* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
133- applied with new versioning policy
134- spec in UTF-8
135
136* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
137- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
138
139* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
140- new upstream release.
141
142* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
143- build for VineSeed
144
145* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
146- new upstream version
147- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
148- add %{_bindir}/* in files section.
149- add %{_libdir}/xfce4 in files section.
150- add %{_libexecdir}/* in files section.
151- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
152- add %{_mandir}/man1/* in files section.
153- add %{_datadir}/xfce4/doc/*/* in files section.
154- add %{_datadir}/xfce4/helpers in files section.
155- remove %{_datadir}/gtk-doc/html/exo in files section.
156- update icon-cache in %post and %postun.
157
158* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
159- changed Group to System Environment/Libraires
160- changed devel Group to Development/Libraries
161- added %post and %postun section
162
163* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
164- rebuild for VineSeed
165
166* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
167- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.