source: projects/specs/trunk/lib/libe/libewf/libewf-vl.spec @ 5787

Revision 5787, 5.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Summary: Library to support the Expert Witness Compression Format
4Name: libewf
5Version: 20100226
6Release: 3%{?_dist_release}
7License: LGPL
8Group: System Environment/Libraries
9URL: http://libewf.sourceforge.net
10
11Source0: %{name}-%{version}.tar.gz
12Source1: mount_ewf-20090113.py
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16Requires:   zlib
17BuildRequires:   zlib-devel
18BuildRequires:   libuuid-devel
19BuildRequires:   openssl-devel
20BuildRequires:   python-devel
21
22%description
23libewf is a library for support of the Expert Witness Compression Format (EWF).
24libewf allows you to read media information of EWF files in the SMART (EWF-S01)
25format and the EnCase (EWF-E01) format. libewf allows to read files created by
26EnCase 1 to 6, linen and FTK Imager.
27
28%package devel
29Summary: Header files and libraries for developing applications for libewf
30Group: Development/Libraries
31Requires: libewf = %{version}-%{release}
32
33%description devel
34Header files and libraries for developing applications for libewf.
35
36%package tools
37Summary: Several tools for reading and writing EWF files
38Group: Applications/System
39Requires: openssl e2fsprogs-devel libewf = %{version}-%{release}
40BuildRequires: zlib-devel openssl-devel e2fsprogs-devel
41
42%description tools
43Several tools for reading and writing EWF files.
44It contains tools to acquire, verify and export EWF files.
45
46%prep
47%setup -q
48
49%build
50%configure \
51        --disable-static \
52        --enable-v2-api=yes \
53        --enable-wide-character-type \
54        --enable-python
55make %{?_smp_mflags}
56
57%install
58rm -rf ${RPM_BUILD_ROOT}
59make DESTDIR=${RPM_BUILD_ROOT} install
60
61mkdir -p ${RPM_BUILD_ROOT}/sbin
62install -pm 0755 %{SOURCE1} ${RPM_BUILD_ROOT}/sbin/mount.ewf
63ln -s mount.ewf ${RPM_BUILD_ROOT}/sbin/umount.ewf
64
65find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
66
67%clean
68rm -rf ${RPM_BUILD_ROOT}
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74%files
75%defattr(644,root,root,755)
76%doc AUTHORS COPYING NEWS README
77%attr(755,root,root) %{_libdir}/*.so.*
78
79%files devel
80%defattr(644,root,root,755)
81%doc AUTHORS COPYING NEWS README ChangeLog
82%{_libdir}/*.so
83%{_libdir}/pkgconfig/libewf.pc
84%{_includedir}/*
85%{_mandir}/man3/*
86
87%files tools
88%defattr(644,root,root,755)
89%doc AUTHORS COPYING NEWS README
90%attr(755,root,root) %{_bindir}/ewfacquire
91%attr(755,root,root) %{_bindir}/ewfacquirestream
92%attr(755,root,root) %{_bindir}/ewfexport
93%attr(755,root,root) %{_bindir}/ewfinfo
94%attr(755,root,root) %{_bindir}/ewfverify
95%attr(755,root,root) /sbin/*.ewf
96%{python_sitearch}/pyewf.so*
97%{_mandir}/man1/*
98
99%changelog
100* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 20100226-3
101- rebuild with python-2.7.2
102
103* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 20100226-2
104- rebuild with openssl-1.0.0c
105
106* Tue Dec 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 20100226-1
107- initial build for Vine Linux
108
109
110* Sat Nov 14 2009 Joachim Metz <forensics@hoffmannbv.nl> 20091114-1
111- Removed ewfalter and ewfdebug exclusion for stable release
112
113* Fri Aug 28 2009 Joachim Metz <forensics@hoffmannbv.nl> 20090828-1
114- Added dynamic support for libuuid requires and build requires
115
116* Sun Apr 5 2009 Joachim Metz <forensics@hoffmannbv.nl> 20090405-1
117- Added exclusion for ewfdebug
118- Added default v2 API support
119
120* Sat Mar 7 2009 Joachim Metz <forensics@hoffmannbv.nl> 20090307-1
121- Changed libuca into libuna
122- Added support for libbfio
123
124* Tue Sep 2 2008 Joachim Metz <forensics@hoffmannbv.nl> 20080902-1
125- Changed project website
126- Added support for libuca
127
128* Sat Aug 9 2008 Joachim Metz <forensics@hoffmannbv.nl> 20080809-1
129- Changed license
130
131* Sun May 11 2008 Joachim Metz <forensics@hoffmannbv.nl> 20080511-1
132- Fixed a typo
133
134* Thu May 1 2008 Joachim Metz <forensics@hoffmannbv.nl> 20080501-1
135- Added some addition text to the description of the tools package
136
137* Wed Mar 12 2008 Joachim Metz <forensics@hoffmannbv.nl> 20080312-1
138- Added requirement for e2fsprogs-devel package for libuuid
139
140* Sat Dec 29 2007 Joachim Metz <forensics@hoffmannbv.nl> 20071229-1
141- Updated URL
142
143* Sun Dec 9 2007 Joachim Metz <forensics@hoffmannbv.nl> 20071209-1
144- Moved pkgconfig file from excluded to development
145- Adjustments to Requires and BuildRequires
146- Adjusted description of library package removed tools
147- Corrected groups
148
149* Sat Sep 15 2007 Joachim Metz <forensics@hoffmannbv.nl> 20070915-1
150- Adjustment to text
151- library and tools are now stored in seperate packages
152
153* Mon Jan 15 2007 Joachim Metz <forensics@hoffmannbv.nl> 20070115-1
154- Added ewfacquirestream to package
155
156* Fri Dec 29 2006 Joachim Metz <forensics@hoffmannbv.nl> 20061229-1
157- Added exclusion of new expirimental addtitions
158
159* Tue Dec 26 2006 Christophe Grenier <grenier@cgsecurity.org> 20061223-2
160- Made small correction to the spec file, removed abundant Requires line
161
162* Sat Dec 23 2006 Joachim Metz <forensics@hoffmannbv.nl> 20061223-1
163- Made small corrections to the spec file input by Christophe Grenier
164- Added --libdir to ./configure to correct for /usr/lib64
165
166* Sat Dec 19 2006 Joachim Metz <forensics@hoffmannbv.nl> 20061219-1
167- Made small corrections to the spec file input by Christophe Grenier
168- The library source package no longer contains a release number
169
170* Sat Dec 16 2006 Christophe Grenier <grenier@cgsecurity.org> 20061213-2
171- Fixed the spec file
172
173* Sat Dec 9 2006 Joachim Metz <forensics@hoffmannbv.nl> 20061213-1
174- Initial version
175
Note: See TracBrowser for help on using the repository browser.