source: projects/specs/trunk/lib/libe/libevent/libevent-vl.spec @ 11897

Revision 11897, 4.7 KB checked in by tomop, 6 years ago (diff)

libevent-2.1.8-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Abstract asynchronous event notification library
4Summary(ja):    非同期イベント通知ライブラリ
5Name:           libevent
6Version:        2.1.8
7Release:        2%{?_dist_release}
8Group:          System Environment/Libraries
9License:        BSD
10URL:            https://libevent.org/
11Source0:        https://github.com/libevent/libevent/releases/download/release-%{version}-stable/libevent-%{version}-stable.tar.gz
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  openssl-devel
19
20
21%description
22The libevent API provides a mechanism to execute a callback function
23when a specific event occurs on a file descriptor or after a timeout
24has been reached. libevent is meant to replace the asynchronous event
25loop found in event driven network servers. An application just needs
26to call event_dispatch() and can then add or remove events dynamically
27without having to change the event loop.
28
29%package devel
30Summary: Header files, libraries and development documentation for %{name}
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description devel
35This package contains the header files, static libraries and development
36documentation for %{name}. If you like to develop programs using %{name},
37you will need to install %{name}-devel.
38
39
40%package -n compat32-%{name}
41Summary:        Abstract asynchronous event notification library
42Summary(ja):    非同期イベント通知ライブラリ
43Group:          System Environment/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description -n compat32-%{name}
47The libevent API provides a mechanism to execute a callback function
48when a specific event occurs on a file descriptor or after a timeout
49has been reached. libevent is meant to replace the asynchronous event
50loop found in event driven network servers. An application just needs
51to call event_dispatch() and can then add or remove events dynamically
52without having to change the event loop.
53
54
55%prep
56%setup -q -n %{name}-%{version}-stable
57
58
59%build
60%configure \
61    --disable-static \
62    --disable-dependency-tracking
63%__make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68%__make DESTDIR=$RPM_BUILD_ROOT install
69rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76
77%postun -p /sbin/ldconfig
78
79
80%files
81%defattr(-,root,root,0755)
82%doc README
83%{_bindir}/*
84%{_libdir}/lib*.so.*
85
86%files devel
87%defattr(-,root,root,0755)
88%doc sample/*.c
89%{_includedir}/*
90%{_libdir}/lib*.so
91%{_libdir}/pkgconfig/%{name}*.pc
92
93%if %{build_compat32}
94%files -n compat32-%{name}
95%defattr(-,root,root,0755)
96%doc README
97%{_bindir}/*
98%{_libdir}/lib*.so.*
99%endif
100
101
102%changelog
103* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.8-2
104- added a subpackage 'compat32-libevent'.
105
106* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.8-1
107- updated to 2.1.8.
108
109* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
110- rebuild with openssl-1.0.2
111
112* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-1
113- update to 2.0.21
114
115* Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.20-1
116- new upstream release
117
118* Sun Feb 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.10-2
119- add BuildRequires: openssl-devel
120
121* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.10-1
122- new upstream release
123
124* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.13-2
125- rebuilt with gcc-4.4.3-3 on ppc
126
127* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-1
128- new upstream release
129- built with new toolchains
130
131* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-2
132- spec in utf-8
133- remove static libs
134
135* Wed Apr 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-1
136- new upstream release
137
138* Sun Jul  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3b-0vl1
139- new upstream release
140
141* Sun Aug 13 2006 IWAI, Masaharu <iwai@alib.jp> 1.1b-0vl1
142- new upstream release
143
144* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1a-0vl1
145- initial build for Vine Linux
146
147* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.1a-3.2
148- bump again for double-long bug on ppc(64)
149
150* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1a-3.1
151- rebuilt for new gcc4.1 snapshot and glibc changes
152
153* Tue Jan 24 2006 Warren Togami <wtogami@redhat.com> - 1.1a-3
154- rebuild (#177697)
155
156* Mon Jul 04 2005 Ralf Ertzinger <ralf@skytale.net> - 1.1a-2
157- Removed unnecessary -r from rm
158
159* Fri Jun 17 2005 Ralf Ertzinger <ralf@skytale.net> - 1.1a-1
160- Upstream update
161
162* Wed Jun 08 2005 Ralf Ertzinger <ralf@skytale.net> - 1.1-2
163- Added some docs
164- Moved "make verify" into %%check
165
166* Mon Jun 06 2005 Ralf Ertzinger <ralf@skytale.net> - 1.1-1
167- Initial build for Fedora Extras, based on the package
168  by Dag Wieers
Note: See TracBrowser for help on using the repository browser.