source: projects/specs/trunk/lib/libe/libev/libev-vl.spec @ 9049

Revision 9049, 5.9 KB checked in by inagaki, 9 years ago (diff)

2014-11-01 Ryoichi INAGAKI <ryo1@…>

  • libev, xmlsec1: updated
  • accountsservice, ctpl, poppler-data: changed Group


Line 
1%global source_dir  %{_datadir}/%{name}-source
2%global inst_srcdir %{buildroot}/%{source_dir}
3
4Name:           libev
5Version:        4.19
6Release:        1%{?_dist_release}
7Summary:        High-performance event loop/event model with lots of features
8Summary(ja):    高機能・高性能のイベントループ・イベントモデル
9Group:          System Environment/Libraries
10License:        BSD or GPLv2+
11URL:            http://software.schmorp.de/pkg/libev.html
12Source0:        http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
13Source1:        %{name}.pc.in
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires:  automake libtool
17
18%description
19Libev is modeled (very loosely) after libevent and the Event Perl
20module, but is faster, scales better and is more correct, and also more
21featureful. And also smaller.
22
23%description -l ja
24libev は libevent および Perl の Event を大まかに参考にして作られましたが、
25それらより高速に動作し、よりスケールし、より正確で、より高機能で、
26同時によりコンパクトです。
27
28
29%package        devel
30Summary:        Development files for %{name}
31Summary(ja):    %{name} の開発用ファイル
32Group:          Development/Libraries
33Requires:       %{name}%{?_isa} = %{version}-%{release}
34Requires:       pkgconfig
35
36%description    devel
37Libev is modeled (very loosely) after libevent and the Event Perl
38module, but is faster, scales better and is more correct, and also more
39featureful. And also smaller. Development libraries.
40
41%description    devel -l ja
42このパッケージには libev 用開発ライブラリとヘッダが収録されています。
43
44
45%package        source
46Summary:        Source code for libev
47Summary(ja):    libev のソースコード
48Group:          Development/Libraries
49BuildArch:      noarch
50
51%description    source
52This package contains the source code for libev.
53
54Libev is modeled (very loosely) after libevent and the Event Perl
55module, but is faster, scales better and is more correct, and also more
56featureful. And also smaller. Development libraries.
57
58%description    source -l ja
59このパッケージには libev のソースコードが収録されています。
60
61
62%prep
63%setup -q
64
65# Add pkgconfig support
66cp -p %{SOURCE1} .
67sed -i.pkgconfig -e 's|Makefile|Makefile libev.pc|' configure.ac configure
68sed -i.pkgconfig -e 's|lib_LTLIBRARIES|pkgconfigdir = $(libdir)/pkgconfig\n\npkgconfig_DATA = libev.pc\n\nlib_LTLIBRARIES|' Makefile.am Makefile.in
69aclocal
70automake
71
72
73%build
74%configure --disable-static --with-pic --includedir=%{_includedir}/%{name}
75make %{?_smp_mflags}
76
77
78%check
79make check
80
81
82%install
83rm -rf %{buildroot}
84make install DESTDIR=%{buildroot} INSTALL="install -p"
85
86rm -rf %{buildroot}%{_libdir}/%{name}.la
87
88# Make the source package
89mkdir -p %{inst_srcdir}
90
91find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
92install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
93
94
95%clean
96rm -rf %{buildroot}
97
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
102
103%files
104%doc Changes LICENSE README
105%{_libdir}/%{name}.so.4
106%{_libdir}/%{name}.so.4.0.0
107
108
109%files devel
110%{_libdir}/%{name}.so
111%{_includedir}/libev/
112%{_libdir}/pkgconfig/%{name}.pc
113%{_mandir}/man?/*
114
115
116%files source
117%{source_dir}
118
119
120%changelog
121* Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
122- updated to 4.19
123- spec in UTF-8
124- moved devel and source packages to Development/Libraries Group
125
126* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
127- initial build for Vine Linux
128
129* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
131
132* Tue Aug  9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
133- move man page
134- cleanup spec
135- update to 4.04
136
137* Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
138- EL5 cannot have noarch subpackages.
139
140* Sat Feb  5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
141- 4.03; RHBZ#674022
142- add a -source subpackage (Mathieu Bridon); RHBZ#672153
143
144* Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
145- 4.01
146- fix grammar in %%description
147
148* Sat Jan  2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
149- 3.9
150
151* Fri Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
152- 3.8
153- always use the most recent automake
154- BuildRequires now libtool
155
156* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
158
159* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
160- spec file change, which prevented uploading most recent tarball
161  so the RPM was "3.70" but tarball was from 3.60
162
163* Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
164- v3.7
165- list libev soname explicitly
166
167* Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
168- previous version was called "3.6" but this is broken update
169  path wrt version "3.53" -- thus bumping to "3.60"
170
171* Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
172- 3.60
173- fixed few mixed-use-of-spaces-and-tabs warnings in spec file
174
175* Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
176- 3.53
177
178* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
180
181* Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
182- 3.52
183
184* Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
185- 3.51
186
187* Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
188- version bump: 3.49
189
190* Sun Nov  9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
191- version bump: 3.48
192
193* Mon Oct  6 2008 kwizart <kwizart at gmail.com> - 3.44-1
194- bump to 3.44
195
196* Tue Sep  2 2008 kwizart <kwizart at gmail.com> - 3.43-4
197- Fix pkgconfig support
198
199* Mon Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
200- removed libev.a
201- installing with "-p"
202- event.h is removed intentionaly, because is there only for
203  backward compatibility with libevent
204
205* Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
206- initial package
207
Note: See TracBrowser for help on using the repository browser.