source: projects/specs/trunk/lib/libe/libesmtp/libesmtp-vl.spec @ 1316

Revision 1316, 6.2 KB checked in by daisuke, 14 years ago (diff)

libesmtp: new package, 1.0.4

Line 
1%define plugindir %{_libdir}/esmtp-plugins
2
3Summary:        SMTP client library
4SUmmary(ja):    SMTPクライアントライブラリ
5Name:           libesmtp
6Version:        1.0.4
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group:          System Environment/Libraries
10Source:         http://www.stafford.uklinux.net/libesmtp/%{name}-%{version}.tar.bz2
11Patch1:         libesmtp-build.patch
12Patch2:         libesmtp-1.0.4-ssl.patch
13URL:            http://www.stafford.uklinux.net/libesmtp/
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires:  openssl-devel pkgconfig
16
17%description
18LibESMTP is a library to manage posting (or submission of) electronic
19mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
20Exim. It may be used as part of a Mail User Agent (MUA) or another
21program that must be able to post electronic mail but where mail
22functionality is not the program's primary purpose.
23
24%package devel
25Summary: Headers and development libraries for libESMTP
26# example file is under the GPLv2+
27License: LGPLv2+ and GPLv2+
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}, openssl-devel
30
31%description devel
32LibESMTP is a library to manage posting (or submission of) electronic
33mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
34Exim.
35
36The libesmtp-devel package contains headers and development libraries
37necessary for building programs against libesmtp.
38
39%prep
40%setup -q
41%patch1 -p1 -b .build
42%patch2 -p1 -b .571817
43
44# Keep rpmlint happy about libesmtp-debuginfo...
45chmod a-x htable.c
46
47%build
48
49if pkg-config openssl ; then
50  export CFLAGS="$CFLAGS $RPM_OPT_FLAGS `pkg-config --cflags openssl`"
51  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
52fi
53%configure --with-auth-plugin-dir=%{plugindir} --enable-pthreads \
54  --enable-require-all-recipients --enable-debug \
55  --enable-etrn --disable-isoc --disable-more-warnings --disable-static
56make %{?_smp_mflags}
57cat << "EOF" > libesmtp.pc
58prefix=%{_prefix}
59exec_prefix=%{_prefix}
60libdir=%{_libdir}
61includedir=%{_includedir}
62
63Name: libESMTP
64Version: %{version}
65Description: SMTP client library.
66Requires: openssl
67Libs: -pthread -L${libdir} -lesmtp
68Cflags:
69EOF
70
71cat << "EOF" > libesmtp-config
72#! /bin/sh
73exec pkg-config "$@" libesmtp
74EOF
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make DESTDIR=$RPM_BUILD_ROOT install INSTALL='install -p'
79rm $RPM_BUILD_ROOT/%{_libdir}/*.la
80rm $RPM_BUILD_ROOT/%{_libdir}/esmtp-plugins/*.la
81install -p -m644 -D libesmtp.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libesmtp.pc
82
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHORS COPYING.LIB NEWS Notes README
94%{_libdir}/libesmtp.so.*
95%{plugindir}
96
97%files devel
98%defattr(-,root,root,-)
99%doc examples COPYING
100%{_bindir}/libesmtp-config
101%{_prefix}/include/*
102%{_libdir}/libesmtp.so
103%{_libdir}/pkgconfig/libesmtp.pc
104
105%changelog
106* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
107- new upstream release
108
109- fix bug 599428: use 'version' macro instead of '_version'.
110- Use SSL patch by Ludwig Nussel of SUSE (bugzilla att id 399130).
111
112* Tue Mar  9 2010 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-13
113- fix CVE-2009-2408 (#571817).
114
115* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-12
116- rebuilt with new openssl
117
118* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-11
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-10
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-9
125- rebuild with new openssl
126
127* Sat Nov  1 2008 Manuel "lonely wolf" Wolfshant <wolfy@fedoraproject.org> - 1.0.4-8
128- do not package libtool files from the plugin directory
129
130* Fri Apr  4 2008 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-7
131- attempt at multilib support (#342011).
132
133* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.4-6
134- Autorebuild for GCC 4.3
135
136* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.0.4-5
137 - Rebuild for deps
138
139* Sun Nov 18 2007 Patrice Dumas <pertusus@free.fr> - 1.0.4-4
140- use --disable-static
141
142* Thu Nov 15 2007 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-3
143- drop static libs as suggested in bug 377731.
144
145* Mon Sep 11 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-2
146- rebuild for FC6.
147
148* Fri Mar 24 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-1
149- Update to 1.0.4 - redo build and ssl patches.
150
151* Wed Mar  1 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-8
152- Rebuild for Fedora Extras 5
153
154* Sun Dec  4 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-7
155- Fix bug 173332 completely, including licence issues.
156
157* Thu Nov 17 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-6
158- fix #173332.
159
160* Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> - 1.0.3r1-5
161- rebuild against newer crypto libs
162
163* Wed Oct 19 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-4
164- fix crashes on certificates with subjectAltName extension. Fix #166844.
165
166* Sun Jun 12 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-3
167- Add libesmtp-build.patch - fix building under FC4.
168
169* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.3r1-2
170- Include libesmtp-config in libesmtp-devel (#125426, patch by Robert Scheck)
171
172* Tue Jul 13 2004 John Dennis <jdennis@redhat.com> 1.0.3r1-1
173- bring up to latest upstream release
174
175* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
176- rebuilt
177
178* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
179- rebuilt
180
181* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
182- rebuilt
183
184* Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 1.0.2-1
185- upgrade to 1.0.2 (#113894)
186
187* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.0.1-1
188- update to 1.0.1, rebuild to fix some broken 64-bit libs
189
190* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
191- rebuilt
192
193* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
194- rebuilt
195
196* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-4
197- include compilation flags for openssl as defined for pkg-config
198- don't blow up on compile because key schedules aren't arrays
199
200* Tue Nov  5 2002 Bill Nottingham <notting@redhat.com> 0.8.12-3
201- build on various platforms
202
203* Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.8.12-2
204- fix broken lib (no pthread dependency)
Note: See TracBrowser for help on using the repository browser.