source: projects/specs/trunk/lib/libe/libesmtp/libesmtp-vl.spec @ 9287

Revision 9287, 6.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-22 Ryoichi INAGAKI <ryo1@…>

  • libesmtp, spice, spice-protcol, telepathy-salut: updated
  • ptlib: rebuilt


Line 
1%define plugindir %{_libdir}/esmtp-plugins
2
3Summary:        SMTP client library
4SUmmary(ja):    SMTP クライアントライブラリ
5Name:           libesmtp
6Version:        1.0.6
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group:          System Environment/Libraries
10URL:            http://www.stafford.uklinux.net/libesmtp/
11
12Source:         http://www.stafford.uklinux.net/libesmtp/%{name}-%{version}.tar.bz2
13Patch1:         libesmtp-build.patch
14Patch2:         libesmtp-1.0.4-ssl.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires:  openssl-devel
18BuildRequires:  pkgconfig
19
20%description
21LibESMTP is a library to manage posting (or submission of) electronic
22mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
23Exim. It may be used as part of a Mail User Agent (MUA) or another
24program that must be able to post electronic mail but where mail
25functionality is not the program's primary purpose.
26
27%package devel
28Summary: Headers and development libraries for libESMTP
29# example file is under the GPLv2+
30License: LGPLv2+ and GPLv2+
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires:  openssl-devel
34
35%description devel
36LibESMTP is a library to manage posting (or submission of) electronic
37mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
38Exim.
39
40The libesmtp-devel package contains headers and development libraries
41necessary for building programs against libesmtp.
42
43#'
44
45%prep
46%setup -q
47%patch1 -p1 -b .build
48#patch2 -p1 -b .571817
49
50# Keep rpmlint happy about libesmtp-debuginfo...
51chmod a-x htable.c
52
53%build
54
55if pkg-config openssl ; then
56  export CFLAGS="$CFLAGS $RPM_OPT_FLAGS `pkg-config --cflags openssl`"
57  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
58fi
59
60%configure \
61  --with-auth-plugin-dir=%{plugindir} \
62  --enable-pthreads \
63  --enable-require-all-recipients \
64  --enable-debug \
65  --enable-etrn \
66  --disable-isoc \
67  --disable-more-warnings \
68  --disable-static
69
70make %{?_smp_mflags}
71cat << "EOF" > libesmtp.pc
72prefix=%{_prefix}
73exec_prefix=%{_prefix}
74libdir=%{_libdir}
75includedir=%{_includedir}
76
77Name: libESMTP
78Version: %{version}
79Description: SMTP client library.
80Requires: openssl
81Libs: -pthread -L${libdir} -lesmtp
82Cflags:
83EOF
84
85cat << "EOF" > libesmtp-config
86#! /bin/sh
87exec pkg-config "$@" libesmtp
88EOF
89
90%install
91rm -rf $RPM_BUILD_ROOT
92make DESTDIR=$RPM_BUILD_ROOT install INSTALL='install -p'
93rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
94rm -f $RPM_BUILD_ROOT/%{_libdir}/esmtp-plugins/*.la
95install -p -m644 -D libesmtp.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libesmtp.pc
96
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc AUTHORS COPYING.LIB NEWS Notes README
108%{_libdir}/libesmtp.so.*
109%{plugindir}
110
111%files devel
112%defattr(-,root,root,-)
113%doc examples COPYING
114%{_bindir}/libesmtp-config
115%{_prefix}/include/*
116%{_libdir}/libesmtp.so
117%{_libdir}/pkgconfig/libesmtp.pc
118
119%changelog
120* Thu Jan 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.6-1
121- updated to 1.0.6
122- dropt Patch2
123
124* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
125- rebuild with openssl-1.0.0d
126
127* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
128- rebuild with rpm-4.8.1 for pkg-config file
129
130* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
131- new upstream release
132
133- fix bug 599428: use 'version' macro instead of '_version'.
134- Use SSL patch by Ludwig Nussel of SUSE (bugzilla att id 399130).
135
136* Tue Mar  9 2010 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-13
137- fix CVE-2009-2408 (#571817).
138
139* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-12
140- rebuilt with new openssl
141
142* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-11
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
144
145* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-10
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
147
148* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-9
149- rebuild with new openssl
150
151* Sat Nov  1 2008 Manuel "lonely wolf" Wolfshant <wolfy@fedoraproject.org> - 1.0.4-8
152- do not package libtool files from the plugin directory
153
154* Fri Apr  4 2008 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-7
155- attempt at multilib support (#342011).
156
157* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.4-6
158- Autorebuild for GCC 4.3
159
160* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.0.4-5
161 - Rebuild for deps
162
163* Sun Nov 18 2007 Patrice Dumas <pertusus@free.fr> - 1.0.4-4
164- use --disable-static
165
166* Thu Nov 15 2007 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-3
167- drop static libs as suggested in bug 377731.
168
169* Mon Sep 11 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-2
170- rebuild for FC6.
171
172* Fri Mar 24 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-1
173- Update to 1.0.4 - redo build and ssl patches.
174
175* Wed Mar  1 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-8
176- Rebuild for Fedora Extras 5
177
178* Sun Dec  4 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-7
179- Fix bug 173332 completely, including licence issues.
180
181* Thu Nov 17 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-6
182- fix #173332.
183
184* Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> - 1.0.3r1-5
185- rebuild against newer crypto libs
186
187* Wed Oct 19 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-4
188- fix crashes on certificates with subjectAltName extension. Fix #166844.
189
190* Sun Jun 12 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-3
191- Add libesmtp-build.patch - fix building under FC4.
192
193* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.3r1-2
194- Include libesmtp-config in libesmtp-devel (#125426, patch by Robert Scheck)
195
196* Tue Jul 13 2004 John Dennis <jdennis@redhat.com> 1.0.3r1-1
197- bring up to latest upstream release
198
199* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
200- rebuilt
201
202* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
203- rebuilt
204
205* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
206- rebuilt
207
208* Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 1.0.2-1
209- upgrade to 1.0.2 (#113894)
210
211* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.0.1-1
212- update to 1.0.1, rebuild to fix some broken 64-bit libs
213
214* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
215- rebuilt
216
217* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
218- rebuilt
219
220* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-4
221- include compilation flags for openssl as defined for pkg-config
222- don't blow up on compile because key schedules aren't arrays
223
224* Tue Nov  5 2002 Bill Nottingham <notting@redhat.com> 0.8.12-3
225- build on various platforms
226
227* Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.8.12-2
228- fix broken lib (no pthread dependency)
Note: See TracBrowser for help on using the repository browser.