source: projects/specs/trunk/lib/libe/libepoxy/libepoxy-vl.spec @ 9791

Revision 9791, 2.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library for handling OpenGL function pointer management
4Name: libepoxy
5Version: 1.3.1
6Release: 1%{?_dist_release}
7License: MIT
8Group: System Environment/Libraries
9URL: https://github.com/anholt/libepoxy
10
11Source0: %{name}-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires: mesa-libGL-devel
16BuildRequires: mesa-libEGL-devel
17BuildRequires: mesa-libGLES-devel
18BuildRequires: xorg-x11-util-macros
19BuildRequires: python
20BuildRequires: autoconf
21BuildRequires: libtool
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28Epoxy is a library for handling OpenGL function pointer management for you.
29
30%package devel
31Summary: Development tools for %{name}
32Summary(ja): %{name} の開発環境
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: pkgconfig
36
37%description devel
38Header files and libraries for building a extension library for the %{name}.
39
40# compat32
41%package -n compat32-%{name}
42Summary: A library for handling OpenGL function pointer management
43Group: System Environment/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description -n compat32-%{name}
47Epoxy is a library for handling OpenGL function pointer management for you.
48
49%package -n compat32-%{name}-devel
50Summary: Development tools for compat32-%{name}
51Summary(ja): compat32-%{name} の開発環境
52Group: Development/Libraries
53Requires: compat32-%{name} = %{version}-%{release}
54Requires: %{name}-devel = %{version}-%{release}
55
56%description -n compat32-%{name}-devel
57Header files and libraries for building a extension library for the compat32-%{name}.
58
59%prep
60%setup -q
61sed -i "s|python3||g" configure.ac
62
63%build
64autoreconf -if
65%configure --disable-static
66make %{?smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install DESTDIR=$RPM_BUILD_ROOT
71
72find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%check
78make check
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%post -n compat32-%{name} -p /sbin/ldconfig
84%postun -n compat32-%{name} -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc README.md
89%{_libdir}/libepoxy.so.*
90
91%files devel
92%defattr(-,root,root,-)
93%{_includedir}/epoxy
94%{_libdir}/libepoxy.so
95%{_libdir}/pkgconfig/epoxy.pc
96
97# compat32
98%if %{build_compat32}
99%files -n compat32-%{name}
100%defattr(-,root,root,-)
101%{_libdir}/libepoxy.so.*
102
103%files -n compat32-%{name}-devel
104%defattr(-,root,root,-)
105%{_libdir}/libepoxy.so
106%endif
107
108%changelog
109* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
110- new upstream release
111
112* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1
113- initial build
114
Note: See TracBrowser for help on using the repository browser.