source: projects/specs/trunk/lib/libd/libdvdread/libdvdread-vl.spec @ 1895

Revision 1895, 5.4 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1: libavc1394, libdc1394, libdv, libdvdread, libiec61883, libraw1394

Line 
1# -*- coding: utf-8-unix -*-
2Name:           libdvdread
3Summary:        A library for reading DVD video discs based on Ogle code
4Version:        4.1.3
5Release:        4%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        GPLv2+
9
10Source:         http://www.mplayerhq.hu/MPlayer/releases/dvdnav/libdvdread-%{version}.tar.bz2
11Patch10:        %{name}-4.1.3_bigendian.patch
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Obsoletes:      self-build-libdvdread
15
16%description
17libdvdread provides a simple foundation for reading DVD video disks.
18It provides the functionality that is required to access many DVDs.
19
20%package        devel
21Summary:        Development files for libdvdread
22Group:          Development/Libraries
23Requires:       %{name} = %{version}-%{release}
24
25%description    devel
26libdvdread provides a simple foundation for reading DVD video disks.
27It provides the functionality that is required to access many DVDs.
28
29This package contains development files for libdvdread.
30
31%prep
32%setup -q
33%patch10 -p1 -b .bigendian
34
35%build
36./configure2 \
37    --disable-opts \
38    --disable-static \
39    --disable-strip \
40    --extra-cflags="%{optflags}" \
41    --libdir=%{_libdir} \
42    --prefix=%{_prefix} \
43    --shlibdir=%{_libdir} \
44
45%{__make} %{?_smp_mflags}
46
47%install
48%{__rm} -rf %{buildroot}
49%{__make} install DESTDIR=%{buildroot}
50
51%clean
52%{__rm} -rf %{buildroot}
53
54%post -p /sbin/ldconfig
55
56%postun -p /sbin/ldconfig
57
58%files
59%defattr(-,root,root,-)
60%{_libdir}/libdvdread.so.*
61
62%files devel
63%defattr(-,root,root,-)
64%{_bindir}/dvdread-config
65%{_includedir}/dvdread
66%{_libdir}/libdvdread.so
67%{_libdir}/pkgconfig/dvdread.pc
68
69%changelog
70* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.1.3-4
71- rebuilt with rpm-4.8.1 for pkg-config
72
73* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.3-3
74- add Patch10: fix DVD playback failure on ppc (big endian, more precisely)
75
76* Fri Nov 07 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
77- obsolete self-build-libdvdread
78
79* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
80- initial bulid based on Fedora package
81
82* Tue Sep 09 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-1
83- update to 4.1.3 final
84
85* Sun Aug 31 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.3.rc1
86- update to 4.1.3rc1
87- fix include path
88
89* Thu Jul 17 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.2
90- resurrect package from new upstream
91
92* Sun Jan 27 2008 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-4
93- fix missing <inttypes.h> include (bug 428910)
94
95* Wed Aug 29 2007 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-3
96- rebuild for BuildID
97- update license tag
98
99* Wed Nov 26 2006 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-2
100- Rebuild.
101
102* Fri Oct  6 2006 Dams <anvil[AT]livna.org> - 0.9.7-1
103- Updated to 0.9.7
104
105* Wed Sep 20 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-2
106- Rebuild.
107
108* Sun Jul 23 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-1
109- 0.9.6.
110- Specfile cleanup.
111
112* Thu Mar 16 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.4-4
113- Fix linking with libdl on x86_64.
114- Don't ship static libs.
115- Build with dependency tracking disabled.
116- Convert specfile and docs to UTF-8.
117- Improve package descriptions.
118
119* Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 0.9.4-3
120- We BuildConflicting libdvdcss-devel at build time
121
122* Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.9.4-2
123- Drop Epoch completely
124
125* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
126- switch to new release field
127- drop Epoch
128
129* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
130- add dist
131
132* Thu Apr  3 2003 Marius Johndal <mariuslj at ifi.uio.no> 0:0.9.4-0.fdr.1
133- Initial Fedora RPM release.
134
135* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
136- Rebuilt for Red Hat Linux 9.
137- Exclude .la file.
138
139* Sun Feb 16 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
140- Update to 0.9.4.
141
142* Thu Sep 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
143- Updated to the latest cvs release.
144- Rebuilt for Red Hat Linux 8.0.
145- Updated URLs.
146
147* Mon May 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
148- Update to 0.9.3.
149
150* Wed May 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
151- Fixed the libdvdcss.so.0/1/2 problem again.
152
153* Thu May  2 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
154- Back to using libdvdcss 1.1.1, now it's all merged and fine.
155- Rebuilt against Red Hat Linux 7.3.
156- Added the %{?_smp_mflags} expansion.
157
158* Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
159- Reverted back to using libdvdcss 0.0.3.ogle3 since it works MUCH better
160  than 1.0.x. Doh!
161
162* Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
163- Rebuilt against libdvdcss 1.0.0 (added a patch).
164
165* Mon Oct 29 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
166- Spec file cleanup and fixes.
167
168* Thu Oct 11 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
169- Updated to version 0.9.2
170
171* Tue Sep 25 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
172- Added small patch to fix the ldopen of libdvdcss
173
174* Tue Sep 18 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
175- Updated to version 0.9.1
176
177* Fri Sep 14 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
178- Split into normal and devel package
179
180* Thu Sep 6 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
181- Updated to version 0.9.0
182
183* Tue Jul 03 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
184- initial version
185
186
Note: See TracBrowser for help on using the repository browser.