source: projects/specs/trunk/lib/libd/libdvdread/libdvdread-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# -*- coding: utf-8-unix -*-
2Name:           libdvdread
3Version:        4.1.3
4Release:        3%{?_dist_release}
5Summary:        A library for reading DVD video discs based on Ogle code
6
7Group:          System Environment/Libraries
8License:        GPLv2+
9Source:         http://www.mplayerhq.hu/MPlayer/releases/dvdnav/libdvdread-%{version}.tar.bz2
10Patch10:        %{name}-4.1.3_bigendian.patch
11Obsoletes:      self-build-libdvdread
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15%description
16libdvdread provides a simple foundation for reading DVD video disks.
17It provides the functionality that is required to access many DVDs.
18
19%package        devel
20Summary:        Development files for libdvdread
21Group:          Development/Libraries
22Requires:       %{name} = %{version}-%{release}
23Requires:       pkgconfig
24
25%description    devel
26libdvdread provides a simple foundation for reading DVD video disks.
27It provides the functionality that is required to access many DVDs.
28
29This package contains development files for libdvdread.
30
31%prep
32%setup -q
33%patch10 -p1 -b .bigendian
34
35%build
36./configure2 \
37    --disable-opts \
38    --disable-static \
39    --disable-strip \
40    --extra-cflags="%{optflags}" \
41    --libdir=%{_libdir} \
42    --prefix=%{_prefix} \
43    --shlibdir=%{_libdir} \
44
45%{__make} %{?_smp_mflags}
46
47%install
48%{__rm} -rf %{buildroot}
49%{__make} install DESTDIR=%{buildroot}
50
51%clean
52%{__rm} -rf %{buildroot}
53
54%post -p /sbin/ldconfig
55
56%postun -p /sbin/ldconfig
57
58%files
59%defattr(-,root,root,-)
60%{_libdir}/libdvdread.so.*
61
62%files devel
63%defattr(-,root,root,-)
64%{_bindir}/dvdread-config
65%{_includedir}/dvdread
66%{_libdir}/libdvdread.so
67%{_libdir}/pkgconfig/dvdread.pc
68
69%changelog
70* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.3-3
71- add Patch10: fix DVD playback failure on ppc (big endian, more precisely)
72
73* Fri Nov 07 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
74- obsolete self-build-libdvdread
75
76* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
77- initial bulid based on Fedora package
78
79* Tue Sep 09 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-1
80- update to 4.1.3 final
81
82* Sun Aug 31 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.3.rc1
83- update to 4.1.3rc1
84- fix include path
85
86* Thu Jul 17 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.2
87- resurrect package from new upstream
88
89* Sun Jan 27 2008 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-4
90- fix missing <inttypes.h> include (bug 428910)
91
92* Wed Aug 29 2007 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-3
93- rebuild for BuildID
94- update license tag
95
96* Wed Nov 26 2006 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-2
97- Rebuild.
98
99* Fri Oct  6 2006 Dams <anvil[AT]livna.org> - 0.9.7-1
100- Updated to 0.9.7
101
102* Wed Sep 20 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-2
103- Rebuild.
104
105* Sun Jul 23 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-1
106- 0.9.6.
107- Specfile cleanup.
108
109* Thu Mar 16 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.4-4
110- Fix linking with libdl on x86_64.
111- Don't ship static libs.
112- Build with dependency tracking disabled.
113- Convert specfile and docs to UTF-8.
114- Improve package descriptions.
115
116* Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 0.9.4-3
117- We BuildConflicting libdvdcss-devel at build time
118
119* Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.9.4-2
120- Drop Epoch completely
121
122* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
123- switch to new release field
124- drop Epoch
125
126* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
127- add dist
128
129* Thu Apr  3 2003 Marius Johndal <mariuslj at ifi.uio.no> 0:0.9.4-0.fdr.1
130- Initial Fedora RPM release.
131
132* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
133- Rebuilt for Red Hat Linux 9.
134- Exclude .la file.
135
136* Sun Feb 16 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
137- Update to 0.9.4.
138
139* Thu Sep 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
140- Updated to the latest cvs release.
141- Rebuilt for Red Hat Linux 8.0.
142- Updated URLs.
143
144* Mon May 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
145- Update to 0.9.3.
146
147* Wed May 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
148- Fixed the libdvdcss.so.0/1/2 problem again.
149
150* Thu May  2 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
151- Back to using libdvdcss 1.1.1, now it's all merged and fine.
152- Rebuilt against Red Hat Linux 7.3.
153- Added the %{?_smp_mflags} expansion.
154
155* Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
156- Reverted back to using libdvdcss 0.0.3.ogle3 since it works MUCH better
157  than 1.0.x. Doh!
158
159* Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
160- Rebuilt against libdvdcss 1.0.0 (added a patch).
161
162* Mon Oct 29 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
163- Spec file cleanup and fixes.
164
165* Thu Oct 11 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
166- Updated to version 0.9.2
167
168* Tue Sep 25 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
169- Added small patch to fix the ldopen of libdvdcss
170
171* Tue Sep 18 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
172- Updated to version 0.9.1
173
174* Fri Sep 14 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
175- Split into normal and devel package
176
177* Thu Sep 6 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
178- Updated to version 0.9.0
179
180* Tue Jul 03 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
181- initial version
182
183
Note: See TracBrowser for help on using the repository browser.