source: projects/specs/trunk/lib/libd/libdbi/libdbi-vl.spec @ 9000

Revision 9000, 5.9 KB checked in by inagaki, 10 years ago (diff)

2014-10-06 Ryoichi INAGAKI <ryo1@…>

  • libdbi, libnl, libnl3, libtevent, libunicode: update
Line 
1Name: libdbi
2Summary: Database Independent Abstraction Layer for C
3Version: 0.8.4
4Release: 2%{?_dist_release}
5Group: System Environment/Libraries
6License: LGPLv2+
7URL: http://libdbi.sourceforge.net/
8
9Source: http://prdownloads.sourceforge.net/libdbi/%{name}-%{version}.tar.gz
10
11Patch1: libdbi-cflags.patch
12Patch2: libdbi-leak.patch
13Patch3: libdbi-version.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: openjade docbook-style-dsssl
17Conflicts: libdbi-dbd-mysql < 0.8
18Conflicts: libdbi-dbd-pgsql < 0.8
19
20%description
21libdbi implements a database-independent abstraction layer in C, similar to the
22DBI/DBD layer in Perl. Writing one generic set of code, programmers can
23leverage the power of multiple databases and multiple simultaneous database
24connections by using this framework.
25
26The libdbi package contains just the libdbi framework.  To make use of
27libdbi you will also need one or more plugins from libdbi-drivers, which
28contains the plugins needed to interface to specific database servers.
29
30%package devel
31Summary: Development files for libdbi (Database Independent Abstraction Layer for C)
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36The libdbi-devel package contains the header files and documentation
37needed to develop applications with libdbi.
38
39%clean
40[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41
42%prep
43%setup -q -n %{name}-%{version}
44
45%patch1 -p1
46%patch2 -p1
47%patch3 -p1
48
49%build
50%configure --disable-static
51
52make %{?_smp_mflags}
53
54%install
55[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
56make DESTDIR=$RPM_BUILD_ROOT install
57
58#rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.a
59rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.la
60
61%post -p /sbin/ldconfig
62
63%postun -p /sbin/ldconfig
64
65%files
66%defattr(-,root,root)
67%doc AUTHORS
68%doc ChangeLog
69%doc COPYING
70%doc README
71%{_libdir}/libdbi.so.*
72
73%files devel
74%defattr(-,root,root)
75%doc TODO
76%doc doc/programmers-guide.pdf
77%doc doc/programmers-guide/
78%doc doc/driver-guide.pdf
79%doc doc/driver-guide/
80/usr/include/dbi/
81%{_libdir}/libdbi.so
82
83%changelog
84* Mon Oct  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.4-2
85- moved libdbi to System Environment/Libraries
86
87* Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-1
88- initial build for Vine Linux
89
90* Mon Jul 23 2012 Tom Lane <tgl@redhat.com> 0.8.4-2
91- Prevent undesirable change in library soname version number
92
93* Sun Jul 22 2012 Tom Lane <tgl@redhat.com> 0.8.4-1
94- Update to version 0.8.4 (seems to contain only configure-support updates,
95  but might as well adopt it)
96- Fix memory leak due to incorrect test in _is_row_fetched()
97Related: #733413
98
99* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-6
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
101
102* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
104
105* Fri Sep  3 2010 Tom Lane <tgl@redhat.com> 0.8.3-4
106- Do not use -ffast-math; it breaks things and seems quite unlikely to offer
107  any useful performance benefit for this type of package, anyway
108Resolves: #629964
109
110* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-3
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
112
113* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
117- Update to version 0.8.3.
118
119* Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-3
120- Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
121Resolves: #330681
122
123* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-2
124- Fix typo in Release field.
125
126* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1
127- Update to version 0.8.2.
128- Update License tag to match code.
129- Remove static library and .la file, per packaging guidelines.
130
131* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-2.1
132- rebuild
133
134* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.8.1-2
135- rebuild for -devel deps
136
137* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2.1
138- bump again for double-long bug on ppc(64)
139
140* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2
141- rebuilt for new gcc4.1 snapshot and glibc changes
142
143* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
144- rebuilt
145
146* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1-1
147- Update to version 0.8.1.
148
149* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.2-2
150- Packaging improvements per discussion with sopwith.
151
152* Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.2-1
153- Import new libdbi version, splitting libdbi-drivers into a separate SRPM
154  so we can track new upstream packaging.
155
156* Sun Mar  6 2005 Tom Lane <tgl@redhat.com> 0.6.5-11
157- Rebuild with gcc4.
158
159* Mon Nov 08 2004 Tom Lane <tgl@redhat.com> 0.6.5-10
160- build against mysqlclient10, not mysql, for license reasons
161
162* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
163- rebuilt
164
165* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
166- rebuilt
167
168* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
169- rebuilt
170
171* Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.6.5-7
172- rebuilt
173
174* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
175- rebuilt
176
177* Fri Jan 24 2003 Tom Lane <tgl@redhat.com>
178- /usr/include/dbi should be owned
179
180* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
181- rebuilt
182
183* Sun Dec 01 2002 Elliot Lee <sopwith@redhat.com> 0.6.5-3
184- multilibify
185
186* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
187- automated rebuild
188
189* Tue Jun 18 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.5-1
190- 0.6.5
191
192* Thu May 23 2002 Tim Powers <timp@redhat.com>
193- automated rebuild
194
195* Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.4-2
196- 0.6.4
197
198* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
199- automated rebuild
200
201* Thu Sep 20 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.6.2-1
202- Sanitize, prepare for distribution
203
204* Sat Aug 4 2001 David Parker <david@neongoat.com>
205- initial spec file created
Note: See TracBrowser for help on using the repository browser.