source: projects/specs/trunk/lib/libd/libdbi/libdbi-vl.spec @ 12202

Revision 12202, 6.1 KB checked in by tomop, 5 years ago (diff)

updated gnucash and friends

Line 
1Name: libdbi
2Summary: Database Independent Abstraction Layer for C
3Version: 0.9.0
4Release: 2%{?_dist_release}
5Group: System Environment/Libraries
6License: LGPLv2+
7URL: http://libdbi.sourceforge.net/
8
9Vendor: Project Vine
10Distribution: Vine Linux
11
12Source: http://prdownloads.sourceforge.net/libdbi/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: openjade docbook-style-dsssl
16Conflicts: libdbi-dbd-mysql < 0.8
17Conflicts: libdbi-dbd-pgsql < 0.8
18
19%description
20libdbi implements a database-independent abstraction layer in C, similar to the
21DBI/DBD layer in Perl. Writing one generic set of code, programmers can
22leverage the power of multiple databases and multiple simultaneous database
23connections by using this framework.
24
25The libdbi package contains just the libdbi framework.  To make use of
26libdbi you will also need one or more plugins from libdbi-drivers, which
27contains the plugins needed to interface to specific database servers.
28
29%package devel
30Summary: Development files for libdbi (Database Independent Abstraction Layer for C)
31Group: Development/Libraries
32Requires: pkgconfig
33Requires: %{name} = %{version}-%{release}
34
35%description devel
36The libdbi-devel package contains the header files and documentation
37needed to develop applications with libdbi.
38
39%clean
40[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41
42%prep
43%setup -q -n %{name}-%{version}
44
45%build
46%configure --disable-static
47
48make %{?_smp_mflags}
49
50%install
51[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
52make DESTDIR=$RPM_BUILD_ROOT install
53
54#rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.a
55rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.la
56
57%post -p /sbin/ldconfig
58
59%postun -p /sbin/ldconfig
60
61%files
62%defattr(-,root,root)
63%doc AUTHORS
64%doc ChangeLog
65%license COPYING
66%doc README
67%{_libdir}/libdbi.so.*
68
69%files devel
70%defattr(-,root,root)
71%doc TODO
72%doc doc/programmers-guide.pdf
73%doc doc/programmers-guide/
74%doc doc/driver-guide.pdf
75%doc doc/driver-guide/
76%{_libdir}/libdbi.so
77%{_libdir}/pkgconfig/dbi.pc
78%{_includedir}/dbi/
79
80%changelog
81* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.0-2
82- rebuilt with current environment.
83
84* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.0-1
85- update to 0.9.0
86- remove old patches
87
88* Mon Oct  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.4-2
89- moved libdbi to System Environment/Libraries
90
91* Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-1
92- initial build for Vine Linux
93
94* Mon Jul 23 2012 Tom Lane <tgl@redhat.com> 0.8.4-2
95- Prevent undesirable change in library soname version number
96
97* Sun Jul 22 2012 Tom Lane <tgl@redhat.com> 0.8.4-1
98- Update to version 0.8.4 (seems to contain only configure-support updates,
99  but might as well adopt it)
100- Fix memory leak due to incorrect test in _is_row_fetched()
101Related: #733413
102
103* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-6
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
105
106* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
108
109* Fri Sep  3 2010 Tom Lane <tgl@redhat.com> 0.8.3-4
110- Do not use -ffast-math; it breaks things and seems quite unlikely to offer
111  any useful performance benefit for this type of package, anyway
112Resolves: #629964
113
114* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-3
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
116
117* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
119
120* Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
121- Update to version 0.8.3.
122
123* Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-3
124- Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
125Resolves: #330681
126
127* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-2
128- Fix typo in Release field.
129
130* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1
131- Update to version 0.8.2.
132- Update License tag to match code.
133- Remove static library and .la file, per packaging guidelines.
134
135* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-2.1
136- rebuild
137
138* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.8.1-2
139- rebuild for -devel deps
140
141* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2.1
142- bump again for double-long bug on ppc(64)
143
144* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2
145- rebuilt for new gcc4.1 snapshot and glibc changes
146
147* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
148- rebuilt
149
150* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1-1
151- Update to version 0.8.1.
152
153* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.2-2
154- Packaging improvements per discussion with sopwith.
155
156* Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.2-1
157- Import new libdbi version, splitting libdbi-drivers into a separate SRPM
158  so we can track new upstream packaging.
159
160* Sun Mar  6 2005 Tom Lane <tgl@redhat.com> 0.6.5-11
161- Rebuild with gcc4.
162
163* Mon Nov 08 2004 Tom Lane <tgl@redhat.com> 0.6.5-10
164- build against mysqlclient10, not mysql, for license reasons
165
166* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
167- rebuilt
168
169* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
170- rebuilt
171
172* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
173- rebuilt
174
175* Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.6.5-7
176- rebuilt
177
178* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
179- rebuilt
180
181* Fri Jan 24 2003 Tom Lane <tgl@redhat.com>
182- /usr/include/dbi should be owned
183
184* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
185- rebuilt
186
187* Sun Dec 01 2002 Elliot Lee <sopwith@redhat.com> 0.6.5-3
188- multilibify
189
190* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
191- automated rebuild
192
193* Tue Jun 18 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.5-1
194- 0.6.5
195
196* Thu May 23 2002 Tim Powers <timp@redhat.com>
197- automated rebuild
198
199* Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.4-2
200- 0.6.4
201
202* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
203- automated rebuild
204
205* Thu Sep 20 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.6.2-1
206- Sanitize, prepare for distribution
207
208* Sat Aug 4 2001 David Parker <david@neongoat.com>
209- initial spec file created
Note: See TracBrowser for help on using the repository browser.