source: projects/specs/trunk/lib/libd/libdbi-drivers/libdbi-drivers-vl.spec @ 9291

Revision 9291, 7.8 KB checked in by Takemikaduchi, 9 years ago (diff)

libdbi-drivers,goffice08,guile18: NEW package
geda-gaf,missile,rrdtool,trackballs,trackballs-music,ulogd,xkeycaps,xorg-x11-jpfonts: rebuild
others: new upstream release

Line 
1Summary: Database-specific drivers for libdbi
2Name: libdbi-drivers
3Version: 0.9.0
4Release: 1%{?_dist_release}
5Group: Development/Libraries
6License: LGPLv2+
7URL: http://libdbi-drivers.sourceforge.net/
8
9Source: http://prdownloads.sourceforge.net/libdbi-drivers/%{name}-%{version}.tar.gz
10# old automake does not offer aarch64
11Patch1: libdbi-drivers-aarch64.patch
12
13Requires: libdbi >= 0.9
14BuildRequires: libdbi-devel >= 0.9
15BuildRequires: autoconf
16BuildRequires: openjade docbook-style-dsssl
17BuildRequires: docbook-style-dsssl
18
19BuildRequires: libmysqlclient-devel
20BuildRequires: openssl-devel
21BuildRequires: libpq-devel
22BuildRequires: krb5-devel
23BuildRequires: sqlite3-devel
24
25%description
26libdbi implements a database-independent abstraction layer in C, similar to the
27DBI/DBD layer in Perl. Writing one generic set of code, programmers can
28leverage the power of multiple databases and multiple simultaneous database
29connections by using this framework.
30
31libdbi-drivers contains the database-specific plugins needed to connect
32libdbi to particular database servers.
33
34%package -n libdbi-dbd-mysql
35Summary: MySQL plugin for libdbi
36Group: Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38
39%description -n libdbi-dbd-mysql
40This plugin provides connectivity to MySQL/MariaDB database servers through
41the libdbi database independent abstraction layer. Switching a program's
42plugin does not require recompilation or rewriting source code.
43
44%package -n libdbi-dbd-pgsql
45Summary: PostgreSQL plugin for libdbi
46Group: Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48
49%description -n libdbi-dbd-pgsql
50This plugin provides connectivity to PostgreSQL database servers through the
51libdbi database independent abstraction layer. Switching a program's plugin
52does not require recompilation or rewriting source code.
53
54%package -n libdbi-dbd-sqlite
55Summary: SQLite plugin for libdbi
56Group: Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58
59%description -n libdbi-dbd-sqlite
60This plugin provides access to an embedded SQL engine using libsqlite3 through
61the libdbi database independent abstraction layer. Switching a program's plugin
62does not require recompilation or rewriting source code.
63
64%prep
65%setup -q -n %{name}-%{version}
66%patch1 -p1
67autoconf
68# mariadb provides headers in a subfolder <mysql/mysql.h>
69sed -i -r 's|<(mysql\.h)>|<mysql/\1>|' drivers/mysql/dbd_mysql.c
70# exporting LDFLAGS or LIBS or SQLITE3_LIBS before running autoconf or
71#   ./configure doesn't help => hardcode it
72sed -i -r "s|(SQLITE3_LIBS=)-lsqlite[^[:space:]]*|\1$(pkg-config --libs-only-l sqlite3)|" \
73  configure
74
75%build
76# configure is broken, must pass both --with-*sql-libdir _AND_
77# --with-*sql-incdir in order for --with-*sql-libdir to be used
78%configure --with-mysql --with-pgsql --with-sqlite3 \
79        --with-mysql-libdir=%{_libdir}/mysql \
80        --with-mysql-incdir=%{_includedir} \
81        --with-pgsql-libdir=%{_libdir} \
82        --with-pgsql-incdir=%{_includedir}/pgsql \
83        --with-sqlite3-libdir=%{_libdir} \
84        --with-sqlite3-incdir=%{_includedir} \
85        --with-dbi-libdir=%{_libdir}
86
87make %{?_smp_mflags}
88
89%install
90make DESTDIR=$RPM_BUILD_ROOT install
91
92rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.a
93rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.la
94
95# package the docs via %%doc directives
96rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102%files
103%doc AUTHORS ChangeLog COPYING README
104%doc drivers/mysql/dbd_mysql/*.html
105%doc drivers/mysql/*.pdf
106%doc drivers/pgsql/dbd_pgsql/*.html
107%doc drivers/pgsql/*.pdf
108%doc drivers/sqlite3/dbd_sqlite3/*.html
109%doc drivers/sqlite3/*.pdf
110%dir %{_libdir}/dbd
111
112%files -n libdbi-dbd-mysql
113%{_libdir}/dbd/libdbdmysql.*
114
115%files -n libdbi-dbd-pgsql
116%{_libdir}/dbd/libdbdpgsql.*
117
118%files -n libdbi-dbd-sqlite
119%{_libdir}/dbd/libdbdsqlite3.*
120
121%changelog
122* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.0-1
123- initial build for Vine Linux based on fedora
124
125
126* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-3
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
128
129* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
131
132* Thu Jan 23 2014 Jan Pacner <jpacner@redhat.com> - 0.9.0-1
133- new release
134
135* Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> 0.8.3-13
136- Spec file clean-up
137- Add support for aarch64
138
139* Tue Mar  5 2013 Tom Lane <tgl@redhat.com> 0.8.3-12
140- Remove unnecessary package-name Requires:, since dependencies on library
141  sonames should be enough, and we don't want to hard-wire assumptions about
142  which packages provide which libraries
143- isa-ify cross-subpackage Requires:
144
145* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-11
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
147
148* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-10
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
150
151* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-9
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
153
154* Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 0.8.3-8
155- Rebuild for libmysqlclient 5.5.10 soname version bump
156
157* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
159
160* Fri Sep  3 2010 Tom Lane <tgl@redhat.com> 0.8.3-6
161- Do not use -ffast-math; it breaks things and seems quite unlikely to offer
162  any useful performance benefit for this type of package, anyway
163Resolves: #629964
164
165* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
167
168* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-4
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
170
171* Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 0.8.3-3
172- Rebuild for mysql 5.1
173
174* Mon Sep  1 2008 Tom Lane <tgl@redhat.com> 0.8.3-2
175- Fix mistaken external reference in libdbdsqlite3.so.  (I'm applying this
176  as a patch, rather than updating to upstream's 0.8.3-1, because that isn't
177  acceptable as an RPM Version tag.)
178Resolves: #460734
179
180* Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
181- Update to version 0.8.3.
182- Code is now all licensed LGPLv2+, so adjust License tags.
183
184* Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.3
185- Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
186Resolves: #330691
187
188* Fri Aug  3 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.2
189- Correct License tag for sqlite subpackage; it's currently not same license
190  as the rest of the code.
191
192* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.1
193- Update to version 0.8.2-1.
194- Update License tag to match code.
195- Remove static libraries and .la files, per packaging guidelines.
196- Fix up packaging of documentation.
197
198* Mon Dec 11 2006 Tom Lane <tgl@redhat.com> 0.8.1a-2
199- Enable building of sqlite driver
200Resolves: #184568
201- Rebuild needed anyway for Postgres library update
202
203* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.2
204- rebuild
205
206* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.1
207- bump again for double-long bug on ppc(64)
208
209* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2
210- rebuilt for new gcc4.1 snapshot and glibc changes
211
212* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
213- rebuilt
214
215* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1a-1
216- Update to version 0.8.1a.
217
218* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.7.1-3
219- Rebuild for Postgres 8.0.2 (new libpq major version).
220
221* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.1-2
222- Packaging improvements per discussion with sopwith.
223
224* Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.1-1
225- Import new libdbi version, splitting libdbi-drivers into a separate SRPM
226  so we can track new upstream packaging.
Note: See TracBrowser for help on using the repository browser.