source: projects/specs/trunk/lib/libd/libdbi-drivers/libdbi-drivers-vl.spec @ 12202

Revision 12202, 8.0 KB checked in by tomop, 5 years ago (diff)

updated gnucash and friends

Line 
1Summary: Database-specific drivers for libdbi
2Name: libdbi-drivers
3Version: 0.9.0
4Release: 2%{?_dist_release}
5Group: Development/Libraries
6License: LGPLv2+
7URL: http://libdbi-drivers.sourceforge.net/
8
9Vendor: Project Vine
10Distribution: Vine Linux
11
12Source: http://prdownloads.sourceforge.net/libdbi-drivers/%{name}-%{version}.tar.gz
13# old automake does not offer aarch64
14Patch1: libdbi-drivers-aarch64.patch
15
16Requires: libdbi >= 0.9
17BuildRequires: libdbi-devel >= 0.9
18BuildRequires: autoconf
19BuildRequires: openjade docbook-style-dsssl
20BuildRequires: docbook-style-dsssl
21
22BuildRequires: libmariadb-devel
23BuildRequires: openssl-devel
24BuildRequires: libpq-devel
25BuildRequires: krb5-devel
26BuildRequires: sqlite3-devel
27
28%description
29libdbi implements a database-independent abstraction layer in C, similar to the
30DBI/DBD layer in Perl. Writing one generic set of code, programmers can
31leverage the power of multiple databases and multiple simultaneous database
32connections by using this framework.
33
34libdbi-drivers contains the database-specific plugins needed to connect
35libdbi to particular database servers.
36
37%package -n libdbi-dbd-mysql
38Summary: MySQL plugin for libdbi
39Group: Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41
42%description -n libdbi-dbd-mysql
43This plugin provides connectivity to MySQL/MariaDB database servers through
44the libdbi database independent abstraction layer. Switching a program's
45plugin does not require recompilation or rewriting source code.
46
47%package -n libdbi-dbd-pgsql
48Summary: PostgreSQL plugin for libdbi
49Group: Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51
52%description -n libdbi-dbd-pgsql
53This plugin provides connectivity to PostgreSQL database servers through the
54libdbi database independent abstraction layer. Switching a program's plugin
55does not require recompilation or rewriting source code.
56
57%package -n libdbi-dbd-sqlite
58Summary: SQLite plugin for libdbi
59Group: Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61
62%description -n libdbi-dbd-sqlite
63This plugin provides access to an embedded SQL engine using libsqlite3 through
64the libdbi database independent abstraction layer. Switching a program's plugin
65does not require recompilation or rewriting source code.
66
67%prep
68%setup -q -n %{name}-%{version}
69%patch1 -p1
70autoconf
71# mariadb provides headers in a subfolder <mysql/mysql.h>
72sed -i -r 's|<(mysql\.h)>|<mysql/\1>|' drivers/mysql/dbd_mysql.c
73# exporting LDFLAGS or LIBS or SQLITE3_LIBS before running autoconf or
74#   ./configure doesn't help => hardcode it
75sed -i -r "s|(SQLITE3_LIBS=)-lsqlite[^[:space:]]*|\1$(pkg-config --libs-only-l sqlite3)|" \
76  configure
77
78%build
79# configure is broken, must pass both --with-*sql-libdir _AND_
80# --with-*sql-incdir in order for --with-*sql-libdir to be used
81%configure --with-mysql --with-pgsql --with-sqlite3 \
82        --with-mysql-libdir=%{_libdir}/mysql \
83        --with-mysql-incdir=%{_includedir} \
84        --with-pgsql-libdir=%{_libdir} \
85        --with-pgsql-incdir=%{_includedir}/pgsql \
86        --with-sqlite3-libdir=%{_libdir} \
87        --with-sqlite3-incdir=%{_includedir} \
88        --with-dbi-libdir=%{_libdir}
89
90make %{?_smp_mflags}
91
92%install
93make DESTDIR=$RPM_BUILD_ROOT install
94
95rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.a
96rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.la
97
98# package the docs via %%doc directives
99rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%license COPYING
107%doc AUTHORS ChangeLog README
108%doc drivers/mysql/dbd_mysql/*.html
109%doc drivers/mysql/*.pdf
110%doc drivers/pgsql/dbd_pgsql/*.html
111%doc drivers/pgsql/*.pdf
112%doc drivers/sqlite3/dbd_sqlite3/*.html
113%doc drivers/sqlite3/*.pdf
114%dir %{_libdir}/dbd
115
116%files -n libdbi-dbd-mysql
117%{_libdir}/dbd/libdbdmysql.*
118
119%files -n libdbi-dbd-pgsql
120%{_libdir}/dbd/libdbdpgsql.*
121
122%files -n libdbi-dbd-sqlite
123%{_libdir}/dbd/libdbdsqlite3.*
124
125%changelog
126* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.0-2
127- rebuilt with current environment.
128
129* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.0-1
130- initial build for Vine Linux based on fedora
131
132
133* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-3
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
135
136* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
138
139* Thu Jan 23 2014 Jan Pacner <jpacner@redhat.com> - 0.9.0-1
140- new release
141
142* Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> 0.8.3-13
143- Spec file clean-up
144- Add support for aarch64
145
146* Tue Mar  5 2013 Tom Lane <tgl@redhat.com> 0.8.3-12
147- Remove unnecessary package-name Requires:, since dependencies on library
148  sonames should be enough, and we don't want to hard-wire assumptions about
149  which packages provide which libraries
150- isa-ify cross-subpackage Requires:
151
152* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-11
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
154
155* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-10
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
157
158* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-9
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
160
161* Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 0.8.3-8
162- Rebuild for libmysqlclient 5.5.10 soname version bump
163
164* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
166
167* Fri Sep  3 2010 Tom Lane <tgl@redhat.com> 0.8.3-6
168- Do not use -ffast-math; it breaks things and seems quite unlikely to offer
169  any useful performance benefit for this type of package, anyway
170Resolves: #629964
171
172* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
174
175* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-4
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
177
178* Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 0.8.3-3
179- Rebuild for mysql 5.1
180
181* Mon Sep  1 2008 Tom Lane <tgl@redhat.com> 0.8.3-2
182- Fix mistaken external reference in libdbdsqlite3.so.  (I'm applying this
183  as a patch, rather than updating to upstream's 0.8.3-1, because that isn't
184  acceptable as an RPM Version tag.)
185Resolves: #460734
186
187* Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
188- Update to version 0.8.3.
189- Code is now all licensed LGPLv2+, so adjust License tags.
190
191* Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.3
192- Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
193Resolves: #330691
194
195* Fri Aug  3 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.2
196- Correct License tag for sqlite subpackage; it's currently not same license
197  as the rest of the code.
198
199* Thu Aug  2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.1
200- Update to version 0.8.2-1.
201- Update License tag to match code.
202- Remove static libraries and .la files, per packaging guidelines.
203- Fix up packaging of documentation.
204
205* Mon Dec 11 2006 Tom Lane <tgl@redhat.com> 0.8.1a-2
206- Enable building of sqlite driver
207Resolves: #184568
208- Rebuild needed anyway for Postgres library update
209
210* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.2
211- rebuild
212
213* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.1
214- bump again for double-long bug on ppc(64)
215
216* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2
217- rebuilt for new gcc4.1 snapshot and glibc changes
218
219* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
220- rebuilt
221
222* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1a-1
223- Update to version 0.8.1a.
224
225* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.7.1-3
226- Rebuild for Postgres 8.0.2 (new libpq major version).
227
228* Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.1-2
229- Packaging improvements per discussion with sopwith.
230
231* Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.1-1
232- Import new libdbi version, splitting libdbi-drivers into a separate SRPM
233  so we can track new upstream packaging.
Note: See TracBrowser for help on using the repository browser.