source: projects/specs/trunk/lib/libd/libdb/libdb-vl.spec @ 11295

Revision 11295, 23.8 KB checked in by tomop, 6 years ago (diff)

libdb-5.3.28-11

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define __soversion_major 5
4%define __soversion %{__soversion_major}.3
5
6%bcond_with java
7
8Summary: The Berkeley DB database library for C
9Summary(ja): C 言語用 Berkeley DB データベースライブラリ
10Name: libdb
11Version: 5.3.28
12Release: 11%{?_dist_release}
13Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
14Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
15# For mt19937db.c
16Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
17Patch0: libdb-multiarch.patch
18# db-1.85 upstream patches
19Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
20Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
21Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
22Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
23# other patches
24Patch20: db-1.85-errno.patch
25Patch22: db-4.6.21-1.85-compat.patch
26Patch24: db-4.5.20-jni-include-dir.patch
27# License clarification patch
28# http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
29Patch25: 007-mt19937db.c_license.patch
30#Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
31Patch26: java8-fix.patch
32# memp_stat fix provided by upstream (rhbz#1211871)
33Patch27: db-5.3.21-memp_stat-upstream-fix.patch
34# fix for mutexes not being released provided by upstream (rhbz#1277887)
35Patch28: db-5.3.21-mutex_leak.patch
36# fix for overflowing hash variable inside bundled lemon
37Patch29: db-5.3.28-lemon_hash.patch
38# upstream patch adding the ability to recreate libdb's environment on version mismatch
39# or when libpthread.so is modified (rhbz#1394862)
40Patch30: db-5.3.28-condition_variable.patch
41# additional changes to the upstream patch to address rhbz#1460003
42Patch31: db-5.3.28-condition-variable-ppc.patch
43# downstream patch that adds a check for rpm transaction lock in order to be able to update libdb
44# FIXME: remove when able
45Patch32: db-5.3.28-rpm-lock-check.patch
46# downstream patch to hotfix rhbz#1464033, sent upstream
47Patch33: db-5.3.28-cwd-db_config.patch
48Patch34: libdb-5.3.21-region-size-check.patch
49# Patch sent upstream
50Patch35: checkpoint-opd-deadlock.patch
51
52URL: http://www.oracle.com/database/berkeley-db/
53License: BSD and LGPLv2 and Sleepycat
54Group: System Environment/Libraries
55BuildRequires: perl libtool
56BuildRequires: tcl-devel >= 8.5.2-3
57%if %{with java}
58BuildRequires: java-devel >= 1:1.6.0
59%endif
60#BuildRequires: chrpath
61#Conflicts: filesystem < 3
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: tomop
66
67%description
68The Berkeley Database (Berkeley DB) is a programmatic toolkit that
69provides embedded database support for both traditional and
70client/server applications. The Berkeley DB includes B+tree, Extended
71Linear Hashing, Fixed and Variable-length record access methods,
72transactions, locking, logging, shared memory caching, and database
73recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
74used by many applications, including Python and Perl, so this should
75be installed on all systems.
76
77%package utils
78Summary: Command line tools for managing Berkeley DB databases
79Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
80Group: Applications/Databases
81Requires: %{name}%{?_isa} = %{version}-%{release}
82Obsoletes: db4-utils
83Provides: db4-utils
84
85%description utils
86The Berkeley Database (Berkeley DB) is a programmatic toolkit that
87provides embedded database support for both traditional and
88client/server applications. Berkeley DB includes B+tree, Extended
89Linear Hashing, Fixed and Variable-length record access methods,
90transactions, locking, logging, shared memory caching, and database
91recovery. DB supports C, C++, Java and Perl APIs.
92
93%package devel
94Summary: C development files for the Berkeley DB library
95Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
96Group: Development/Libraries
97Requires: %{name}%{?_isa} = %{version}-%{release}
98Obsoletes: db4-devel
99Provides: db4-devel
100
101%description devel
102The Berkeley Database (Berkeley DB) is a programmatic toolkit that
103provides embedded database support for both traditional and
104client/server applications. This package contains the header files
105and libraries for building programs which use the Berkeley DB.
106
107%package devel-doc
108Summary: C development documentation files for the Berkeley DB library
109Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
110Group: Documentation
111Requires: %{name} = %{version}-%{release}
112Requires: %{name}-devel = %{version}-%{release}
113BuildArch: noarch
114
115%description devel-doc
116The Berkeley Database (Berkeley DB) is a programmatic toolkit that
117provides embedded database support for both traditional and
118client/server applications. This package contains the documentation
119for building programs which use the Berkeley DB.
120
121%package devel-static
122Summary: Berkeley DB static libraries
123Summary(ja): Berkeley DB 静的ライブラリ
124Group: Development/Libraries
125Requires: %{name}-devel%{?_isa} = %{version}-%{release}
126
127%description devel-static
128The Berkeley Database (Berkeley DB) is a programmatic toolkit that
129provides embedded database support for both traditional and
130client/server applications. This package contains static libraries
131needed for applications that require static linking of
132Berkeley DB.
133
134%package cxx
135Summary: The Berkeley DB database library for C++
136Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
137Group: System Environment/Libraries
138Requires: %{name}%{?_isa} = %{version}-%{release}
139
140%description cxx
141The Berkeley Database (Berkeley DB) is a programmatic toolkit that
142provides embedded database support for both traditional and
143client/server applications. The Berkeley DB includes B+tree, Extended
144Linear Hashing, Fixed and Variable-length record access methods,
145transactions, locking, logging, shared memory caching, and database
146recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
147used by many applications, including Python and Perl, so this should
148be installed on all systems.
149
150%package cxx-devel
151Summary: C++ development files for the Berkeley DB library
152Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
153Group: Development/Libraries
154Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
155Requires: %{name}-devel%{?_isa} = %{version}-%{release}
156
157%description cxx-devel
158The Berkeley Database (Berkeley DB) is a programmatic toolkit that
159provides embedded database support for both traditional and
160client/server applications. This package contains the header files,
161libraries, and documentation for building programs which use the
162Berkeley DB in C++.
163
164%package tcl
165Summary: The Berkeley DB library for tcl
166Summary(ja): tcl 用 Berkeley DB データベースライブラリ
167Group: System Environment/Libraries
168Requires: %{name}%{?_isa} = %{version}-%{release}
169
170%description tcl
171The Berkeley Database (Berkeley DB) is a programmatic toolkit that
172provides embedded database support for both traditional and
173client/server applications. This package contains the libraries
174for building programs which use the Berkeley DB in Tcl.
175
176%package tcl-devel
177Summary: Development files for using the Berkeley DB with tcl
178Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
179Group: Development/Libraries
180Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
181
182%description tcl-devel
183The Berkeley Database (Berkeley DB) is a programmatic toolkit that
184provides embedded database support for both traditional and
185client/server applications. This package contains the libraries
186for building programs which use the Berkeley DB in Tcl.
187
188%package sql
189Summary: The Berkeley DB library for SQL
190Summary(ja): SQL 用 Berkeley DB データベースライブラリ
191Group: System Environment/Libraries
192Requires: %{name}%{?_isa} = %{version}-%{release}
193
194%description sql
195The Berkeley Database (Berkeley DB) is a programmatic toolkit that
196provides embedded database support for both traditional and
197client/server applications. This package contains the libraries
198for building programs which use the Berkeley DB in SQL.
199
200%package sql-devel
201Summary: Development files for using the Berkeley DB with sql
202Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
203Group: Development/Libraries
204Requires: %{name}-sql%{?_isa} = %{version}-%{release}
205
206%description sql-devel
207The Berkeley Database (Berkeley DB) is a programmatic toolkit that
208provides embedded database support for both traditional and
209client/server applications. This package contains the libraries
210for building programs which use the Berkeley DB in SQL.
211
212%if %{with java}
213%package java
214Summary: The Berkeley DB library for Java
215Summary(ja): Java 用 Berkeley DB データベースライブラリ
216Group: System Environment/Libraries
217Requires: %{name}%{?_isa} = %{version}-%{release}
218
219%description java
220The Berkeley Database (Berkeley DB) is a programmatic toolkit that
221provides embedded database support for both traditional and
222client/server applications. This package contains the libraries
223for building programs which use the Berkeley DB in Java.
224
225%package java-devel
226Summary: Development files for using the Berkeley DB with Java
227Summary(ja): Java で Berkeley DB を利用するための開発ファイル
228Group: Development/Libraries
229Requires: %{name}-java%{?_isa} = %{version}-%{release}
230
231%description java-devel
232The Berkeley Database (Berkeley DB) is a programmatic toolkit that
233provides embedded database support for both traditional and
234client/server applications. This package contains the libraries
235for building programs which use the Berkeley DB in Java.
236%endif
237
238# compat32
239%package -n compat32-%{name}
240Summary: The Berkeley DB database library for C
241Summary(ja): C 言語用 Berkeley DB データベースライブラリ
242Group: System Environment/Libraries
243Requires: libdb = %{version}-%{release}
244
245%description -n compat32-%{name}
246The Berkeley Database (Berkeley DB) is a programmatic toolkit that
247provides embedded database support for both traditional and
248client/server applications. The Berkeley DB includes B+tree, Extended
249Linear Hashing, Fixed and Variable-length record access methods,
250transactions, locking, logging, shared memory caching, and database
251recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
252used by many applications, including Python and Perl, so this should
253be installed on all systems.
254
255%package -n compat32-%{name}-cxx
256Summary: The Berkeley DB database library for C++
257Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
258Group: System Environment/Libraries
259Requires: %{name}-cxx = %{version}-%{release}
260Requires: compat32-%{name} = %{version}-%{release}
261
262%description -n compat32-%{name}-cxx
263The Berkeley Database (Berkeley DB) is a programmatic toolkit that
264provides embedded database support for both traditional and
265client/server applications. The Berkeley DB includes B+tree, Extended
266Linear Hashing, Fixed and Variable-length record access methods,
267transactions, locking, logging, shared memory caching, and database
268recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
269used by many applications, including Python and Perl, so this should
270be installed on all systems.
271
272%package -n compat32-%{name}-devel
273Summary: C development files for the Berkeley DB library
274Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
275Group: Development/Libraries
276Requires: compat32-%{name} = %{version}-%{release}
277Requires: %{name}-devel    = %{version}-%{release}
278Obsoletes: compat32-db4-devel
279Provides: compat32-db4-devel
280
281%description -n compat32-%{name}-devel
282The Berkeley Database (Berkeley DB) is a programmatic toolkit that
283provides embedded database support for both traditional and
284client/server applications. This package contains the header files,
285libraries, and documentation for building programs which use the
286Berkeley DB.
287
288
289%prep
290%setup -q -n db-%{version} -a 1
291cp %{SOURCE2} .
292
293%patch0 -p1 -b .multiarch
294pushd db.1.85/PORT/linux
295%patch10 -p0 -b .1.1
296popd
297pushd db.1.85
298%patch11 -p0 -b .1.2
299%patch12 -p0 -b .1.3
300%patch13 -p0 -b .1.4
301%patch20 -p1 -b .errno
302popd
303
304%patch22 -p1 -b .185compat
305%patch24 -p1 -b .4.5.20.jni
306%patch25 -p1 -b .licensefix
307%patch26 -p1 -b .java8-fix
308%patch27 -p1 -b .memp_stat-fix
309%patch28 -p1
310%patch29 -p1
311%patch30 -p1
312%patch31 -p1
313%patch32 -p1
314%patch33 -p1
315%patch34 -p1
316%patch35 -p1
317
318cd dist
319./s_config
320cd ..
321
322%build
323CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
324CFLAGS="$CFLAGS -DSHAREDSTATEDIR='\"%{_sharedstatedir}\"' -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
325export CFLAGS
326
327# Build the old db-185 libraries.
328make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
329
330test -d dist/dist-tls || mkdir dist/dist-tls
331# Static link db_dump185 with old db-185 libraries.
332/bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
333/bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
334
335# Update config files to understand aarch64
336#for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
337#  cp /usr/lib/rpm/config.{guess,sub} "$dir"
338#done
339
340pushd dist/dist-tls
341%define _configure ../configure
342%configure -C \
343        --enable-compat185 \
344        --enable-dump185 \
345        --enable-shared \
346        --enable-static \
347        --enable-tcl \
348        --with-tcl=%{_libdir} \
349        --enable-cxx \
350        --enable-sql \
351        --enable-test \
352        --disable-rpath \
353        --with-tcl=%{_libdir}/tcl8.5 \
354%if %{with java}
355        --enable-java
356%endif
357
358# Remove libtool predep_objects and postdep_objects wonkiness so that
359# building without -nostdlib doesn't include them twice.  Because we
360# already link with g++, weird stuff happens if you don't let the
361# compiler handle this.
362perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
363perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
364perl -pi -e 's/-shared -nostdlib/-shared/' libtool
365
366make %{?_smp_mflags}
367
368%if %{with java}
369# XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
370LDBJ=./.libs/libdb_java-%{__soversion}.la
371if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
372        sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
373fi
374%endif
375
376popd
377
378%install
379rm -rf ${RPM_BUILD_ROOT}
380mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
381mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
382
383%makeinstall STRIP=/bin/true -C dist/dist-tls
384
385# XXX Nuke non-versioned archives and symlinks
386rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
387
388chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
389
390# Move the header files to a subdirectory, in case we're deploying on a
391# system with multiple versions of DB installed.
392mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
393mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
394
395# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
396for i in db.h db_cxx.h db_185.h; do
397        ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
398done
399
400%if %{with java}
401# Move java jar file to the correct place
402mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
403mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
404%endif
405
406# Eliminate installed doco
407rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
408
409# XXX Avoid Permission denied. strip when building as non-root.
410chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
411
412# remove unneeded .la files (#225675)
413rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
414
415# remove RPATHs
416#chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
417
418# unify documentation and examples, remove stuff we don't need
419rm -rf docs/csharp
420rm -rf examples/csharp
421rm -rf docs/installation
422mv examples docs
423
424%clean
425rm -rf ${RPM_BUILD_ROOT}
426
427%post -p /sbin/ldconfig
428
429%postun -p /sbin/ldconfig
430
431%post cxx -p /sbin/ldconfig
432
433%postun cxx -p /sbin/ldconfig
434
435%post sql -p /sbin/ldconfig
436
437%postun sql -p /sbin/ldconfig
438
439%post tcl -p /sbin/ldconfig
440
441%postun tcl -p /sbin/ldconfig
442
443%if %{with java}
444%post java -p /sbin/ldconfig
445
446%postun java -p /sbin/ldconfig
447
448%endif
449
450
451%if %{build_compat32}
452%post -n compat32-%{name} -p /sbin/ldconfig
453
454%postun -n compat32-%{name} -p /sbin/ldconfig
455
456%post -n compat32-%{name}-cxx -p /sbin/ldconfig
457
458%postun -n compat32-%{name}-cxx -p /sbin/ldconfig
459
460%endif
461
462%files
463%defattr(-,root,root,-)
464%doc LICENSE README lgpl-2.1.txt
465%{_libdir}/libdb-%{__soversion}.so
466%{_libdir}/libdb-%{__soversion_major}.so
467
468%files devel
469%defattr(-,root,root,-)
470%{_libdir}/libdb.so
471%dir %{_includedir}/%{name}
472%{_includedir}/%{name}/db.h
473%{_includedir}/%{name}/db_185.h
474%{_includedir}/db.h
475%{_includedir}/db_185.h
476
477%files devel-doc
478%defattr(-,root,root,-)
479%doc    docs/*
480
481%files devel-static
482%defattr(-,root,root,-)
483%{_libdir}/libdb-%{__soversion}.a
484%{_libdir}/libdb_cxx-%{__soversion}.a
485%{_libdir}/libdb_tcl-%{__soversion}.a
486%{_libdir}/libdb_sql-%{__soversion}.a
487%if %{with java}
488%{_libdir}/libdb_java-%{__soversion}.a
489%endif
490
491%files utils
492%defattr(-,root,root,-)
493%{_bindir}/db*_archive
494%{_bindir}/db*_checkpoint
495%{_bindir}/db*_deadlock
496%{_bindir}/db*_dump*
497%{_bindir}/db*_hotbackup
498%{_bindir}/db*_load
499%{_bindir}/db*_printlog
500%{_bindir}/db*_recover
501%{_bindir}/db*_replicate
502%{_bindir}/db*_stat
503%{_bindir}/db*_upgrade
504%{_bindir}/db*_verify
505%{_bindir}/db*_tuner
506
507%files cxx
508%defattr(-,root,root,-)
509%{_libdir}/libdb_cxx-%{__soversion}.so
510%{_libdir}/libdb_cxx-%{__soversion_major}.so
511
512%files cxx-devel
513%defattr(-,root,root,-)
514%{_includedir}/%{name}/db_cxx.h
515%{_includedir}/db_cxx.h
516%{_libdir}/libdb_cxx.so
517
518%files tcl
519%defattr(-,root,root,-)
520%{_libdir}/libdb_tcl-%{__soversion}.so
521%{_libdir}/libdb_tcl-%{__soversion_major}.so
522
523%files tcl-devel
524%defattr(-,root,root,-)
525%{_libdir}/libdb_tcl.so
526
527%files sql
528%defattr(-,root,root,-)
529%{_libdir}/libdb_sql-%{__soversion}.so
530%{_libdir}/libdb_sql-%{__soversion_major}.so
531
532%files sql-devel
533%defattr(-,root,root,-)
534%{_bindir}/dbsql
535%{_libdir}/libdb_sql.so
536%{_includedir}/%{name}/dbsql.h
537
538%if %{with java}
539%files java
540%defattr(-,root,root,-)
541%{_libdir}/libdb_java-%{__soversion_major}*.so
542%{_datadir}/java/*.jar
543
544%files java-devel
545%defattr(-,root,root,-)
546%{_libdir}/libdb_java.so
547%endif
548
549%if %{build_compat32}
550%files -n compat32-%{name}
551%defattr(-,root,root)
552%{_libdir}/libdb-%{__soversion}.so
553%{_libdir}/libdb-%{__soversion_major}.so
554
555%files -n compat32-%{name}-cxx
556%defattr(-,root,root)
557%{_libdir}/libdb_cxx-%{__soversion}.so
558%{_libdir}/libdb_cxx-%{__soversion_major}.so
559
560%files -n compat32-%{name}-devel
561%defattr(-,root,root)
562%{_libdir}/libdb.so
563%endif
564
565%changelog
566* Fri Dec 22 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-11
567- added Patch28-15.
568
569* Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-10
570- rebuilt with new toolchain.
571
572* Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
573- added Patch27.
574
575* Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
576- added compat32 subpackages
577
578* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
579- updated Summary and Group
580
581* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
582- added "Provides: db4-{utils,devel}".
583
584* Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
585- initial build for Vine Linux.
586
587* Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
588- Add some of the previous aarch64 bits back as the sub configure don't use the macro
589
590* Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
591- Fix configure macro usage for better aarch64 build fix
592
593* Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
594- Updated config files to allow build on aarch64 (#1022970)
595
596* Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
597- Added Sleepycat to the license list (#1013841)
598- Updated to 5.3.28 (#1013233)
599
600* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
601- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
602
603* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
604- add copy of lgpl-2.1.txt
605
606* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
607- Fix missing debuginfo issue for utils subpackage
608
609* Thu May  9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
610- add license clarification fix
611
612* Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
613- Added sqlite compability CFLAGS (#788496)
614
615* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
616- Cleaning the specfile - removed gcc-java dependecy other way
617
618* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
619- Removed dependency on obsolete gcc-java package (#927742)
620
621* Thu Mar  7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
622- add LGPLv2+ and remove Sleepycat in license tag (#886838)
623
624* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
625- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
626
627* Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
628- fix license tag
629
630* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
631- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
632
633* Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
634- Specify tag for libtool (fixes FTBFS # 838334 )
635
636* Thu Jul  5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
637- update to 5.3.21
638http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
639
640* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
641- move C++ header files to cxx-devel
642
643* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
644- fix -devel packages dependencies yet more (#832225)
645
646* Sun May  6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
647- package -devel packages correctly
648
649* Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
650- fix multiarch conflict in libdb-devel (#812901)
651- remove unneeded dos2unix BR
652
653* Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
654- update to 5.3.15
655  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
656
657* Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
658- Resolves rhbz#794472
659- Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
660
661* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
662- add filesystem guard
663
664* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
665- install everything in /usr
666  https://fedoraproject.org/wiki/Features/UsrMove
667
668* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
669- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
670
671* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
672- update to 5.2.36,
673  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
674
675* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
676- move development documentation to devel-doc subpackage (#705386)
677
678* Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
679- update to 5.2.28
680
681* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
682- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
683
684* Thu Feb  3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
685- update to 5.1.25
686
687* Wed Sep 29 2010 jkeating - 5.1.19-2
688- Rebuilt for gcc bug 634757
689
690* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
691- update to 5.1.19
692- rename -devel-static to -static subpackage (#617800)
693- build java on all arches
694
695* Wed Jul  7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
696- update to 5.0.26
697- drop BR: ed
698
699* Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
700- add Requires: libdb-cxx to libdb-devel
701
702* Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
703- initial build
704
705* Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
706- remove C# documentation
707- disable/remove rpath
708- fix description
709- tighten dependencies
710- run ldconfig for cxx and sql subpackages
711
712* Fri Apr  9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
713- enable sql
714- package 5.0.21
Note: See TracBrowser for help on using the repository browser.