source: projects/specs/trunk/lib/libd/libdatrie/libdatrie-vl.spec @ 9791

Revision 9791, 4.1 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Double-Array Trie Library
4Name:           libdatrie
5Version:        0.2.10
6Release:        1%{?_dist_release}
7Source0:        http://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.xz
8License:        GPLv2
9Group:          System Environment/Libraries
10URL:            http://linux.thai.net/~thep/datrie/datrie.html
11
12BuildRequires:  doxygen
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Packager:       Takemikaduchi
19
20
21%description
22This is an implementation of double-array structure for representing trie,
23as proposed by Junichi Aoe.
24
25Trie is a kind of digital search tree, an efficient indexing method with
26O(1) time complexity for searching. Comparably as efficient as hashing,
27trie also provides flexibility on incremental matching and key spelling
28manipulation. This makes it ideal for lexical analyzers, as well as spelling
29dictionaries.
30
31
32%package                devel
33Summary:        Development tools for libdatrie
34Summary(ja):    libdatrie の開発環境
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       pkgconfig
38
39%description    devel
40Header files and libraries for building a extension library for the
41libdatrie.
42
43
44%package        docs
45Summary:        Documentation for libdatrie
46Summary(ja):    libdatrie 用のドキュメント
47Group:          Documentation
48Requires:       %{name} = %{version}-%{release}
49BuildArch:      noarch
50Provides:       %{name}-doc = %{version}-%{release}
51
52%description    docs
53This package contains documentation for libdatrie
54
55
56# compat32
57%package -n compat32-%{name}
58Summary:        Double-Array Trie Library
59Group:          System Environment/Libraries
60Requires:       %{name} = %{version}-%{release}
61
62%description -n compat32-%{name}
63This is an implementation of double-array structure for representing trie,
64as proposed by Junichi Aoe.
65
66Trie is a kind of digital search tree, an efficient indexing method with
67O(1) time complexity for searching. Comparably as efficient as hashing,
68trie also provides flexibility on incremental matching and key spelling
69manipulation. This makes it ideal for lexical analyzers, as well as spelling
70dictionaries.
71
72
73%package -n compat32-%{name}-devel
74Summary:        Development tools for libdatrie
75Summary(ja):    libdatrie の開発環境
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}-%{release}
78Requires:       pkgconfig
79
80%description -n compat32-%{name}-devel
81Header files and libraries for building a extension library for the
82libdatrie.
83
84
85%prep
86%setup -q
87
88
89%build
90%configure \
91        --disable-static
92
93%{__make} %{?_smp_mflags}
94
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%{__make} install DESTDIR=${RPM_BUILD_ROOT}
99
100find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
101find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
102
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107%post -p /sbin/ldconfig
108
109%postun -p /sbin/ldconfig
110
111%post -n compat32-%{name} -p /sbin/ldconfig
112
113%postun -n compat32-%{name} -p /sbin/ldconfig
114
115
116%files
117%defattr(-,root,root,-)
118%doc COPYING ChangeLog NEWS README
119%{_bindir}/trietool
120%{_bindir}/trietool-0.2
121%{_libdir}/%{name}.so.*
122%{_mandir}/man1/*.gz
123
124%files devel
125%defattr(-,root,root,-)
126%{_includedir}/datrie
127%{_libdir}/%{name}.so
128%{_libdir}/pkgconfig/datrie-0.2.pc
129
130%files docs
131%defattr(-,root,root,-)
132%{_docdir}/%{name}/README.migration
133%{_docdir}/datrie/html
134
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr(-, root, root,-)
138%{_libdir}/%{name}.so.*
139
140%files -n compat32-%{name}-devel
141%defattr(-, root, root,-)
142%{_libdir}/%{name}.so
143%endif
144
145
146%changelog
147* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.10-1
148- new upstream release
149
150* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.8-1
151- new upstream release
152
153* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.7.1-1
154- new upstream release
155
156* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.6-1
157- update to 0.2.6
158
159* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-2
160- remove *.pc from compat32-%{name}-devel
161- fix typo
162
163* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-1
164- initial build for Vine Linux
165
Note: See TracBrowser for help on using the repository browser.