source: projects/specs/trunk/lib/libd/libdatrie/libdatrie-vl.spec @ 5353

Revision 5353, 3.5 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: libdatrie, libthai
pango: rebuild with libthai

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Double-Array Trie Library
4Name:           libdatrie
5Version:        0.2.5
6Release:        1%{?_dist_release}
7Source0:        http://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.gz
8License:        GPLv2
9Group:          System Environment/Libraries
10URL:            http://linux.thai.net/~thep/datrie/datrie.html
11
12BuildRequires:  doxygen
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Packager:       Takemikaduchi
19
20
21%description
22This is an implementation of double-array structure for representing trie,
23as proposed by Junichi Aoe.
24
25Trie is a kind of digital search tree, an efficient indexing method with
26O(1) time complexity for searching. Comparably as efficient as hashing,
27trie also provides flexibility on incremental matching and key spelling
28manipulation. This makes it ideal for lexical analyzers, as well as spelling
29dictionaries.
30
31
32%package        devel
33Summary:        Development tools for libdatrie
34Summary(ja):    libdatrie の開発環境
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       pkgconfig
38
39%description    devel
40Header files and libraries for building a extension library for the
41libdatrie.
42
43
44%package        doc
45Summary:        Documentation for libdatrie
46Summary(ja):    libdatrie 用のドキュメント
47Group:          Documentation
48Requires:       %{name} = %{version}-%{release}
49BuildArch:      noarch
50
51%description    doc
52This package contains documentation for libdatrie
53
54
55# compat32
56%package -n compat32-%{name}
57Summary:        Double-Array Trie Library
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}-%{release}
60
61%description -n compat32-%{name}
62This is an implementation of double-array structure for representing trie,
63as proposed by Junichi Aoe.
64
65Trie is a kind of digital search tree, an efficient indexing method with
66O(1) time complexity for searching. Comparably as efficient as hashing,
67trie also provides flexibility on incremental matching and key spelling
68manipulation. This makes it ideal for lexical analyzers, as well as spelling
69dictionaries.
70
71
72%package -n compat32-%{name}-devel
73Summary:        Development tools for libdatrie
74Summary(ja):    libdatrie の開発環境
75Group:          Development/Libraries
76Requires:       compat32-%{name} = %{version}-%{release}
77Requires:       pkgconfig
78
79%description -n compat32-%{name}-devel
80Header files and libraries for building a extension library for the
81libdatrie.
82
83
84%prep
85%setup -q
86
87
88%build
89%configure \
90        --disable-static
91
92%{__make} %{?_smp_mflags}
93
94
95%install
96%{__rm} -rf ${RPM_BUILD_ROOT}
97%{__make} install DESTDIR=${RPM_BUILD_ROOT}
98
99find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
100find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
101
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110
111%files
112%defattr(-,root,root,-)
113%doc COPYING ChangeLog NEWS README
114%{_bindir}/trietool-0.2
115%{_libdir}/%{name}.so.*
116%{_mandir}/man1/*.gz
117
118%files devel
119%defattr(-,root,root,-)
120%{_includedir}/datrie
121%{_libdir}/%{name}.so
122%{_libdir}/pkgconfig/datrie-0.2.pc
123
124%files doc
125%defattr(-,root,root,-)
126%{_docdir}/%{name}/README.migration
127%{_docdir}/datrie
128
129%if %{build_compat32}
130%files -n compat32-%{name}
131%defattr(-, root, root,-)
132%{_libdir}/%{name}.so.*
133
134%files -n compat32-%{name}-devel
135%defattr(-, root, root,-)
136%{_libdir}/%{name}.so
137%{_libdir}/pkgconfig/datrie-0.2.pc
138%endif
139
140
141%changelog
142* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.16-1
143- initial build for Vine Linux
144
Note: See TracBrowser for help on using the repository browser.