source: projects/specs/trunk/lib/libc/libcxp/libcxp-vl.spec @ 1901

Revision 1901, 3.4 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define name libcxp
2%define version 0.5.6
3%define release 2%{?_dist_release}
4
5Name: %{name}
6Summary: libcxp is the base library of cxp application family.
7Version: %{version}
8Release: %{release}
9Source: %{name}-%{version}.tar.gz
10Group: System Environment/Libraries
11URL: http://cxplorer.sourceforge.jp/
12BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
13License: GPL
14Requires: gtk2 GConf2 shared-mime-info
15BuildRequires: gtk2-devel GConf2-devel shared-mime-info
16
17Summary(ja): libcxp は cxp アプリケーションファミリのベースライブラリです。
18
19%description
20libcxp is the base library of cxp application family. But, cxplorer is only
21applicaiton which is developped as cxp family yet.
22
23%description -l ja
24 libcxpは、cxpアプリケーションファミリのベースライブラリです。しかし、まだ
25cxp familyとして開発されているのはcxplorerのみです。
26
27%package devel
28Summary:        Libraries and include files for libcxp.
29Group:          Development/Libraries
30Requires:       %{name} = %{version}
31Summary(ja):    libcxpのライブラリとインクルードファイル
32
33%description devel
34Libraries and header files if you want to make use of the libcxp library in your
35own programs.
36
37%description -l ja devel
38libcxpライブラリを利用したプログラムを作成するのに必要なライブラリとヘッダファイル
39
40%prep
41rm -rf $RPM_BUILD_ROOT
42
43%setup -q -n %{name}-%{version}
44%build
45%configure
46
47make
48
49%install
50export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
51%makeinstall
52unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
53
54%{find_lang} %{name}
55
56%post
57export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
58gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/libcxp.schemas > /dev/null
59/sbin/ldconfig
60
61%preun
62if [ $1 = 0 ]; then
63        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
64        gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/libcxp.schemas > /dev/null
65fi
66
67%postun
68/sbin/ldconfig
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files -f %{name}.lang
75%defattr(-,root,root)
76%doc AUTHORS COPYING ChangeLog INSTALL README NEWS
77%{_libdir}/libcxp.so.*
78%{_datadir}/pixmaps/cxp
79%{_sysconfdir}/gconf/schemas/libcxp.schemas
80
81%files devel
82%defattr (-, root, root)
83/usr/include/cxp
84%{_libdir}/libcxp.so
85%{_libdir}/libcxp.a
86%{_libdir}/pkgconfig/libcxp.pc
87
88%changelog
89* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.6-2
90- rebuild with rpm-4.8.1 for pkg-config file
91
92* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.6-1vl5
93- applied new versioning policy, spec in utf-8
94
95* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.5.6-0vl2
96- changed Group to System Environment/Libraries
97- added /sbin/ldconfig to %post and %postun section
98
99* Fri Dec 30 2005 Yasumichi Akahoshi <yasumichi@vinelinux.org>
100- 0.5.6-0vl1
101- version update(upstream)
102- devide devel sub package.
103
104* Wed Oct 12 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
105- 0.5.5-0vl1
106- version update(upstream)
107
108* Wed Oct 05 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
109- version update(upstream)
110
111* Thu Sep 08 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
112- version update(upstream)
113
114* Mon Sep 05 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
115- 0.5.0-0vl1
116- version update(upstream)
117- add script related gconf.
118
119* Thu May 19 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
120- 0.4.2-0vl1
121- revision update(upstream)
122- 0.4.2-0vl2
123- fix GROUP
124
125* Wed May 11 2005 Yasumichi Akahoshi <w2linux@lapis.plala.or.jp>
126- 0.4.1-0vl1
127- First release
Note: See TracBrowser for help on using the repository browser.