source: projects/specs/trunk/lib/libc/libcrystalhd/libcrystalhd-vl.spec @ 5397

Revision 5397, 5.4 KB checked in by munepi, 12 years ago (diff)

updated libcrystalhd-vl.spec: applied libcrystalhd-3.5.1-define-first.patch and libcrystalhd-3.5.1-gcc46.patch

Line 
1Summary:        Broadcom Crystal HD device interface library
2Name:           libcrystalhd
3Version:        3.5.1
4Release:        3%{?_dist_release}
5License:        LGPLv2
6Group:          System Environment/Libraries
7#Source:         http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
8# This tarball and README are inside the above zip file...
9Source0:        crystalhd_07032010.tbz2
10Source1:        README_07032010
11# We're going to use even newer firmware for now
12Source2:        bcm70012fw.bin
13Source3:        bcm70015fw.bin
14# LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
15Source4:        LICENSE
16Requires:       crystalhd-firmware
17URL:            http://www.broadcom.com/support/crystal_hd/
18# Patch generated from http://git.wilsonet.com/crystalhd.git/
19Patch0:         libcrystalhd-updates.patch
20# patch for ppc
21Patch1:         libcrystalhd-ppc.patch
22# patch for gcc4.6 based on
23# http://git.wilsonet.com/?p=crystalhd.git;a=patch;h=dd4f01a0f9861425406c9ead7e326324d525d19a
24Patch10:        libcrystalhd-3.5.1-gcc46.patch
25# fix building failures
26Patch11:        libcrystalhd-3.5.1-define-first.patch
27ExcludeArch:    s390 s390x
28BuildRequires:  autoconf automake
29
30%description
31The libcrystalhd library provides userspace access to Broadcom Crystal HD
32video decoder devices. The device supports hardware decoding of MPEG-2,
33h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
34bcm970012 hardware, and up to 1080p at 60fps for the second-generation
35bcm970015 hardware.
36
37%package devel
38Summary:       Development libs for libcrystalhd
39Group:         Development/Libraries
40Requires:      %{name} = %{version}-%{release}
41
42%description devel
43Development libraries needed to build applications against libcrystalhd.
44
45%package -n crystalhd-firmware
46Summary:       Firmware for the Broadcom Crystal HD video decoder
47License:       Redistributable, no modification permitted
48BuildArch:     noarch
49Group:         System Environment/Kernel
50Requires:      %{name} = %{version}-%{release}
51
52%description -n crystalhd-firmware
53Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
54video decoders.
55
56%define        majorminor 0.10
57%define        _gst 0.10.30
58%define        _gstpb 0.10.30
59
60%package -n gstreamer-plugin-crystalhd
61Summary:       Gstreamer crystalhd decoder plugin
62Group:         Applications/Multimedia
63Requires:      %{name} = %{version}-%{release}
64Requires:      gstreamer-plugins-base
65BuildRequires: gstreamer-devel >= %{_gst}
66BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
67
68%description -n gstreamer-plugin-crystalhd
69Gstreamer crystalhd decoder plugin
70
71%prep
72%setup -q -n 07032010
73%patch0 -p1 -b .git
74%ifarch ppc
75%patch1 -p1 -b .ppc
76%endif
77
78%patch10 -p1 -b .gcc46
79%patch11 -p1 -b .boolian
80
81cp %{SOURCE1} %{SOURCE4} .
82
83%build
84pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
85# FIXME: this doesn't work just yet...
86#make CPPFLAGS="%{optflags}" %{?_smp_mflags}
87make %{?_smp_mflags}
88popd > /dev/null 2>&1
89pushd filters/gst/gst-plugin/ > /dev/null 2>&1
90%configure
91make %{?_smp_mflags}
92popd > /dev/null 2>&1
93
94%install
95rm -rf $RPM_BUILD_ROOT
96pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
97make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
98popd > /dev/null 2>&1
99pushd filters/gst/gst-plugin/ > /dev/null 2>&1
100make install DESTDIR=$RPM_BUILD_ROOT
101rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
102popd > /dev/null 2>&1
103cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
104cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(-,root,root,0755)
115%doc README_07032010 LICENSE
116%{_libdir}/libcrystalhd.so.*
117
118%files devel
119%defattr(-,root,root,0755)
120%dir %{_includedir}/libcrystalhd
121%{_includedir}/libcrystalhd/*
122%{_libdir}/libcrystalhd.so
123
124%files -n crystalhd-firmware
125%defattr(-,root,root,0755)
126%doc LICENSE
127/lib/firmware/bcm70012fw.bin
128/lib/firmware/bcm70015fw.bin
129
130%files -n gstreamer-plugin-crystalhd
131%defattr(-,root,root,0755)
132%{_libdir}/gstreamer-%{majorminor}/*.so
133
134
135%changelog
136* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.5.1-3
137- applied libcrystalhd-3.5.1-define-first.patch
138
139* Sun May 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.1-2
140- add Patch1 for ppc (libcrystalhd-ppc.patch)
141
142* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
143- initial build based on Fedora rawhide
144
145* Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
146- Update to v3.5.1, now with nv12 support
147
148* Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
149- Tarball had object files in it, clean them out before building
150
151* Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
152- Rebase to 07032010 crystalhd sources
153- Large version-bump as driver and lib are now essentially 100%
154  in sync with the Windows driver and lib
155- Ship firmware, now that Broadcom has posted a redistribution,
156  no modification license to cover it
157- Build the gstreamer decoder plugin (will be moved to its own
158  package sooner or later)
159
160* Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
161- Fix segfault on firmware upload
162
163* Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
164- Update to pre-0.9.26 libcrystalhd, which contains support
165  for the new Broadcom BCM970015 Crystal HD decoder card
166
167* Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
168- Minor fixups to the as-yet-not-enabled firmware sub-package
169
170* Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
171- Initial package
Note: See TracBrowser for help on using the repository browser.