source: projects/specs/trunk/lib/libc/libcrystalhd/libcrystalhd-vl.spec @ 2723

Revision 2723, 4.8 KB checked in by munepi, 13 years ago (diff)

added libcrystalhd-vl.spec

Line 
1Summary:        Broadcom Crystal HD device interface library
2Name:           libcrystalhd
3Version:        3.5.1
4Release:        1%{?_dist_release}
5License:        LGPLv2
6Group:          System Environment/Libraries
7#Source:         http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
8# This tarball and README are inside the above zip file...
9Source0:        crystalhd_07032010.tbz2
10Source1:        README_07032010
11# We're going to use even newer firmware for now
12Source2:        bcm70012fw.bin
13Source3:        bcm70015fw.bin
14# LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
15Source4:        LICENSE
16Requires:       crystalhd-firmware
17URL:            http://www.broadcom.com/support/crystal_hd/
18# Patch generated from http://git.wilsonet.com/crystalhd.git/
19Patch0:         libcrystalhd-updates.patch
20ExcludeArch:    s390 s390x
21BuildRequires:  autoconf automake
22
23%description
24The libcrystalhd library provides userspace access to Broadcom Crystal HD
25video decoder devices. The device supports hardware decoding of MPEG-2,
26h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
27bcm970012 hardware, and up to 1080p at 60fps for the second-generation
28bcm970015 hardware.
29
30%package devel
31Summary:       Development libs for libcrystalhd
32Group:         Development/Libraries
33Requires:      %{name} = %{version}-%{release}
34
35%description devel
36Development libraries needed to build applications against libcrystalhd.
37
38%package -n crystalhd-firmware
39Summary:       Firmware for the Broadcom Crystal HD video decoder
40License:       Redistributable, no modification permitted
41BuildArch:     noarch
42Group:         System Environment/Kernel
43Requires:      %{name} = %{version}-%{release}
44
45%description -n crystalhd-firmware
46Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
47video decoders.
48
49%define        majorminor 0.10
50%define        _gst 0.10.30
51%define        _gstpb 0.10.30
52
53%package -n gstreamer-plugin-crystalhd
54Summary:       Gstreamer crystalhd decoder plugin
55Group:         Applications/Multimedia
56Requires:      %{name} = %{version}-%{release}
57Requires:      gstreamer-plugins-base
58BuildRequires: gstreamer-devel >= %{_gst}
59BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
60
61%description -n gstreamer-plugin-crystalhd
62Gstreamer crystalhd decoder plugin
63
64%prep
65%setup -q -n 07032010
66%patch0 -p1
67cp %{SOURCE1} %{SOURCE4} .
68
69%build
70pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
71# FIXME: this doesn't work just yet...
72#make CPPFLAGS="%{optflags}" %{?_smp_mflags}
73make %{?_smp_mflags}
74popd > /dev/null 2>&1
75pushd filters/gst/gst-plugin/ > /dev/null 2>&1
76%configure
77make %{?_smp_mflags}
78popd > /dev/null 2>&1
79
80%install
81rm -rf $RPM_BUILD_ROOT
82pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
83make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
84popd > /dev/null 2>&1
85pushd filters/gst/gst-plugin/ > /dev/null 2>&1
86make install DESTDIR=$RPM_BUILD_ROOT
87rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
88popd > /dev/null 2>&1
89cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
90cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,0755)
101%doc README_07032010 LICENSE
102%{_libdir}/libcrystalhd.so.*
103
104%files devel
105%defattr(-,root,root,0755)
106%dir %{_includedir}/libcrystalhd
107%{_includedir}/libcrystalhd/*
108%{_libdir}/libcrystalhd.so
109
110%files -n crystalhd-firmware
111%defattr(-,root,root,0755)
112%doc LICENSE
113/lib/firmware/bcm70012fw.bin
114/lib/firmware/bcm70015fw.bin
115
116%files -n gstreamer-plugin-crystalhd
117%defattr(-,root,root,0755)
118%{_libdir}/gstreamer-%{majorminor}/*.so
119
120
121%changelog
122* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
123- initial build based on Fedora rawhide
124
125* Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
126- Update to v3.5.1, now with nv12 support
127
128* Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
129- Tarball had object files in it, clean them out before building
130
131* Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
132- Rebase to 07032010 crystalhd sources
133- Large version-bump as driver and lib are now essentially 100%
134  in sync with the Windows driver and lib
135- Ship firmware, now that Broadcom has posted a redistribution,
136  no modification license to cover it
137- Build the gstreamer decoder plugin (will be moved to its own
138  package sooner or later)
139
140* Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
141- Fix segfault on firmware upload
142
143* Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
144- Update to pre-0.9.26 libcrystalhd, which contains support
145  for the new Broadcom BCM970015 Crystal HD decoder card
146
147* Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
148- Minor fixups to the as-yet-not-enabled firmware sub-package
149
150* Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
151- Initial package
Note: See TracBrowser for help on using the repository browser.