source: projects/specs/trunk/lib/libc/libcrystalhd/libcrystalhd-vl.spec @ 9439

Revision 9439, 6.2 KB checked in by inagaki, 9 years ago (diff)

2015-03-18 Ryoichi INAGAKI <ryo1@…>

  • cdrdao: rebuilt
  • digikam: fixed Group
  • easytag, libao, libcrystalhd, libmp4v2: updated


Line 
1%global majorminor 1.0
2%global date 20120405
3
4Name:           libcrystalhd
5Version:        3.10.0
6Release:        1%{?_dist_release}
7Summary:        Broadcom Crystal HD device interface library
8Summary(ja):    Broadcom Crystal HD デバイスのインターフェースライブラリ
9
10License:        LGPLv2
11Group:          System Environment/Libraries
12URL:            http://www.broadcom.com/support/crystal_hd/
13
14#Source:         http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
15# This tarball and README are inside the above zip file...
16# Patch generated from http://git.linuxtv.org/jarod/crystalhd.git
17Source0:        libcrystalhd-%{date}.tar.bz2
18Source1:        README_07032010
19# We're going to use even newer firmware for now
20Source2:        bcm70012fw.bin
21Source3:        bcm70015fw.bin
22# LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
23Source4:        LICENSE
24Source5:        libcrystalhd-snapshot.sh
25Patch0:         libcrystalhd-nosse2.patch
26# https://patchwork2.kernel.org/patch/2247431/
27Patch1:         crystalhd-gst-Port-to-GStreamer-1.0-API.patch
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30BuildRequires:  autoconf automake libtool
31BuildRequires:  gstreamer1-devel >= %{majorminor}
32BuildRequires:  gstreamer1-plugins-base-devel >= %{majorminor}
33Requires:       crystalhd-firmware
34
35%description
36The libcrystalhd library provides userspace access to Broadcom Crystal HD
37video decoder devices. The device supports hardware decoding of MPEG-2,
38h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
39bcm970012 hardware, and up to 1080p at 60fps for the second-generation
40bcm970015 hardware.
41
42%package devel
43Summary:       Development libs for libcrystalhd
44Summary(ja):   libcrystalhd の開発用ファイル
45Group:         Development/Libraries
46Requires:      %{name} = %{version}-%{release}
47
48%description devel
49Development libraries needed to build applications against libcrystalhd.
50
51%package -n crystalhd-firmware
52Summary:       Firmware for the Broadcom Crystal HD video decoder
53Summary(ja):   Broadcom Crystal HD ビデオデコーダ用ファームウェア
54License:       Redistributable, no modification permitted
55Group:         System Environment/Kernel
56BuildArch:     noarch
57Requires:      %{name} = %{version}-%{release}
58
59%description -n crystalhd-firmware
60Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
61video decoders.
62
63%package -n gstreamer-plugin-crystalhd
64Summary:       Gstreamer crystalhd decoder plugin
65Summary(ja):   Gstreamer crystalhd デコーダプラグイン
66Group:         System Environment/Libraries
67Requires:      %{name} = %{version}-%{release}
68Requires:      gstreamer1-plugins-base
69
70%description -n gstreamer-plugin-crystalhd
71Gstreamer crystalhd decoder plugin
72
73%prep
74%setup -q -n libcrystalhd-%{date}
75cp %{SOURCE1} %{SOURCE4} .
76%ifnarch %{ix86} ia64 x86_64
77%patch0 -p1 -b .nosse2
78sed -i -e 's|-msse2||' linux_lib/libcrystalhd/Makefile
79%endif
80%patch1 -p1 -b .gst1
81
82%build
83pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
84# FIXME: this doesn't work just yet...
85#make CPPFLAGS="%{optflags}" %{?_smp_mflags}
86make %{?_smp_mflags}
87popd > /dev/null 2>&1
88
89pushd filters/gst/gst-plugin/ > /dev/null 2>&1
90sh autogen.sh || :
91
92%configure
93make %{?_smp_mflags} \
94  CFLAGS="-I%{_builddir}/%{buildsubdir}/include -I%{_builddir}/%{buildsubdir}/linux_lib/libcrystalhd" \
95  BCMDEC_LDFLAGS="-L%{_builddir}/%{buildsubdir}/linux_lib/libcrystalhd -lcrystalhd"
96popd > /dev/null 2>&1
97
98%install
99rm -rf $RPM_BUILD_ROOT
100pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
101make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
102popd > /dev/null 2>&1
103pushd filters/gst/gst-plugin/ > /dev/null 2>&1
104make install DESTDIR=$RPM_BUILD_ROOT
105rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstbcmdec.{a,la}
106popd > /dev/null 2>&1
107
108#rm -rf $RPM_BUILD_ROOT/lib/firmware/
109mkdir -p $RPM_BUILD_ROOT/lib/firmware/
110cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
111cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
112
113# Install udev rule
114mkdir -p $RPM_BUILD_ROOT/lib/udev/rules.d
115install -pm 0644 driver/linux/20-crystalhd.rules \
116    $RPM_BUILD_ROOT/lib/udev/rules.d
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(-,root,root,0755)
127%doc README_07032010 LICENSE
128%{_libdir}/libcrystalhd.so.*
129
130%files devel
131%defattr(-,root,root,0755)
132%dir %{_includedir}/libcrystalhd
133%{_includedir}/libcrystalhd/*
134%{_libdir}/libcrystalhd.so
135
136%files -n crystalhd-firmware
137%defattr(-,root,root,0755)
138%doc LICENSE
139/lib/udev/rules.d/20-crystalhd.rules
140/lib/firmware/bcm70012fw.bin
141/lib/firmware/bcm70015fw.bin
142
143%files -n gstreamer-plugin-crystalhd
144%defattr(-,root,root,0755)
145%{_libdir}/gstreamer-%{majorminor}/*.so
146
147
148%changelog
149* Tue Mar 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.10.0-1
150- updated to 3.10.0 based on Fedora 3.10.0-8
151- changed gstreamer-plugin-crystalhd to System Environment/Libraries Group
152
153* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.5.1-3
154- applied libcrystalhd-3.5.1-define-first.patch
155
156* Sun May 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.1-2
157- add Patch1 for ppc (libcrystalhd-ppc.patch)
158
159* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
160- initial build based on Fedora rawhide
161
162* Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
163- Update to v3.5.1, now with nv12 support
164
165* Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
166- Tarball had object files in it, clean them out before building
167
168* Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
169- Rebase to 07032010 crystalhd sources
170- Large version-bump as driver and lib are now essentially 100%
171  in sync with the Windows driver and lib
172- Ship firmware, now that Broadcom has posted a redistribution,
173  no modification license to cover it
174- Build the gstreamer decoder plugin (will be moved to its own
175  package sooner or later)
176
177* Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
178- Fix segfault on firmware upload
179
180* Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
181- Update to pre-0.9.26 libcrystalhd, which contains support
182  for the new Broadcom BCM970015 Crystal HD decoder card
183
184* Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
185- Minor fixups to the as-yet-not-enabled firmware sub-package
186
187* Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
188- Initial package
Note: See TracBrowser for help on using the repository browser.