source: projects/specs/trunk/lib/libc/libconfig/libconfig-vl.spec @ 10570

Revision 10570, 4.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:                   libconfig
2Summary:                C/C++ configuration file library
3Summary(ja):            C/C++ 設定ファイルライブラリ
4Version:                1.4.9
5Release:                2%{?_dist_release}
6License:                LGPLv2+
7Group:                  System Environment/Libraries
8Source0:                http://www.hyperrealm.com/libconfig/libconfig-%{version}.tar.gz
9URL:                    http://www.hyperrealm.com/libconfig/
10BuildRequires:          texinfo, task-texlive
11BuildRequires:          bison, flex
12
13%description
14Libconfig is a simple library for manipulating structured configuration
15files. This file format is more compact and more readable than XML. And
16unlike XML, it is type-aware, so it is not necessary to do string parsing
17in application code.
18
19%package devel
20Summary:                Development files for libconfig
21Summary(ja):            libconfig の開発ファイル
22Group:                  Development/Libraries
23Requires:               %{name} = %{version}-%{release}
24Requires:               pkgconfig
25Requires(post):         install-info
26Requires(preun):        install-info
27
28%description devel
29Development libraries and headers for developing software against
30libconfig.
31
32%prep
33%setup -q
34iconv -f iso-8859-1 -t utf-8 -o AUTHORS{.utf8,}
35mv AUTHORS{.utf8,}
36
37%build
38%configure --disable-static
39make %{?_smp_mflags}
40make pdf
41
42%install
43make DESTDIR=$RPM_BUILD_ROOT install install-pdf
44rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
45rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
46# Prevent multilib conflicts
47sed -i '/^\/CreationDate/d' $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/libconfig.pdf
48sed -i '/^\/ModDate/d' $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/libconfig.pdf
49sed -i '/^\/ID /d' $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/libconfig.pdf
50
51%post -p /sbin/ldconfig
52
53%post devel
54/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
55
56%postun -p /sbin/ldconfig
57
58%preun devel
59if [ $1 = 0 ]; then
60   /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
61fi
62
63%files
64%defattr(-,root,root,-)
65%doc AUTHORS ChangeLog COPYING.LIB README
66%{_libdir}/libconfig*.so.*
67
68
69%files devel
70%defattr(-,root,root,-)
71%{_includedir}/libconfig*
72%{_libdir}/libconfig*.so
73%{_libdir}/pkgconfig/libconfig*.pc
74%{_defaultdocdir}/%{name}/
75%{_infodir}/libconfig.info*
76
77%changelog
78* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
79- rebuild with gcc-5.4.0
80
81* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-1
82- initial build for Vine Linux
83
84* Mon Oct  1 2012 Tom Callaway <spot@fedoraproject.org> - 1.4.9-1
85- update to 1.4.9
86
87* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-3
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
89
90* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
92
93* Fri Aug 12 2011 Tom Callaway <spot@fedoraproject.org> - 1.4.8-1
94- update to 1.4.8
95
96* Wed Mar 23 2011 Tom Callaway <spot@fedoraproject.org> - 1.4.7-1
97- update to 1.4.7
98
99* Tue Mar  1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.4.6-1
100- Update to 1.4.6
101- Install libconfig_tests
102- Fix rpmlint warnings
103
104* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-2
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
106
107* Wed May  5 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4.5-1
108- update to 1.4.5
109
110* Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.2-1
111- update to 1.3.2
112
113* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
115
116* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-3
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
118
119* Wed Dec 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.1-2
120- prevent multilib conflicts with the generated pdf
121
122* Fri Sep 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.1-1
123- update to 1.3.1
124
125* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-2
126- Autorebuild for GCC 4.3
127
128* Tue Feb 19 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.1-1
129- bump to 1.2.1
130
131* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.2-4
132- nuke %%{_infodir}/dir, we handle it in %%post
133
134* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.2-3
135- move all docs to devel
136- move scriptlets around to match
137- move requires around to match
138
139* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.2-2
140- BR: texinfo-tex (not Requires)
141
142* Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.2-1
143- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.