source: projects/specs/trunk/lib/libc/libchamplain/libchamplain-vl.spec @ 9791

Revision 9791, 13.4 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define ver     0.12
2
3Summary:        Map view for Clutter
4Summary(ja):    Clutter用のマップビューア
5Name:           libchamplain
6Version:        0.12.11
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group: System Environment/Libraries
10URL: http://projects.gnome.org/libchamplain/
11Source0: http://download.gnome.org/sources/libchamplain/0.12/%{name}-%{version}.tar.xz
12
13Requires: gobject-introspection
14
15BuildRequires: clutter-devel
16BuildRequires: clutter-gtk-devel
17BuildRequires: libsoup-devel
18BuildRequires: sqlite3-devel
19BuildRequires: gtk-doc >= 1.14
20BuildRequires: gobject-introspection-devel >= 0.6.8
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29Libchamplain is a C library aimed to provide a ClutterActor to display
30rasterized maps.
31
32%description -l ja
33Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38
39Requires:       gobject-introspection-devel
40Requires:       clutter-devel
41Requires:       sqlite3-devel
42Requires:       libsoup-devel
43Requires:       %{name} = %{version}-%{release}
44
45%description devel
46This package contains development files for %{name}.
47
48%package        gtk
49Summary:        Gtk+ widget wrapper for %{name}
50Group:          System Environment/Libraries
51
52Requires:       %{name} = %{version}-%{release}
53
54%description gtk
55Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
56into Gtk+ applications.
57
58%package        gtk-devel
59Summary:        Development files for %{name}-gtk
60Group:          Development/Libraries
61
62Requires:       clutter-gtk-devel
63Requires:       gtk2-devel
64Requires:       %{name}-devel = %{version}-%{release}
65Requires:       %{name}-gtk = %{version}-%{release}
66
67%description gtk-devel
68This package contains development files for %{name}-gtk.
69
70%package        vala
71Summary:        Vala bindings for %{name}
72Summary(ja):    %{name} の Vala バインディング
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       %{name}-gtk = %{version}-%{release}
76Requires:       vala
77
78%description    vala
79Vala bindings for %{name}.
80
81%package        docs
82Summary:        Documentation for %{name}
83Summary(ja):    %{name} 用のドキュメント
84Group:          Documentation
85Requires:       %{name} = %{version}-%{release}
86Requires:               gtk-doc
87BuildArch:      noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93%prep
94%setup -q
95
96%build
97%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
98  --enable-introspection=yes --enable-silent-rules
99
100# Omit unused direct shared library dependencies.
101sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
102
103make %{?_smp_mflags}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
109find $RPM_BUILD_ROOT -type f -name "*.la" -delete
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post gtk -p /sbin/ldconfig
119
120%postun gtk -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc AUTHORS
125%doc ChangeLog
126%doc COPYING
127%doc NEWS
128%{_libdir}/girepository-1.0/Champlain-%{ver}.typelib
129%{_libdir}/%{name}-%{ver}.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%doc demos/animated-marker.c
134%doc demos/launcher.c
135%doc demos/markers.c
136%doc demos/markers.h
137%doc demos/polygons.c
138%doc demos/url-marker.c
139%{_datadir}/gir-1.0/Champlain-%{ver}.gir
140%{_libdir}/%{name}-%{ver}.so
141%{_libdir}/pkgconfig/champlain-%{ver}.pc
142
143%dir %{_includedir}/%{name}-%{ver}
144%{_includedir}/%{name}-%{ver}/champlain
145
146%files gtk
147%defattr(-,root,root,-)
148%{_libdir}/girepository-1.0/GtkChamplain-%{ver}.typelib
149%{_libdir}/%{name}-gtk-%{ver}.so.*
150
151%files gtk-devel
152%defattr(-,root,root,-)
153%doc demos/launcher-gtk.c
154%doc demos/markers.c
155%{_datadir}/gir-1.0/GtkChamplain-%{ver}.gir
156%{_libdir}/%{name}-gtk-%{ver}.so
157%{_libdir}/pkgconfig/champlain-gtk-%{ver}.pc
158
159%dir %{_includedir}/%{name}-gtk-%{ver}
160%{_includedir}/%{name}-gtk-%{ver}/champlain-gtk
161
162%files vala
163%defattr(-,root,root,-)
164%{_datadir}/vala/vapi/champlain-%{ver}.vapi
165%{_datadir}/vala/vapi/champlain-gtk-%{ver}.vapi
166
167%files docs
168%defattr(-,root,root,-)
169%{_datadir}/gtk-doc/html/libchamplain-%{ver}
170%{_datadir}/gtk-doc/html/libchamplain-gtk-%{ver}
171
172
173%changelog
174* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.11-1
175- new upstream release
176
177* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.10-1
178- new upstream release
179
180* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
181- new upstream release
182
183* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
184- new upstream release
185
186* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-2
187- rebuild with VineSeed environment
188
189* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-1
190- new upstream release
191- create vala, docs subpackages
192
193* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
194- new upstream release
195
196* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-3
197- rebuild with cogl-0.14.0
198
199* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-2
200- rebuild with cogl-0.12.0
201
202* Tue Jul 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
203- new upstream release
204
205* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
206- new upstream release
207
208* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
209- new upstream release
210
211* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
212- new upstream release
213
214* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
215- new upstream release
216- add Requires: sqlite3-devel, libsoup-devel (-devel package)
217
218* Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
219- add Requires: sqlite3-devel, libsoup-devel (-devel package)
220- add Requires: gtk2-devel (-gtk-devel package)
221
222* Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
223- new upstream release
224- remove BuildRequires: gir-repository-devel
225- fix %files (change version)
226
227* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
228- rebuild with rpm-4.8.1 for pkg-config file
229
230* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
231- new upstream release
232
233* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
234- new upstream release
235
236* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
237- new upstream release
238- fix BuildRequires: gtk-doc >= 1.14
239- add Requires: clutter-devel (devel package)
240- add Requires: clutter-gtk-devel (gtk-devel package)
241
242* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
243- Initial build for Vine Linux
244- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
245
246
247* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
248- Version bump to 0.4.2.
249  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
250  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
251  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
252  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
253
254* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
255- Version bump to 0.4.1.
256  * Added champlain_view_remove_layer.
257  * ChamplainSelectionLayer now has a "changed" signal.
258  * Added champlain_marker_get_highlighted_text_color,
259    champlain_marker_set_highlighted_text_color and
260    Added champlain_marker_get_highlighted_color.
261  * Fixed slowdowns with big caches.
262  * Don't emit invalid latitude and longitude notifications.
263  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
264    Bugzilla #598106)
265  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
266  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
267
268- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
269  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
270  (GNOME Bugzilla #598942)
271- Explicitly disabled debug code.
272- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
273
274* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
275- Version bump to 0.4.0.
276  * ChamplainView now has keyboard shortcuts (but not when used with
277    GtkChamplainEmbed).
278  * Removed deprecated symbols introduced in 0.3.
279  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
280  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
281  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
282  * Initial center_on should not result on the map being in Antarctica.
283    (GNOME Bugzilla #594963)
284  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
285  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
286
287* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
288- Version bump to 0.3.91.
289  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
290
291* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
292- Version bump to 0.3.90.
293  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
294  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
295
296* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
297- Version bump to 0.3.6.
298  * New marker animation API.
299  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
300  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
301  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
302
303* Sun Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
304- Version bump to 0.3.5.
305  * Marker selection API. (GNOME Bugzilla #577909)
306  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
307  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
308  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
309  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
310
311* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
312- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
313
314* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
315- Version bump to 0.3.3.
316  * Support for custom map sources and listing available map sources.
317  * Smooth movement to a new position. (GNOME Bugzilla #557641)
318  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
319    #557642)
320  * Double click to zoom and center. (GNOME Bugzilla #557644)
321  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
322    #557965)
323  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
324    Bugzilla #558020)
325  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
326  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
327  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
328    #559446)
329  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
330    #561700)
331  * Added disk cache management. (GNOME Bugzillla #568931)
332  * Host application should be able to limit the maximum and minimum zoom
333    levels. (GNOME Bugzilla #571702)
334  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
335    #572377)
336  * Support proxies. (GNOME Bugzilla #573937)
337  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
338  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
339  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
340    #575139)
341  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
342    (GNOME Bugzilla #575902).
343  * Implemented advanced markers. (GNOME Bugzilla #576055)
344  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
345    #576159)
346  * Any go_to should stop a previous and not yet finished go_to. (GNOME
347    Bugzilla #576832)
348  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
349  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
350    Bugzilla #577169)
351  * Set decel-rate correctly. (GNOME Bugzilla #580785)
352  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
353    #582786)
354  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
355  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
356    Bugzilla #584365)
357  * Make the cache work the first time. (GNOME Bugzilla #584390)
358  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
359    #585698)
360- Added 'BuildRequires: chrpath' for removing rpaths.
361
362* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
363- Version bump to 0.2.9.
364  * Fixed elastic effect.
365  * Reduced exported symbols.
366
367* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
368- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
369
370* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
371- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
372  for all distributions, except Fedora 10.
373- Fixed sample code to not use generic headers.
374
375* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
376- Initial build. Imported SPEC from openSUSE.
377  * Added a new constructor for ChamplainMarkers made of an image.
378  * Double clicking on the map will now zoom and recenter.
379  * When resizing a ChamplainView, the centered content will still be
380    centered after the resizing. Can be disabled.
381  * The Map's license is displayed by default on the lower right corner.
382  * Fixed map centering on startup.
383  * Fixed missing zoom level in OpenStreetMap Mapnik.
384  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.