source: projects/specs/trunk/lib/libc/libchamplain/libchamplain-vl.spec @ 624

Revision 624, 10.4 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1Summary:        Map view for Clutter
2Summary(ja):    Clutter用のマップビューア
3Name:           libchamplain
4Version:        0.4.4
5Release:        1%{?_dist_release}
6License:        LGPLv2+
7Group: System Environment/Libraries
8URL: http://projects.gnome.org/libchamplain/
9Source0: http://download.gnome.org/sources/libchamplain/0.4/%{name}-%{version}.tar.bz2
10
11Requires: gobject-introspection
12
13BuildRequires: clutter-devel
14BuildRequires: clutter-gtk-devel
15BuildRequires: gir-repository-devel
16BuildRequires: libsoup-devel
17BuildRequires: sqlite3-devel
18BuildRequires: gtk-doc
19BuildRequires: gobject-introspection-devel >= 0.6.8
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22%description
23Libchamplain is a C library aimed to provide a ClutterActor to display
24rasterized maps.
25
26%description -l ja
27Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
28
29%package devel
30Summary:        Development files for %{name}
31Group:          Development/Libraries
32
33Requires:       gobject-introspection-devel
34Requires:       gtk-doc
35Requires:       %{name} = %{version}-%{release}
36
37%description devel
38This package contains development files for %{name}.
39
40%package gtk
41Summary:        Gtk+ widget wrapper for %{name}
42Group:          System Environment/Libraries
43
44Requires:       %{name} = %{version}-%{release}
45
46%description gtk
47Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
48into Gtk+ applications.
49
50%package gtk-devel
51Summary:        Development files for %{name}-gtk
52Group:          Development/Libraries
53
54Requires:       gtk-doc
55Requires:       %{name}-devel = %{version}-%{release}
56Requires:       %{name}-gtk = %{version}-%{release}
57
58%description gtk-devel
59This package contains development files for %{name}-gtk.
60
61%prep
62%setup -q
63
64%build
65%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
66  --enable-introspection=yes --enable-silent-rules
67
68# Omit unused direct shared library dependencies.
69sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
70
71make %{?_smp_mflags}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
77find $RPM_BUILD_ROOT -type f -name "*.la" -delete
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83
84%postun -p /sbin/ldconfig
85
86%post gtk -p /sbin/ldconfig
87
88%postun gtk -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%doc AUTHORS
93%doc ChangeLog
94%doc COPYING
95%doc NEWS
96%{_libdir}/girepository-1.0/Champlain-0.4.typelib
97%{_libdir}/%{name}-0.4.so.*
98
99%files devel
100%defattr(-,root,root,-)
101%doc demos/animated-marker.c
102%doc demos/launcher.c
103%doc demos/markers.c
104%doc demos/markers.h
105%doc demos/polygons.c
106%doc demos/url-marker.c
107%{_datadir}/gir-1.0/Champlain-0.4.gir
108%{_libdir}/%{name}-0.4.so
109%{_libdir}/pkgconfig/champlain-0.4.pc
110
111%dir %{_datadir}/gtk-doc/html/libchamplain
112%doc %{_datadir}/gtk-doc/html/libchamplain/*
113
114%dir %{_includedir}/%{name}-0.4
115%{_includedir}/%{name}-0.4/champlain
116
117%files gtk
118%defattr(-,root,root,-)
119%{_libdir}/girepository-1.0/GtkChamplain-0.4.typelib
120%{_libdir}/%{name}-gtk-0.4.so.*
121
122%files gtk-devel
123%defattr(-,root,root,-)
124%doc demos/launcher-gtk.c
125%doc demos/markers.c
126%{_datadir}/gir-1.0/GtkChamplain-0.4.gir
127%{_libdir}/%{name}-gtk-0.4.so
128%{_libdir}/pkgconfig/champlain-gtk-0.4.pc
129
130%dir %{_datadir}/gtk-doc/html/libchamplain-gtk
131%doc %{_datadir}/gtk-doc/html/libchamplain-gtk/*
132
133%dir %{_includedir}/%{name}-gtk-0.4
134%{_includedir}/%{name}-gtk-0.4/champlain-gtk
135
136%changelog
137* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> -0.4.4-1
138- Initial build for Vine Linux
139- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
140
141
142* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
143- Version bump to 0.4.2.
144  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
145  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
146  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
147  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
148
149* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
150- Version bump to 0.4.1.
151  * Added champlain_view_remove_layer.
152  * ChamplainSelectionLayer now has a "changed" signal.
153  * Added champlain_marker_get_highlighted_text_color,
154    champlain_marker_set_highlighted_text_color and
155    Added champlain_marker_get_highlighted_color.
156  * Fixed slowdowns with big caches.
157  * Don't emit invalid latitude and longitude notifications.
158  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
159    Bugzilla #598106)
160  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
161  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
162
163- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
164  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
165  (GNOME Bugzilla #598942)
166- Explicitly disabled debug code.
167- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
168
169* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
170- Version bump to 0.4.0.
171  * ChamplainView now has keyboard shortcuts (but not when used with
172    GtkChamplainEmbed).
173  * Removed deprecated symbols introduced in 0.3.
174  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
175  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
176  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
177  * Initial center_on should not result on the map being in Antarctica.
178    (GNOME Bugzilla #594963)
179  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
180  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
181
182* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
183- Version bump to 0.3.91.
184  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
185
186* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
187- Version bump to 0.3.90.
188  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
189  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
190
191* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
192- Version bump to 0.3.6.
193  * New marker animation API.
194  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
195  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
196  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
197
198* Sat Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
199- Version bump to 0.3.5.
200  * Marker selection API. (GNOME Bugzilla #577909)
201  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
202  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
203  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
204  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
205
206* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
207- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
208
209* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
210- Version bump to 0.3.3.
211  * Support for custom map sources and listing available map sources.
212  * Smooth movement to a new position. (GNOME Bugzilla #557641)
213  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
214    #557642)
215  * Double click to zoom and center. (GNOME Bugzilla #557644)
216  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
217    #557965)
218  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
219    Bugzilla #558020)
220  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
221  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
222  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
223    #559446)
224  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
225    #561700)
226  * Added disk cache management. (GNOME Bugzillla #568931)
227  * Host application should be able to limit the maximum and minimum zoom
228    levels. (GNOME Bugzilla #571702)
229  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
230    #572377)
231  * Support proxies. (GNOME Bugzilla #573937)
232  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
233  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
234  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
235    #575139)
236  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
237    (GNOME Bugzilla #575902).
238  * Implemented advanced markers. (GNOME Bugzilla #576055)
239  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
240    #576159)
241  * Any go_to should stop a previous and not yet finished go_to. (GNOME
242    Bugzilla #576832)
243  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
244  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
245    Bugzilla #577169)
246  * Set decel-rate correctly. (GNOME Bugzilla #580785)
247  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
248    #582786)
249  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
250  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
251    Bugzilla #584365)
252  * Make the cache work the first time. (GNOME Bugzilla #584390)
253  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
254    #585698)
255- Added 'BuildRequires: chrpath' for removing rpaths.
256
257* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
258- Version bump to 0.2.9.
259  * Fixed elastic effect.
260  * Reduced exported symbols.
261
262* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
263- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
264
265* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
266- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
267  for all distributions, except Fedora 10.
268- Fixed sample code to not use generic headers.
269
270* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
271- Initial build. Imported SPEC from openSUSE.
272  * Added a new constructor for ChamplainMarkers made of an image.
273  * Double clicking on the map will now zoom and recenter.
274  * When resizing a ChamplainView, the centered content will still be
275    centered after the resizing. Can be disabled.
276  * The Map's license is displayed by default on the lower right corner.
277  * Fixed map centering on startup.
278  * Fixed missing zoom level in OpenStreetMap Mapnik.
279  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.