source: projects/specs/trunk/lib/libc/libchamplain/libchamplain-vl.spec @ 10716

Revision 10716, 13.6 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define ver     0.12
2
3Summary:        Map view for Clutter
4Summary(ja):    Clutter用のマップビューア
5Name:           libchamplain
6Version:        0.12.13
7Release:        1%{?_dist_release}
8License:        LGPLv2+
9Group: System Environment/Libraries
10URL: http://projects.gnome.org/libchamplain/
11Source0: http://download.gnome.org/sources/libchamplain/0.12/%{name}-%{version}.tar.xz
12
13Requires: gobject-introspection
14
15BuildRequires: clutter-devel
16BuildRequires: clutter-gtk-devel
17BuildRequires: libsoup-devel
18BuildRequires: sqlite3-devel
19BuildRequires: gtk-doc >= 1.14
20BuildRequires: gobject-introspection-devel >= 0.6.8
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29Libchamplain is a C library aimed to provide a ClutterActor to display
30rasterized maps.
31
32%description -l ja
33Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
34
35%package        devel
36Summary:        Development files for %{name}
37Group:          Development/Libraries
38
39Requires:       gobject-introspection-devel
40Requires:       clutter-devel
41Requires:       sqlite3-devel
42Requires:       libsoup-devel
43Requires:       %{name} = %{version}-%{release}
44
45%description devel
46This package contains development files for %{name}.
47
48%package        gtk
49Summary:        Gtk+ widget wrapper for %{name}
50Group:          System Environment/Libraries
51
52Requires:       %{name} = %{version}-%{release}
53
54%description gtk
55Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
56into Gtk+ applications.
57
58%package        gtk-devel
59Summary:        Development files for %{name}-gtk
60Group:          Development/Libraries
61
62Requires:       clutter-gtk-devel
63Requires:       gtk2-devel
64Requires:       %{name}-devel = %{version}-%{release}
65Requires:       %{name}-gtk = %{version}-%{release}
66
67%description gtk-devel
68This package contains development files for %{name}-gtk.
69
70%package        vala
71Summary:        Vala bindings for %{name}
72Summary(ja):    %{name} の Vala バインディング
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       %{name}-gtk = %{version}-%{release}
76Requires:       vala
77
78%description    vala
79Vala bindings for %{name}.
80
81%package        docs
82Summary:        Documentation for %{name}
83Summary(ja):    %{name} 用のドキュメント
84Group:          Documentation
85Requires:       %{name} = %{version}-%{release}
86Requires:               gtk-doc
87BuildArch:      noarch
88
89%description    docs
90This package contains documentation for %{name}.
91
92
93%prep
94%setup -q
95
96%build
97%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
98  --enable-introspection=yes --enable-silent-rules
99
100# Omit unused direct shared library dependencies.
101sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
102
103make %{?_smp_mflags}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
109find $RPM_BUILD_ROOT -type f -name "*.la" -delete
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post gtk -p /sbin/ldconfig
119
120%postun gtk -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc AUTHORS
125%doc ChangeLog
126%doc COPYING
127%doc NEWS
128%{_libdir}/girepository-1.0/Champlain-%{ver}.typelib
129%{_libdir}/%{name}-%{ver}.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%doc demos/animated-marker.c
134%doc demos/launcher.c
135%doc demos/markers.c
136%doc demos/markers.h
137%doc demos/polygons.c
138%doc demos/url-marker.c
139%{_datadir}/gir-1.0/Champlain-%{ver}.gir
140%{_libdir}/%{name}-%{ver}.so
141%{_libdir}/pkgconfig/champlain-%{ver}.pc
142
143%dir %{_includedir}/%{name}-%{ver}
144%{_includedir}/%{name}-%{ver}/champlain
145
146%files gtk
147%defattr(-,root,root,-)
148%{_libdir}/girepository-1.0/GtkChamplain-%{ver}.typelib
149%{_libdir}/%{name}-gtk-%{ver}.so.*
150
151%files gtk-devel
152%defattr(-,root,root,-)
153%doc demos/launcher-gtk.c
154%doc demos/markers.c
155%{_datadir}/gir-1.0/GtkChamplain-%{ver}.gir
156%{_libdir}/%{name}-gtk-%{ver}.so
157%{_libdir}/pkgconfig/champlain-gtk-%{ver}.pc
158
159%dir %{_includedir}/%{name}-gtk-%{ver}
160%{_includedir}/%{name}-gtk-%{ver}/champlain-gtk
161
162%files vala
163%defattr(-,root,root,-)
164%{_datadir}/vala/vapi/champlain-%{ver}.vapi
165%{_datadir}/vala/vapi/champlain-gtk-%{ver}.vapi
166
167%files docs
168%defattr(-,root,root,-)
169%{_datadir}/gtk-doc/html/libchamplain-%{ver}
170%{_datadir}/gtk-doc/html/libchamplain-gtk-%{ver}
171
172
173%changelog
174* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.13-1
175- new upstream release
176
177* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.12-1
178- new upstream release
179
180* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.11-1
181- new upstream release
182
183* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.10-1
184- new upstream release
185
186* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
187- new upstream release
188
189* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
190- new upstream release
191
192* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-2
193- rebuild with VineSeed environment
194
195* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-1
196- new upstream release
197- create vala, docs subpackages
198
199* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
200- new upstream release
201
202* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-3
203- rebuild with cogl-0.14.0
204
205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-2
206- rebuild with cogl-0.12.0
207
208* Tue Jul 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
209- new upstream release
210
211* Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
212- new upstream release
213
214* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
215- new upstream release
216
217* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
218- new upstream release
219
220* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
221- new upstream release
222- add Requires: sqlite3-devel, libsoup-devel (-devel package)
223
224* Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
225- add Requires: sqlite3-devel, libsoup-devel (-devel package)
226- add Requires: gtk2-devel (-gtk-devel package)
227
228* Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
229- new upstream release
230- remove BuildRequires: gir-repository-devel
231- fix %files (change version)
232
233* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
234- rebuild with rpm-4.8.1 for pkg-config file
235
236* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
237- new upstream release
238
239* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
240- new upstream release
241
242* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
243- new upstream release
244- fix BuildRequires: gtk-doc >= 1.14
245- add Requires: clutter-devel (devel package)
246- add Requires: clutter-gtk-devel (gtk-devel package)
247
248* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
249- Initial build for Vine Linux
250- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
251
252
253* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
254- Version bump to 0.4.2.
255  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
256  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
257  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
258  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
259
260* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
261- Version bump to 0.4.1.
262  * Added champlain_view_remove_layer.
263  * ChamplainSelectionLayer now has a "changed" signal.
264  * Added champlain_marker_get_highlighted_text_color,
265    champlain_marker_set_highlighted_text_color and
266    Added champlain_marker_get_highlighted_color.
267  * Fixed slowdowns with big caches.
268  * Don't emit invalid latitude and longitude notifications.
269  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
270    Bugzilla #598106)
271  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
272  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
273
274- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
275  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
276  (GNOME Bugzilla #598942)
277- Explicitly disabled debug code.
278- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
279
280* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
281- Version bump to 0.4.0.
282  * ChamplainView now has keyboard shortcuts (but not when used with
283    GtkChamplainEmbed).
284  * Removed deprecated symbols introduced in 0.3.
285  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
286  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
287  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
288  * Initial center_on should not result on the map being in Antarctica.
289    (GNOME Bugzilla #594963)
290  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
291  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
292
293* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
294- Version bump to 0.3.91.
295  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
296
297* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
298- Version bump to 0.3.90.
299  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
300  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
301
302* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
303- Version bump to 0.3.6.
304  * New marker animation API.
305  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
306  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
307  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
308
309* Sun Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
310- Version bump to 0.3.5.
311  * Marker selection API. (GNOME Bugzilla #577909)
312  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
313  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
314  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
315  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
316
317* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
318- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
319
320* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
321- Version bump to 0.3.3.
322  * Support for custom map sources and listing available map sources.
323  * Smooth movement to a new position. (GNOME Bugzilla #557641)
324  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
325    #557642)
326  * Double click to zoom and center. (GNOME Bugzilla #557644)
327  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
328    #557965)
329  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
330    Bugzilla #558020)
331  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
332  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
333  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
334    #559446)
335  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
336    #561700)
337  * Added disk cache management. (GNOME Bugzillla #568931)
338  * Host application should be able to limit the maximum and minimum zoom
339    levels. (GNOME Bugzilla #571702)
340  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
341    #572377)
342  * Support proxies. (GNOME Bugzilla #573937)
343  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
344  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
345  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
346    #575139)
347  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
348    (GNOME Bugzilla #575902).
349  * Implemented advanced markers. (GNOME Bugzilla #576055)
350  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
351    #576159)
352  * Any go_to should stop a previous and not yet finished go_to. (GNOME
353    Bugzilla #576832)
354  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
355  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
356    Bugzilla #577169)
357  * Set decel-rate correctly. (GNOME Bugzilla #580785)
358  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
359    #582786)
360  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
361  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
362    Bugzilla #584365)
363  * Make the cache work the first time. (GNOME Bugzilla #584390)
364  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
365    #585698)
366- Added 'BuildRequires: chrpath' for removing rpaths.
367
368* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
369- Version bump to 0.2.9.
370  * Fixed elastic effect.
371  * Reduced exported symbols.
372
373* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
374- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
375
376* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
377- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
378  for all distributions, except Fedora 10.
379- Fixed sample code to not use generic headers.
380
381* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
382- Initial build. Imported SPEC from openSUSE.
383  * Added a new constructor for ChamplainMarkers made of an image.
384  * Double clicking on the map will now zoom and recenter.
385  * When resizing a ChamplainView, the centered content will still be
386    centered after the resizing. Can be disabled.
387  * The Map's license is displayed by default on the lower right corner.
388  * Fixed map centering on startup.
389  * Fixed missing zoom level in OpenStreetMap Mapnik.
390  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.