source: projects/specs/trunk/lib/libc/libcgroup/libcgroup-vl.spec @ 12341

Revision 12341, 9.1 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

libcgroup-0.42.2-1

ppp-2.4.8-1

Line 
1%define soversion 1.0.42
2%define soversion_major 1
3
4Name: libcgroup
5Summary: Tools and libraries to control and monitor control groups
6Summary(ja): CGROUPS を管理・監視するためのツールおよびライブラリ
7Version: 0.42.2
8Release: 1%{?_dist_release}
9
10License: LGPLv2+
11Group: System Environment/Libraries
12Vendor: Project Vine
13Distribution: Vine Linux
14
15URL: http://libcg.sourceforge.net/
16Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-v%{version}.tar.gz
17
18Patch1: libcgroup-0.37-chmod.patch
19Patch2: libcgroup-0.40.rc1-coverity.patch
20Patch3: libcgroup-0.40.rc1-fread.patch
21Patch4: libcgroup-0.40.rc1-templates-fix.patch
22
23Patch1000: 0001-modify-configurations.patch
24Patch1001: 0002-fix-initscripts.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires: pam-devel
28BuildRequires: byacc
29BuildRequires: flex
30BuildRequires: coreutils
31Requires(pre): shadow-utils
32Requires(post): chkconfig, /sbin/service
33Requires(preun): /sbin/chkconfig
34
35%description
36Control groups infrastructure. The tools and library help manipulate, control,
37administrate and monitor control groups and the associated controllers.
38
39%package pam
40Summary: A Pluggable Authentication Module for libcgroup
41Summary(ja): Libcgroup の PAM モジュール
42Group: System Environment/Base
43Requires: libcgroup = %{version}-%{release}
44
45%description pam
46Linux-PAM module, which allows administrators to classify the user's login
47processes to pre-configured control group.
48
49%package devel
50Summary: Development files for libcgroup
51Summary(ja): libcgroup の開発用ファイル
52Group: Development/Libraries
53Requires: libcgroup = %{version}-%{release}
54
55%description devel
56It provides API to create/delete and modify cgroup nodes. It will also in the
57future allow creation of persistent configuration for control groups and
58provide scripts to manage that configuration.
59
60%prep
61%setup -q -n %{name}-%{version}
62%autopatch -p1
63
64autoreconf -vif
65
66%build
67%configure --bindir=/bin --sbindir=/sbin --libdir=%{_libdir} --enable-initscript-install --enable-pam-module-dir=/%{_lib}/security
68
69make %{?_smp_mflags}
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make DESTDIR=$RPM_BUILD_ROOT install
75
76# install config files
77mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig
78cp samples/cgred.conf $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cgred.conf
79cp samples/cgconfig.sysconfig $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cgconfig
80cp samples/cgconfig.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgconfig.conf
81cp samples/cgrules.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgrules.conf
82cp samples/cgsnapshot_blacklist.conf $RPM_BUILD_ROOT/%{_sysconfdir}/cgsnapshot_blacklist.conf
83
84# sanitize pam module, we need only pam_cgroup.so
85mv -f $RPM_BUILD_ROOT/%{_lib}/security/pam_cgroup.so.*.*.* $RPM_BUILD_ROOT/%{_lib}/security/pam_cgroup.so
86rm -f $RPM_BUILD_ROOT/%{_lib}/security/pam_cgroup.la $RPM_BUILD_ROOT/%{_lib}/security/pam_cgroup.so.*
87
88# move the libraries  to /
89mkdir -p $RPM_BUILD_ROOT/%{_lib}
90mv -f $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}
91rm -f $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so.%{soversion_major}
92ln -sf libcgroup.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/libcgroup.so.%{soversion_major}
93ln -sf ../../%{_lib}/libcgroup.so.%{soversion} $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so
94rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
95rm -f $RPM_BUILD_ROOT/%{_libdir}/libcgroupfortesting.*
96rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.a
97
98# pre-create /cgroup directory
99mkdir $RPM_BUILD_ROOT/cgroup
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%pre
105getent group cgred >/dev/null || groupadd -r cgred
106
107%post
108/sbin/ldconfig
109/sbin/chkconfig --add cgred
110/sbin/chkconfig --add cgconfig
111
112%preun
113if [ $1 = 0 ]; then
114    /sbin/service cgred stop > /dev/null 2>&1 || :
115    /sbin/service cgconfig stop > /dev/null 2>&1 || :
116    /sbin/chkconfig --del cgconfig
117    /sbin/chkconfig --del cgred
118fi
119
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%config(noreplace) %{_sysconfdir}/sysconfig/cgred.conf
125%config(noreplace) %{_sysconfdir}/sysconfig/cgconfig
126%config(noreplace) %{_sysconfdir}/cgconfig.conf
127%config(noreplace) %{_sysconfdir}/cgrules.conf
128%config(noreplace) %{_sysconfdir}/cgsnapshot_blacklist.conf
129/%{_lib}/libcgroup.so.*
130%attr(2755, root, cgred) /bin/cgexec
131/bin/cgclassify
132/bin/cgcreate
133/bin/cgget
134/bin/cgset
135/bin/cgdelete
136/bin/lscgroup
137/bin/lssubsys
138/sbin/cgconfigparser
139/sbin/cgrulesengd
140/sbin/cgclear
141/bin/cgsnapshot
142%attr(0644, root, root) %{_mandir}/man1/*
143%attr(0644, root, root) %{_mandir}/man5/*
144%attr(0644, root, root) %{_mandir}/man8/*
145%attr(0755,root,root) %{_initrddir}/cgconfig
146%attr(0755,root,root) %{_initrddir}/cgred
147%license COPYING
148%doc README_daemon
149%attr(0755,root,root) %dir /cgroup
150
151%files pam
152%defattr(-,root,root,-)
153%attr(0755,root,root) /%{_lib}/security/pam_cgroup.so
154%license COPYING
155
156%files devel
157%defattr(-,root,root,-)
158%{_includedir}/libcgroup.h
159%{_includedir}/libcgroup/*.h
160%{_libdir}/libcgroup.*
161/%{_libdir}/pkgconfig/libcgroup.pc
162%license COPYING
163
164%changelog
165* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.42.2-1
166- new upstream release.
167- dropped Patch1-15.
168- imported Patch1-4 from rawhide.
169- updated Patch1001.
170
171* Thu May 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.41-2
172- updated Patch1000: add line for systemd-container.
173
174* Sat Jan 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.41-1
175- updated and renumbered Patch0 to Patch1000.
176- updated and renumbered Patch1 to Patch1001.
177- imported Patch1-15 from rawhide.
178
179* Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.37.1-2
180- moved libcgroup to System Environment/Libraries
181
182* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.37.1-1
183- initial build for Vine Linux
184
185* Thu Mar  3 2011 Jan Safranek <jsafrane@redhat.com> 0.37.1-1
186- Update to 0.37.1
187
188* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.37-3
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
190
191* Mon Jan 17 2011 Jan Safranek <jsafrane@redhat.com> 0.37-2
192- Create the 'cgred' group as system group, not as user
193- Fix cgclassify exit code
194
195* Mon Dec 13 2010 Jan Safranek <jsafrane@redhat.com> 0.37-1
196- Update to 0.37
197- use /sys/fs/cgroup as default directory to mount control groups (and rely on
198  systemd mounting tmpfs there)
199
200* Fri Nov 12 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-3
201- Ignore systemd hierarchy - it's now invisible to libcgroup (#627378)
202
203* Mon Aug  2 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-2
204- Fix initscripts to report stopped cgconfig service as not running
205  (#619091)
206
207* Tue Jun 22 2010 Jan Safranek <jsafrane@redhat.com> 0.36.2-1
208- Update to 0.36.2, fixing packaging the libraries (#605434)
209- Remove the dependency on redhat-lsb (#603578)
210
211* Fri May 21 2010 Jan Safranek <jsafrane@redhat.com> 0.36-1
212- Update to 0.36.1
213
214* Tue Mar  9 2010 Jan Safranek <jsafrane@redhat.com> 0.35-1
215- Update to 0.35.1
216- Separate pam module to its own subpackage
217
218* Mon Jan 18 2010 Jan Safranek <jsafrane@redhat.com> 0.34-4
219- Added README.Fedora to describe initscript integration
220
221* Mon Oct 19 2009 Jan Safranek <jsafrane@redhat.com> 0.34-3
222- Change the default configuration to mount everything to /cgroup
223
224* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.34-2
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
226
227* Tue Jul  7 2009 Jan Safranek <jsafrane@redhat.com> 0.34-1
228- Update to 0.34
229* Mon Mar 09 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-3
230- Add a workaround for rt cgroup controller.
231* Mon Mar 09 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-2
232- Change the cgconfig script to start earlier
233- Move the binaries to /bin and /sbin
234* Mon Mar 02 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.33-1
235- Update to latest upstream
236* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.32.2-4
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
238
239* Mon Jan 05 2009 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-3
240- Fix redhat-lsb dependency
241* Mon Dec 29 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-2
242- Fix build dependencies
243* Mon Dec 29 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.2-1
244- Update to latest upstream
245* Thu Oct 23 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32.1-1
246* Tue Feb 24 2009 Balbir Singh <balbir@linux.vnet.ibm.com> 0.33-1
247- Update to 0.33, spec file changes to add Makefiles and pam_cgroup module
248* Fri Oct 10 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.32-1
249- Update to latest upstream
250* Thu Sep 11 2008 Dhaval Giani <dhaval@linux-vnet.ibm.com> 0.31-1
251- Update to latest upstream
252* Sat Aug 2 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.1c-3
253- Change release to fix broken upgrade path
254* Wed Jun 11 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.1c-1
255- Update to latest upstream version
256* Tue Jun 3 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-3
257- Add post and postun. Also fix Requires for devel to depend on base n-v-r
258* Sat May 31 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-2
259- Fix makeinstall, Source0 and URL (review comments from Tom)
260* Mon May 26 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1b-1
261- Add a generatable spec file
262* Tue May 20 2008 Balbir Singh <balbir@linux.vnet.ibm.com> 0.1-1
263- Get the spec file to work
264* Tue May 20 2008 Dhaval Giani <dhaval@linux.vnet.ibm.com> 0.01-1
265- The first version of libcg
Note: See TracBrowser for help on using the repository browser.