source: projects/specs/trunk/lib/libc/libcdio/libcdio-vl.spec @ 12492

Revision 12492, 5.9 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

glib2-2.66.0-1

gvfs-1.46.0-1

libcddb-1.3.2-10

libcdio-paranoia-10.2+2.0.1-1

libcdio-2.1.0-1

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 2.1.0
5Release: 1%{?_dist_release}
6Group: system
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: GPLv3+
11URL: http://www.gnu.org/software/libcdio/
12Source0: https://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
13Source2: libcdio-no_date_footer.hml
14Patch1: libcdio-0.80-paranoia-fix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: pkgconfig doxygen
18BuildRequires: ncurses-devel
19BuildRequires: help2man
20BuildRequires: gcc-c++
21Requires(post): /sbin/install-info
22Requires(preun): /sbin/install-info
23
24%description
25This library provides an interface for CD-ROM access. It can be used
26by applications that need OS- and device-independent access to CD-ROM
27devices.
28
29
30%package        devel
31Summary:        Development files for %{name}
32Summary(ja):    %{name} の開発用ファイル
33Group:          programming
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37This package contains development files for %{name}.
38
39
40%debug_package
41
42
43%prep
44%setup -q
45
46f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
47iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
48
49
50%build
51%configure \
52    --disable-vcd-info \
53    --disable-dependency-tracking \
54    --disable-rpath \
55    --disable-cddb \
56    --disable-static
57
58make %{?_smp_mflags}
59cd doc/doxygen
60sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
61cp %{SOURCE2} .
62./run_doxygen
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68
69rm -f $RPM_BUILD_ROOT%{_infodir}/dir
70find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
71
72rm -rf examples
73mkdir -p examples/C++
74cp -a example/{*.c,README} examples
75cp -a example/C++/{*.cpp,README} examples/C++
76
77
78%check
79# disable test using local CDROM
80%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
81            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
82            test/Makefile
83make check
84
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%post
91/sbin/ldconfig
92/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
93
94%preun
95if [ $1 = 0 ]; then
96        /sbin/install-info --delete %{_infodir}/%{name}.info \
97                %{_infodir}/dir 2>/dev/null || :
98fi
99
100%postun -p /sbin/ldconfig
101
102%files
103%defattr(-,root,root,-)
104%license COPYING
105%doc AUTHORS NEWS README README.libcdio THANKS TODO
106%{_bindir}/*
107%{_libdir}/*.so.*
108%{_infodir}/*
109%{_mandir}/man1/*
110
111
112%files devel
113%defattr(-,root,root,-)
114%doc doc/doxygen/html examples
115%{_includedir}/cdio
116%{_includedir}/cdio++
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119
120
121%changelog
122* Mon Sep 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
123- new upstream release.
124- disabled cddb.
125
126* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.93-1
127- updated to 0.93.
128
129* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
130- update to 0.92
131
132* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
133- rebuilt with rpm-4.8.1 for pkg-config
134- added --enable-cddb
135
136* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
137- new upstream release
138- dropt Patch1
139- removed static libraries from devel package
140
141* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
142- initial build for Vine Linux
143
144* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
145- added patch enabling libcdio_paranoia.pc
146
147* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
148- updated to 0.80
149- removed upstreamed patches
150- last GPLv2+ release
151
152* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
153- added patch to compile with gcc43
154
155* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
156- fixed security fix (was off by two)
157
158* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
159- updated to 0.79
160- fixes #427197 (Long Joliet file name overflows cdio's buffer)
161- fixes #341981 (multiarch conflicts in libcdio)
162
163* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
164- rebuilt
165
166* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
167- updated to 0.78.2 (#221359) (this time for real)
168
169* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
170- updated to 0.78.2 (#221359)
171
172* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
173- disabled iso9660 test case (fails for some reason with date problems)
174  this seems to be a known problem according to the ChangeLog
175
176* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
177 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
178
179* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
180- Updated to 0.77
181
182* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
183- Rebuilt
184
185* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
186- Rebuilt
187
188* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
189- Updated to 0.76.
190- Included doxygen generated documentation into -devel
191- Included examples into -devel
192
193* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
194- disable test accessing local CDROM drive (#164266)
195
196* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
197- Rebuilt without libcddb dependency (#164270)
198
199* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
200- Rebuilt
201
202* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
203- Updated to 0.75.
204
205* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
206- Updated to 0.74.
207
208* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
209- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
210- Run test suite during build.
211- Install Japanese man pages.
212
213* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
214- Updated to 0.73.
215
216* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
217- Fix FC4 build (#151468).
218- Build with dependency tracking disabled.
219
220* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
221- Updated to 0.70.
222
223* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
224- Updated to 0.69.
225- Removed broken iso-read.
226- Split Requires(pre,post).
227- Added BuildReq pkgconfig.
228
229* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
230- Initial RPM release.
231
Note: See TracBrowser for help on using the repository browser.