source: projects/specs/trunk/lib/libc/libcap/libcap-vl.spec @ 12382

Revision 12382, 7.6 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

SDL2-2.0.12-1

SDL2_image-2.0.5-1

SDL2_mixer-2.0.4-1

SDL2_ttf-2.0.15-1

babl-0.1.74-1

bubblewrap-0.4.1-1

gegl04-0.4.22-1

libcap-2.33-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.33
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2
13Source: https://mirrors.edge.kernel.org/pub/linux/libs/security/linux-privs/libcap2/%{name}-%{version}.tar.xz
14Source1: getpcaps.8
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libattr-devel
18BuildRequires: pam-devel
19BuildRequires: glibc-static
20
21%description
22libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
23draft 15 capabilities.
24
25%package devel
26Summary: Development files for libcap
27Summary(ja): libcap の開発用ファイル
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32Development files (Headers, libraries for static linking, etc) for libcap.
33
34libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
35draft 15 capabilities.
36
37Install libcap-devel if you want to develop or compile applications using
38libcap.
39
40%package static
41Summary: static library of libcap
42Summary(ja): libcap のスタティックライブラリ
43Group: Development/Libraries
44Requires: %{name}-devel = %{version}-%{release}
45
46%description static
47This package includes the static library of libpcap
48
49# compat32
50%package -n compat32-%{name}
51Summary: Library for getting and setting POSIX.1e capabilities
52Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
53Group: System Environment/Libraries
54
55%description -n compat32-%{name}
56libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
57draft 15 capabilities.
58
59%package -n compat32-%{name}-devel
60Summary: Development files for libcap
61Summary(ja): libcap の開発用ファイル
62Group: Development/Libraries
63Requires: compat32-%{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65
66%description -n compat32-%{name}-devel
67Development files (Headers, libraries for static linking, etc) for libcap.
68
69libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
70draft 15 capabilities.
71
72Install libcap-devel if you want to develop or compile applications using
73libcap.
74
75
76%prep
77%setup -q
78# %patch0 -p1
79
80sed -i \
81        -e 's| -O2 | $(RPM_OPT_FLAGS) |' \
82        -e 's| #-g| $(RPM_LD_FLAGS) #-g|' \
83        Make.Rules
84
85%build
86# libcap can not be build with _smp_mflags:
87make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
88     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
89
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install RAISE_SETFCAP=no \
94             DESTDIR=${RPM_BUILD_ROOT} \
95             LIBDIR=/%{_lib} \
96             SBINDIR=%{_sbindir} \
97             INCDIR=%{_includedir} \
98             MANDIR=%{_mandir}/ \
99             PKGCONFIGDIR=%{_libdir}/pkgconfig/ \
100             COPTFLAG="$RPM_OPT_FLAGS"
101mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
102#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
103mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
104
105chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
106
107# need to build init.lxc.static
108mv %{buildroot}/%{_lib}/libcap.a %{buildroot}/%{_libdir}/libcap.a
109mv %{buildroot}/%{_lib}/libpsx.a %{buildroot}/%{_libdir}/libpsx.a
110
111cp -f %{SOURCE1} %{buildroot}/%{_mandir}/man8/
112
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117
118%post -p /sbin/ldconfig
119
120%postun -p /sbin/ldconfig
121
122%post -n compat32-%{name} -p /sbin/ldconfig
123
124%postun -n compat32-%{name} -p /sbin/ldconfig
125
126
127%files
128%defattr(-,root,root)
129%license License
130%doc doc/capability.notes
131/%{_lib}/*.so.*
132%{_sbindir}/*
133%{_mandir}/man1/*
134%{_mandir}/man8/*
135/%{_lib}/security/pam_cap.so
136
137%files devel
138%defattr(-,root,root)
139%{_includedir}/*
140/%{_lib}/*.so
141%{_libdir}/pkgconfig/*
142%{_mandir}/man3/*
143
144%files static
145%defattr(-,root,root)
146%{_libdir}/*.a
147
148# compat32
149%if %{build_compat32}
150%files -n compat32-%{name}
151%defattr(-,root,root)
152/%{_lib}/*.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156/%{_lib}/*.so
157%endif
158
159%changelog
160* Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.33-1
161- new upstream release.
162- dropped Patch1: made to get same effect by another way.
163
164* Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.27-1
165- new upstream release.
166
167* Sun Jun 26 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25-1
168- new upstream release.
169- added Source1.
170- added libcap-static.
171
172* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.24-1
173- new upstream release
174- change tarfile format
175- change flags in install section
176- add patch1, drop patch0 (patch1 from fedora)
177
178* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-4
179- rebuild with VineSeed environment
180
181* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
182- add BuildRequires: pam-devel
183
184* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
185- rebuilt with current VineSeed
186
187* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
188- new upstream release
189- remove compat library (libpcap-1.10)
190
191* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
192- added compat32 package for x86_64 arch support
193
194* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
195- source updated
196- built with libattr 2.4.41
197
198* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
199- rebuilt
200
201* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
202- initial build for Vine Linux based on FC package
203
204* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
205- build with gcc-4
206
207* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
208- rebuilt
209
210* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
211- Fix wrong typedef in userland patch (#98801)
212
213* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
214- rebuilt
215
216* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
217- rebuilt
218
219* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
220- rebuilt
221
222* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
223- use _manpath
224
225* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
226- rebuilt
227
228* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
229- rebuilt
230
231* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
232- set execute bits on library so that requires are generated.
233
234* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
235- Removed %%name macro sillyness from package Summary, description text, etc.
236- Removed archaic Prefix: tag
237- lib64 fixes everywhere to use _lib, _libdir, etc
238- Removed deletion of RPM_BUILD_DIR from %%clean section
239- Added -q flag to setup macro
240- Severely cleaned up spec file, and removed usage of perl
241
242* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
243- CFLAGS was using COPTFLAG variable, not COPTFLAGS
244- build with -fpic
245- apply the IA-64 patch everywhere, use capget/capset from glibc,
246  not directly as _syscall (as it is broken on IA-32 with -fpic)
247- reenable alpha
248
249* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
250- automated rebuild
251
252* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
253- Exclude alpha for now, apparent gcc bug.
254
255* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
256- Fix sys/capabilities.h header (#55727)
257- Move to /lib, some applications seem to be using this rather early
258  (#55733)
259
260* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
261- Add post,postun scripts
262
263* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
264- don't build libcap.so.1 with ld -shared, but gcc -shared
265
266* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
267- Rebuild - it was missing for alpha
268
269* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
270- add s390/s390x support
271
272* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
273- initial RPM
274- fix build on ia64
Note: See TracBrowser for help on using the repository browser.