source: projects/specs/trunk/lib/libb/libbytesize/libbytesize-vl.spec @ 12000

Revision 12000, 13.5 KB checked in by tomop, 5 years ago (diff)

new: elogind-239.3 (and packages that depends on elogind)

Line 
1%define realname bytesize
2%define with_python2 1
3%define with_python3 1
4%define with_gtk_doc 1
5
6%if %{with_python3} == 0
7%define python3_opts --without-python3
8%endif
9%if %{with_python2} == 0
10%define python2_opts --without-python2
11%endif
12
13%define configure_opts %{?python3_opts} %{?python2_opts}
14
15Name:         libbytesize
16Version:      1.4
17Release:      2%{?_dist_release}
18Summary:      A library for working with sizes in bytes
19License:      LGPLv2+
20URL:          https://github.com/storaged-project/libbytesize
21
22Vendor:       Project Vine
23Distribution: Vine Linux
24
25Source0:      https://github.com/storaged-project/libbytesize/releases/download/%{version}-%{release}/%{name}-%{version}.tar.gz
26
27BuildRequires: gcc
28BuildRequires: gmp-devel
29BuildRequires: mpfr-devel
30BuildRequires: pcre-devel
31BuildRequires: gettext-devel
32%if %{with_python2}
33BuildRequires: python-devel
34BuildRequires: python-rpm-macros
35%endif
36%if %{with_python3}
37BuildRequires: python3-devel
38BuildRequires: python3-rpm-macros
39%endif
40%if %{with_gtk_doc}
41BuildRequires: gtk-doc
42%endif
43
44%description
45The libbytesize is a C library that facilitates work with sizes in
46bytes. Be it parsing the input from users or producing a nice human readable
47representation of a size in bytes this library takes localization into
48account. It also provides support for sizes bigger than MAXUINT64.
49
50%package devel
51Summary:  Development files for libbytesize
52Requires: %{name}%{?_isa} = %{version}-%{release}
53
54%description devel
55This package contains header files and pkg-config files needed for development
56with the libbytesize library.
57
58%if %{with_python2}
59%package -n python-%{realname}
60Summary: Python 2 bindings for libbytesize
61%{?python_provide:%python_provide python2-%{realname}}
62%{?python_provide:%python_provide python2-libbytesize}
63Requires: %{name}%{?_isa} = %{version}-%{release}
64Requires: python-six
65
66%description -n python-%{realname}
67This package contains Python 2 bindings for libbytesize making the use of
68the library from Python 2 easier and more convenient.
69%endif
70
71%if %{with_python3}
72%package -n python3-%{realname}
73Summary: Python 3 bindings for libbytesize
74Requires: %{name}%{?_isa} = %{version}-%{release}
75Requires: python3-six
76
77%description -n python3-%{realname}
78This package contains Python 3 bindings for libbytesize making the use of
79the library from Python 3 easier and more convenient.
80%endif
81
82%prep
83%setup -q -n %{name}-%{version}
84
85%build
86%configure %{?configure_opts}
87%{__make} %{?_smp_mflags}
88
89%install
90%{make_install}
91find %{buildroot} -type f -name "*.la" | xargs %{__rm}
92%find_lang %{name}
93
94
95%post
96/sbin/ldconfig
97
98%postun
99/sbin/ldconfig
100
101
102%files -f %{name}.lang
103%doc README.md
104%{!?_licensedir:%global license %%doc}
105%license LICENSE
106%{_libdir}/libbytesize.so.*
107
108%files devel
109%{_libdir}/libbytesize.so
110%dir %{_includedir}/bytesize
111%{_includedir}/bytesize/bs_size.h
112%{_libdir}/pkgconfig/bytesize.pc
113%if %{with_gtk_doc}
114%{_datadir}/gtk-doc/html/libbytesize
115%endif
116
117%if %{with_python2}
118%files -n python-%{realname}
119%dir %{python_sitearch}/bytesize
120%{python_sitearch}/bytesize/*
121%endif
122
123%if %{with_python3}
124%files -n python3-%{realname}
125%dir %{python3_sitearch}/bytesize
126%{python3_sitearch}/bytesize/*
127#%{python3_sitearch}/bytesize/__pycache__/*
128%endif
129
130%changelog
131* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4-2
132- initial build for Vine Linux.
133
134* Thu Aug 02 2018 Vojtech Trefny <vtrefny@redhat.com> - 1.4-1
135- Squashed 'translation-canary/' changes from 840c2d6..fccbb1b (vtrefny)
136- Make sure the test script fails if one of the test runs fail (vtrefny)
137- Do not try to run python2 tests without python2 support (vtrefny)
138- Fix licence header for "gettext.h" (vtrefny)
139- Do not use rpm to check for Zanata client (vtrefny)
140- Use new ldconfig_scriptlets macro in spec (vtrefny)
141
142* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-5
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
144
145* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 1.3-4
146- Rebuilt for Python 3.7
147
148* Fri Jun 29 2018 Vojtech Trefny <vtrefny@redhat.com> - 1.3-3
149- Use new ldconfig_scriptlets macro in spec
150
151* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 1.3-2
152- Rebuilt for Python 3.7
153
154* Thu Apr 19 2018 Vojtech Trefny <vtrefny@redhat.com> - 1.3-1
155- Allow building libbytesize without Python 2 support (vtrefny)
156- Sync spec with downstream (vtrefny)
157- Add gcc to BuildRequires (vtrefny)
158- Fix links for documentation and GH project (vtrefny)
159- Add a HACKING.rst file (vpodzime)
160- Do not segfault when trying to bs_size_free NULL (vtrefny)
161
162* Wed Feb 21 2018 Vojtech Trefny <vtrefny@redhat.com> - 1.2-4
163- Add gcc to BuildRequires (vtrefny)
164
165* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-3
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
167
168* Fri Jan 05 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2-2
169- Update Python 2 dependency declarations to new packaging standards
170  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
171
172* Fri Sep 29 2017 Vratislav Podzimek <vpodzime@redhat.com> - 1.2-1
173- Use only version as a tag of the last release (vpodzime)
174- Do not require the glib-2.0 pkgconfig package (vpodzime)
175- Do not lie about tag creation (vpodzime)
176
177* Thu Sep 28 2017 Troy Dawson <tdawson@redhat.com> - 1.1-2
178- Cleanup spec file conditionals
179
180* Thu Sep 21 2017 Vratislav Podzimek <vpodzime@redhat.com> - 1.1-1
181- Add NEWS.rst file (vtrefny)
182- Fix source and url in spec file (vtrefny)
183- Use only one git tag for new releases (vtrefny)
184- Actually translate the units when expected (vpodzime)
185- Add two temporary test files to .gitignore (vpodzime)
186
187* Thu Sep 14 2017 Vratislav Podzimek <vpodzime@redhat.com> - 1.0-1
188- Make more space for CI status image (vtrefny)
189- Include limits.h to make sure ULONG_MAX is defined (vpodzime)
190- Remove extra 'is' in two docstrings (vpodzime)
191- Properly support 64bit operands (vpodzime)
192
193* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.11-4
194- Python 2 binary package renamed to python2-libbytesize
195  See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
196
197* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11-3
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
199
200* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11-2
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
202
203* Wed Jun 14 2017 Vratislav Podzimek <vpodzime@redhat.com> - 0.11-1
204- Fix README file name (vtrefny)
205- Add a build status image to the README.md (vpodzime)
206- Remove "glibc-all-langpacks" from test dependencies (vtrefny)
207- Check for requires in generated spec file, not in the template (vtrefny)
208- Fix checking for available locales (vtrefny)
209- Fix library name in acinclude.m4 (vtrefny)
210- Do not try to run translation tests on CentOS/RHEL 7 (vtrefny)
211- Skip tests if they require unavailable locales (vpodzime)
212
213* Wed Apr 19 2017 Vratislav Podzimek <vpodzime@redhat.com> - 0.10-1
214- Fix installation without specifying --exec-prefix (martin)
215- Sync the spec file with downstream (vpodzime)
216
217* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9-2
218- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
219
220* Wed Jan 11 2017 Vratislav Podzimek <vpodzime@redhat.com> - 0.9-1
221- Allow the Size python class to be easily imported (vpodzime)
222- Make sure pyexecdir is defined (vpodzime)
223- Do not run Python 3 tests without python3 (vpodzime)
224- Disable python3 on RHEL (vpodzime)
225- Reflect the configuration in the spec file template (vpodzime)
226- Make documentation generation conditional (vpodzime)
227- Make python3 support conditional (vpodzime)
228- Require lower version of libpcre (vpodzime)
229- Sync the spec file with downstream (vpodzime)
230
231* Wed Dec 21 2016 Adam Williamson <awilliam@redhat.com> - 0.8-2
232- Rebuild for Python 3.6, again
233
234* Fri Dec 16 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.8-1
235- Add a docstring to python bindings (vpodzime)
236- Neutralize None as an operand for math operations (vpodzime)
237- Add targets for checking and installing test requirements (vpodzime)
238- Fix 'make local' (vtrefny)
239- Make the python packages own their package directories (vpodzime)
240- Don't compare translated and untranslated representations (vpodzime)
241- replace_char_with_str: Fix the character count. (dshea)
242- Ditch autopoint. (dshea)
243
244* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.7-4
245- Rebuild for Python 3.6
246
247* Tue Sep 20 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.7-3
248- Prevent ignored exceptions in __del__ from happening (vpodzime)
249
250* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-2
251- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
252
253* Tue May 17 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.7-1
254- Re-run autogen.sh and configure before updating the .pot file (vpodzime)
255- Change where tests on translated strings are run. (dshea)
256- Squashed 'translation-canary/' changes from d6c0708..840c2d6 (dshea)
257- Make sure we get the tests result report in 'make ci' (vpodzime)
258- Add a new generic error code/enum for failures (vpodzime)
259- Do not ignore the return value from asprintf() (vpodzime)
260- Beware of the radix char when converting to Decimal (#1325705) (vpodzime)
261
262* Fri May  6 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.6-2
263- Beware of unsigned long int on 32bit arches (#1333149) (vpodzime)
264
265* Tue May 03 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.6-1
266- Add support for the ROUND_HALF_UP rounding mode (vpodzime)
267- Make sure we return the right radix char in human_readable() (vpodzime)
268- Allocate enough memory for char->str replacements (vpodzime)
269
270* Tue Apr 26 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.5-1
271- Create both libbytesize-$version and $version tags (vpodzime)
272- Update the .pot file with the new version (vpodzime)
273- Improve how we create changelog (vpodzime)
274- Try harder when getting OverflowError in division (#1326897) (vpodzime)
275- Neutralize the radix char before passing string to MPFR (#1326108) (vpodzime)
276- Run tests with en_US and fr_FR locales (vpodzime)
277- Run the tests with both python2 and python3 again (vpodzime)
278- Do not run the same tests 3 times as part of the 'ci' target (vpodzime)
279- Don't fail if just the best-effort cleanup fails (vpodzime)
280- Throw away the new .pot file when just running tests (vpodzime)
281- Make sure we return one of -1, 0, 1 from cmp functions (#1326113) (vpodzime)
282- Use cmp_bytes(size, bytes) when comparing to 0 (vpodzime)
283- Ignore all .po~ files (vpodzime)
284- Add translator comments (dshea)
285- Integrate translation-canary into the build. (dshea)
286- Run the translation-canary tests from make check. (dshea)
287- Squashed 'translation-canary/' content from commit d6c0708 (dshea)
288- Make 'make check' work. (dshea)
289- Remove files from po/ we don't need to track (vpodzime)
290- Ignore the compiled translation files (vpodzime)
291- Distribute and package the translations (vpodzime)
292- Add the necessary pieces for getting translations (vpodzime)
293
294* Thu Apr 14 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.4-3
295- Only require -lgmp and -lmpfr for static linking (vpodzime)
296
297* Fri Mar 11 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.4-2
298- Do not try to delete the C struct twice (vpodzime)
299
300* Wed Mar 09 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.4-1
301- Add the __init__.py file to provide a proper package (vpodzime)
302- Merge pull request #7 from vpodzime/master-decimal_locale (vpodzime)
303- Make sure we pass a locale-agnostic string to Decimal() (vpodzime)
304- Adapt the package description to no longer using GI (vpodzime)
305- Make Size instances hashable (vpodzime)
306- Sync the spec file with downstream (vpodzime)
307
308* Wed Mar  9 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.3-3
309- Make sure we pass a locale-agnostic string to Decimal() (vpodzime)
310
311* Mon Mar  7 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.3-2
312- Make Size instances hashable (vpodzime)
313
314* Fri Feb 26 2016 Vratislav Podzimek <vpodzime@redhat.com> - 0.3-1
315- Packaging changes related to getting rid of GLib/GObject (vpodzime)
316- Adapt the python bindings and tests (vpodzime)
317- Get rid of GObject and GLib (vpodzime)
318- Define the __divmod__ method even for not dividing by Size (vpodzime)
319
320* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.2-3
321- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
322
323* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2
324- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
325
326* Fri Oct 23 2015 Vratislav Podzimek <vpodzime@redhat.com> - 0.2-1
327- Distribute the tests for overrides (vpodzime)
328- Fix the rpmlog target (vpodzime)
329- Respect the signs when doing division (vpodzime)
330- Add two more internal methods that may be required (vpodzime)
331- Do not pass negative numbers as guint64 when comparing with negative ints (vpodzime)
332- Round toward zero when converting bytes from float to int (vpodzime)
333- Make sure we return Size if doing operations with big integers (vpodzime)
334- Implement the __divmod__() method (vpodzime)
335- Do not try to convert negative int to an unsigned int when multiplying (vpodzime)
336- Fix and test the __deepcopy__ method (vpodzime)
337- Implement the evaluation of Size instance as a bool value (vpodzime)
338- Fix some issues in comparison functions and add tests (vpodzime)
339- Add a function for getting string representation of a unit (vpodzime)
340- Hook the overrides tests to the 'test' target (vpodzime)
341- Merge pull request #4 from japokorn/master-tests_03_python_override (vpodzime)
342- Added tests for Python override (japokorn)
343- Make sure our tests don't get broken by installed overrides (vpodzime)
344
345* Wed Oct 07 2015 Vratislav Podzimek <vpodzime@redhat.com> - 0.1-1
346- Initial release
Note: See TracBrowser for help on using the repository browser.