source: projects/specs/trunk/lib/libb/libbtctl/libbtctl-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%ifarch %ix86 x86_64 ppc ia64 armv4l sparc s390 s390x
2# defined to zero, because beehive doesn't do macros for BuildRequires
3%define with_mono 0
4%else
5%define with_mono 0
6%endif
7ExcludeArch: s390 s390x
8
9Summary: Library for the GNOME Bluetooth Subsystem
10Summary(ja): GNOME Bluetooth ¥µ¥Ö¥·¥¹¥Æ¥àÍѥ饤¥Ö¥é¥ê
11Name: libbtctl
12Version: 0.10.0
13Release: 6%{?_dist_release}
14License: GPL+
15Group: System Environment/Libraries
16URL: http://live.gnome.org/GnomeBluetooth
17Source: http://ftp.gnome.org/pub/gnome/sources/libbtctl/0.10/%{name}-%{version}.tar.bz2
18
19#----------------------------------------------------------------------------
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23#----------------------------------------------------------------------------
24BuildRequires: autoconf >= 0:2.57, bluez-libs-devel, glib2-devel, gtk-doc
25BuildRequires: openobex-devel >= 0:1.1, pygtk2-devel, gtk2-devel
26BuildRequires: python, python-devel, gettext, automake, libtool, intltool
27
28%if %{with_mono}
29%{expand BuildRequires: mono-devel gtk-sharp-gapi gtk-sharp}
30%endif
31
32Patch1: libbtctl-bluez4.patch
33Patch2: libbtctl-0.4.1-pydir.patch
34## Patch4: libbtctl-0.6.0-print.patch
35
36#----------------------------------------------------------------------------
37%description
38Library for the GNOME Bluetooth Subsystem
39
40%description -l ja
41GNOME Bluetooth ¥µ¥Ö¥·¥¹¥Æ¥àÍѥ饤¥Ö¥é¥ê
42
43#----------------------------------------------------------------------------
44%package devel
45Summary: Development files for libbtctl.
46Summary(ja): libbtctl ³«È¯¤Î¤¿¤á¤ÎDEVEL¥Ñ¥Ã¥±¡¼¥¸
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: glib2-devel
50
51%description devel
52This package contains the files needed for developing applications,
53which use libbtctl.
54
55%description devel -l ja
56libbtctl ¤ò»ÈÍѤ¹¤ë¥¢¥×¥ê¥±¡¼¥·¥ç¥ó³«È¯¤Î¤¿¤á¤ËɬÍפÊ
57¥Ø¥Ã¥À¡¼Îà¤Î¥Ñ¥Ã¥±¡¼¥¸
58
59#----------------------------------------------------------------------------
60%prep
61%setup -q
62%patch1 -p0 -b .bluez4
63%patch2 -p1 -b .pydir
64## %patch4 -p1 -b .print
65
66aclocal
67automake -a
68intltoolize -c -f
69autoconf
70
71%build
72%configure \
73%if %{with_mono}
74        ;
75%else
76        --disable-mono
77%endif
78
79# %%{?_smp_mflags} does not work
80make
81
82#----------------------------------------------------------------------------
83%install
84rm -rf $RPM_BUILD_ROOT
85make DESTDIR=$RPM_BUILD_ROOT install
86
87# we do not want .la files
88rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
89rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/*.a
90rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/*.la
91
92%find_lang %name
93
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99
100%postun -p /sbin/ldconfig
101
102#----------------------------------------------------------------------------
103%files -f %{name}.lang
104%defattr(-, root, root)
105%doc AUTHORS ChangeLog NEWS README
106%{_libdir}/lib*.so.*
107%{_libdir}/python?.?/site-packages/*btctl*
108%if %{with_mono}
109%{_libdir}/mono/gac/btctl/*/btctl.dll
110%{_libdir}/mono/libbtctl/btctl.dll
111%{_datadir}/gapi/btctl-api.xml
112%endif
113
114%files devel
115%defattr(-, root, root)
116%{_libdir}/lib*.so
117%{_libdir}/lib*.a
118%{_libdir}/pkgconfig/libbtctl.pc
119%{_includedir}/libbtctl
120%{_datadir}/gtk-doc/html/libbtctl
121%if %{with_mono}
122%{_libdir}/pkgconfig/libbtctl-sharp.pc
123%endif
124
125#----------------------------------------------------------------------------
126# Maintainers: babasaki@mindgear.org
127#
128#----------------------------------------------------------------------------
129%changelog
130* Fri Oct 24  2008 Seiichirou Babasaki 0.10.0-6
131- Update to 0.10.0 (VineSeed)
132- added "# Maintainers: " comments.
133- changed UTF-8 encode at libbtctl.vs.spec
134- FedoraCore - LOGS
135-- 0.10.0-5
136- Rebuild with patch for BlueZ 4.x
137-- 0.10.0-3
138-- made doc subpackage to avoid conflict on multiarch env.
139-- Resolves: #341931
140-- 0.10.0-2
141-- gcc43 rebuild
142-- 0.10.0-1
143-- Update to 0.10.0
144
145* Wed Jan 16 2008 Seiichirou Babasaki 0.9.0-4
146- Import bluez-libbtctl - Packager: Babasaki
147- fixed wrong Source URL
148- Updated specfile
149
150#----------------------------------------------------------------------------
151* Tue Sep 18 2007 - Ondrej Vasik <ovasik@redhat.com> - 0.9.0-3
152- fixed wrong Source URL
153
154* Thu Aug 23 2007 - Ondrej Vasik <ovasik@redhat.com> - 0.9.0-2
155- rebuilt for F8
156- changed License tag to GPL+
157
158* Thu Jul 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.9.0-1
159- Update to 0.9.0
160- Remove out-dated patches
161
162* Wed Feb 28 2007 Harald Hoyer <harald@redhat.com> - 0.8.2-3%{?dist}
163- specfile review
164- portet crash patch to 0.8.2
165
166* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.8.2-2%{?dist}
167- rebuild for python 2.5
168
169* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.2-1%{?dist}
170- version 0.8.2
171- Resolves: rhbz#215230
172
173* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-9.1
174- rebuild
175
176* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.6.0-9
177- rebuilt for openobex
178
179* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-8
180- Bump for new libbluetooth
181
182* Wed Jun  7 2006 Harald Hoyer <harald@redhat.com> - 0.6.0-7
183- printf format corrected
184- more build requires
185
186* Wed May 17 2006 Harald Hoyer <harald@redhat.com> 0.6.0-6
187- added more build requirements (bug #191981)
188
189* Thu Feb 23 2006 Matthias Clasen <mclasen@redhat.com> 0.6.0-5
190- try a fix for (#179413)
191
192* Thu Feb 23 2006 Harald Hoyer <harald@redhat.com> 0.6.0-2
193- rebuild
194
195* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> 0.6.0-1
196- version 0.6.0
197
198* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.0-1.2.1
199- bump again for double-long bug on ppc(64)
200
201* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.0-1.2
202- rebuilt for new gcc4.1 snapshot and glibc changes
203
204* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
205- rebuilt
206
207* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> 0.5.0-1
208- new version 0.5.0
209
210* Tue Jul 19 2005 Harald Hoyer <harald@redhat.com> 0.4.1-8
211- added gtk2-devel to BuildRequires
212
213* Thu Apr 21 2005 Harald Hoyer <harald@redhat.com> 0.4.1-7
214- rebuild with requires python-abi
215
216* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.4.1-6
217- devel req glib2-devel for pkgconfig (#152497)
218
219* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
220- rebuilt
221
222* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
223- rebuilt
224
225* Fri Oct 08 2004 Harald Hoyer <harald@redhat.de> 0.4.1-3
226- buildrequires pygtk2-devel
227
228* Fri Sep 24 2004 Harald Hoyer <harald@redhat.de> 0.4.1-2
229- split out devel package
230- require openobex >= 1.0.1
231- patch for lib64 python path
232
233* Thu Jul 22 2004 Harald Hoyer <harald@redhat.de> 0.4.1-1
234- version 0.4.1
235
236* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
237- rebuilt
238
239* Tue May 25 2004 Harald Hoyer <harald@redhat.de> 0.3-6
240- buildrequire bluez-libs-devel and glib2-devel
241
242* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
243- rebuilt
244
245* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
246- rebuilt
247
248* Tue Aug  5 2003 Harald Hoyer <harald@redhat.de> 0.3-4
249- make shared library
250
251* Tue Aug  5 2003 Harald Hoyer <harald@redhat.de> 0.3-3
252- BuildRequires bluez-sdp
253
254* Tue Jun 24 2003 Harald Hoyer <harald@redhat.de> 0.3-2
255- exclude arch s390
256
257* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.3-1
258- initial RPM
259
260
Note: See TracBrowser for help on using the repository browser.