source: projects/specs/trunk/lib/libb/libboost/libboost-vl.spec @ 8005

Revision 8005, 22.0 KB checked in by iwaim, 10 years ago (diff)

libboost 1.54.0-1

Line 
1%define major 1
2%define minor 54
3%define teeny 0
4%define tarname boost
5%define lnkver %{major}_%{minor}
6%define pkgver %{major}_%{minor}_%{teeny}
7
8%ifnarch %{ix86} x86_64
9  # Avoid using Boost.Context on non-x86 arches.  s390 is not
10  # supported at all and there were _syntax errors_ in PPC code.  This
11  # should be enabled on a case-by-case basis as the arches are tested
12  # and fixed.
13  %bcond_with context
14%else
15  %bcond_without context
16%endif
17
18Summary: Portable C++ source libraries
19Summary(ja): ポータブルな C++ ソースライブラリ
20Name: libboost
21Version: %{major}.%{minor}.%{teeny}
22Release: 1%{?_dist_release}
23Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
24Source1: user-config.jam
25License: distributable
26Group: System Environment/Libraries
27URL: http://www.boost.org/
28
29BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
30BuildRequires: libaio-devel lam
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33# https://svn.boost.org/trac/boost/ticket/6150
34Patch4: boost-1.50.0-fix-non-utf8-files.patch
35
36# Add a manual page for bjam, based on the on-line documentation:
37# http://www.boost.org/boost-build2/doc/html/bbv2/overview.html
38Patch5: boost-1.48.0-add-bjam-man-page.patch
39
40# https://bugzilla.redhat.com/show_bug.cgi?id=781859
41# The following tickets have yet to be fixed by upstream.
42# https://svn.boost.org/trac/boost/ticket/6413
43# https://svn.boost.org/trac/boost/ticket/8849
44Patch9: boost-1.53.0-attribute.patch
45
46# https://bugzilla.redhat.com/show_bug.cgi?id=828856
47# https://bugzilla.redhat.com/show_bug.cgi?id=828857
48Patch15: boost-1.50.0-pool.patch
49
50# https://bugzilla.redhat.com/show_bug.cgi?id=977098
51# https://svn.boost.org/trac/boost/ticket/8731
52Patch18: boost-1.54.0-__GLIBC_HAVE_LONG_LONG.patch
53
54# Upstream patches posted as release notes:
55# http://www.boost.org/users/history/version_1_54_0.html
56Patch19: 001-coroutine.patch
57Patch20: 002-date-time.patch
58Patch21: 003-log.patch
59
60# https://svn.boost.org/trac/boost/ticket/8826
61Patch22: boost-1.54.0-context-execstack.patch
62
63# https://svn.boost.org/trac/boost/ticket/8844
64Patch23: boost-1.54.0-bind-static_assert.patch
65
66# https://svn.boost.org/trac/boost/ticket/8847
67Patch24: boost-1.54.0-concept-unused_typedef.patch
68
69# https://svn.boost.org/trac/boost/ticket/5637
70Patch25: boost-1.54.0-mpl-print.patch
71
72# https://svn.boost.org/trac/boost/ticket/8859
73Patch26: boost-1.54.0-static_warning-unused_typedef.patch
74
75# https://svn.boost.org/trac/boost/ticket/8855
76Patch27: boost-1.54.0-math-unused_typedef.patch
77Patch28: boost-1.54.0-math-unused_typedef-2.patch
78
79# https://svn.boost.org/trac/boost/ticket/8853
80Patch31: boost-1.54.0-tuple-unused_typedef.patch
81
82# https://svn.boost.org/trac/boost/ticket/8854
83Patch32: boost-1.54.0-random-unused_typedef.patch
84
85# https://svn.boost.org/trac/boost/ticket/8856
86Patch33: boost-1.54.0-date_time-unused_typedef.patch
87Patch34: boost-1.54.0-date_time-unused_typedef-2.patch
88
89# https://svn.boost.org/trac/boost/ticket/8870
90Patch35: boost-1.54.0-spirit-unused_typedef.patch
91Patch36: boost-1.54.0-spirit-unused_typedef-2.patch
92
93# https://svn.boost.org/trac/boost/ticket/8871
94Patch37: boost-1.54.0-numeric-unused_typedef.patch
95
96# https://svn.boost.org/trac/boost/ticket/8872
97Patch38: boost-1.54.0-multiprecision-unused_typedef.patch
98
99# https://svn.boost.org/trac/boost/ticket/8874
100Patch42: boost-1.54.0-unordered-unused_typedef.patch
101
102# https://svn.boost.org/trac/boost/ticket/8876
103Patch43: boost-1.54.0-algorithm-unused_typedef.patch
104
105# https://svn.boost.org/trac/boost/ticket/8877
106Patch44: boost-1.54.0-graph-unused_typedef.patch
107
108# https://svn.boost.org/trac/boost/ticket/8878
109Patch45: boost-1.54.0-locale-unused_typedef.patch
110
111# https://svn.boost.org/trac/boost/ticket/8879
112Patch46: boost-1.54.0-property_tree-unused_typedef.patch
113
114# https://svn.boost.org/trac/boost/ticket/8880
115Patch47: boost-1.54.0-xpressive-unused_typedef.patch
116
117# https://svn.boost.org/trac/boost/ticket/8881
118Patch48: boost-1.54.0-mpi-unused_typedef.patch
119
120# https://svn.boost.org/trac/boost/ticket/8888
121Patch49: boost-1.54.0-python-unused_typedef.patch
122
123# https://svn.boost.org/trac/boost/ticket/8941
124Patch50: boost-1.54.0-lexical_cast-int128.patch
125
126# https://svn.boost.org/trac/boost/ticket/9038
127Patch51: boost-1.54.0-pool-test_linking.patch
128
129# https://svn.boost.org/trac/boost/ticket/9037
130Patch52: boost-1.54.0-thread-cond_variable_shadow.patch
131
132# This was already fixed upstream, so no tracking bug.
133Patch53: boost-1.54.0-pool-max_chunks_shadow.patch
134
135# https://svn.boost.org/trac/boost/ticket/9041
136Patch54: boost-1.54.0-thread-link_atomic.patch
137
138# https://bugzilla.redhat.com/show_bug.cgi?id=1002578
139# https://svn.boost.org/trac/boost/ticket/9065
140Patch55: boost-1.54.0-interprocess-atomic_cas32-ppc.patch
141
142Vendor: Project Vine
143Distribution: Vine Linux
144
145Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
146Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
147Obsoletes: %{name}-python-devel %{name}-regex-devel
148Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
149Obsoletes: %{name}-thread-devel %{name}-wave-devel
150
151%description
152Boost provides free peer-reviewed portable C++ source libraries.  The emphasis
153is on libraries which work well with the C++ Standard Library.  The libraries
154are intended to be widely useful, and are in regular use by thousands of
155programmers across a broad spectrum of applications.
156
157A further goal is to establish "existing practice" and provide reference
158implementations so that Boost libraries are suitable for eventual
159standardization. Ten Boost libraries will be included in the C++ Standards
160Committee's upcoming C++ Standard Library Technical Report as a step toward
161becoming part of a future C++ Standard.
162
163%description -l ja
164Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
165準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
166ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
167
168さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
169を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
170として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
171含まれる予定です。
172
173%package atomic
174Summary: Run-Time component of boost atomic library
175Group: System Environment/Libraries
176
177%description atomic
178
179Run-Time support for Boost.Atomic, a library that provides atomic data
180types and operations on these data types, as well as memory ordering
181constraints required for coordinating multiple threads through atomic
182variables.
183
184%package chrono
185Summary: Run-Time component of boost chrono library
186Group: System Environment/Libraries
187Requires: %{name}-system = %{version}-%{release}
188
189%description chrono
190
191Run-Time support for Boost.Chrono, a set of useful time utilities.
192
193%if %{with context}
194%package context
195Summary: Run-Time component of boost context switching library
196Group: System Environment/Libraries
197
198%description context
199
200Run-Time support for Boost.Context, a foundational library that
201provides a sort of cooperative multitasking on a single thread.
202%endif
203
204%package devel
205Summary: Header files and libraries for developing apps which will use %{name}
206Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
207Group: Development/Libraries
208Requires: %{name} = %{version}-%{release}
209
210%description devel
211The %{name}-devel package contains the header files and libraries needed
212to develop programs that use the Boost library.
213
214%description devel -l ja
215%{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
216ヘッダファイルやライブラリを含んでいます。
217
218%package doc
219Summary: Documents of %{name}
220Summary(ja): %{name}のドキュメント
221Group: Applications/Documentation
222Requires: %{name} = %{version}-%{release}
223
224%description doc
225The %{name}-doc package contains the documents about the boost library.
226
227%description doc -l ja
228%{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
229
230%package date-time
231Summary: Set of data-time libralies in %{name}
232Group: System Environment/Libraries
233Requires: %{name} = %{version}-%{release}
234
235%description date-time
236Set of data-time libralies in %{name}
237
238%package filesystem
239Summary: Set of filesystem operation libralies in %{name}
240Group: System Environment/Libraries
241Requires: %{name} = %{version}-%{release}
242
243%description filesystem
244Set of filesystem operation libralies in %{name}
245
246%package graph
247Summary: Set of Graphviz libralies in %{name}
248Group: System Environment/Libraries
249Requires: %{name} = %{version}-%{release}
250
251%description graph
252Set of Graphviz libralies in %{name}
253
254%package iostreams
255Summary: Set of streams and i/o filters libralies in %{name}
256Group: System Environment/Libraries
257Requires: %{name} = %{version}-%{release}
258
259%description iostreams
260Set of streams and i/o filters libralies in %{name}
261
262%package locale
263Summary: Run-Time component of boost locale library
264Group: System Environment/Libraries
265Requires: %{name}-chrono = %{version}-%{release}
266Requires: %{name}-system = %{version}-%{release}
267Requires: %{name}-thread = %{version}-%{release}
268
269%description locale
270
271Run-Time support for Boost.Locale, a set of localization and Unicode
272handling tools.
273
274%package log
275Summary: Run-Time component of boost logging library
276Group: System Environment/Libraries
277
278%description log
279
280Boost.Log library aims to make logging significantly easier for the
281application developer.  It provides a wide range of out-of-the-box
282tools along with public interfaces for extending the library.
283
284%package math
285Summary: Set of math libralies in %{name}
286Group: System Environment/Libraries
287Requires: %{name} = %{version}-%{release}
288
289%description math
290Set of math libralies in %{name}
291
292%package program-options
293Summary: Set of program options libralies in %{name}
294Group: System Environment/Libraries
295Requires: %{name} = %{version}-%{release}
296
297%description program-options
298Set of program options libralies in %{name}
299
300%package python
301Summary: Set of Python libralies in %{name}
302Group: System Environment/Libraries
303Requires: %{name} = %{version}-%{release}
304
305%description python
306Set of Python libralies in %{name}
307
308%package random
309Summary: Set of random number generation libralies in %{name}
310Group: System Environment/Libraries
311Requires: %{name} = %{version}-%{release}
312
313%description random
314Set of random number generation libralies in %{name}
315
316%package regex
317Summary: Set of regular expression libralies in %{name}
318Group: System Environment/Libraries
319Requires: %{name} = %{version}-%{release}
320
321%description regex
322Set of regular expression libralies in %{name}
323
324%package serialization
325Summary: Set of serialization libralies in %{name}
326Group: System Environment/Libraries
327Requires: %{name} = %{version}-%{release}
328
329%description serialization
330Set of serialization libralies in %{name}
331
332%package signals
333Summary: Set of signals and slots libralies in %{name}
334Group: System Environment/Libraries
335Requires: %{name} = %{version}-%{release}
336
337%description signals
338Set of signals and slots libralies in %{name}
339
340%package system
341Summary: Operating system support
342Group: System Environment/Libraries
343Requires: %{name} = %{version}-%{release}
344
345%description system
346Operating system support, including the diagnostics support
347that will be part of the C++0x standard library
348
349%package test
350Summary: Set of libraries for writing and executing tests in %{name}
351Group: System Environment/Libraries
352Requires: %{name} = %{version}-%{release}
353
354%description test
355Set of libraries for writing and executing tests in %{name}
356
357%package thread
358Summary: Set of multi-thread libraries in %{name}
359Group: System Environment/Libraries
360Requires: %{name} = %{version}-%{release}
361
362%description thread
363Set of multi-thread libraries in %{name}
364
365%package timer
366Summary: Run-Time component of boost timer library
367Group: System Environment/Libraries
368Requires: %{name}-chrono = %{version}-%{release}
369Requires: %{name}-system = %{version}-%{release}
370
371%description timer
372
373"How long does my C++ code take to run?"
374The Boost Timer library answers that question and does so portably,
375with as little as one #include and one additional line of code.
376
377%package wave
378Summary: Set of wave libraries in %{name}
379Group: System Environment/Libraries
380Requires: %{name} = %{version}-%{release}
381
382%description wave
383Set of wave libraries in %{name}
384
385%prep
386%setup -q -n %{tarname}_%{pkgver}
387cp %SOURCE1 user-config.jam
388
389%patch4 -p1
390%patch5 -p1
391%patch9 -p1
392%patch15 -p0
393%patch18 -p1
394%patch19 -p1
395%patch20 -p1
396%patch21 -p1
397%patch22 -p1
398%patch23 -p1
399%patch24 -p1
400%patch25 -p0
401%patch26 -p1
402%patch27 -p1
403%patch28 -p0
404%patch31 -p0
405%patch32 -p0
406%patch33 -p0
407%patch34 -p1
408%patch35 -p1
409%patch36 -p1
410%patch37 -p1
411%patch38 -p1
412%patch42 -p1
413%patch43 -p1
414%patch44 -p1
415%patch45 -p1
416%patch46 -p1
417%patch47 -p1
418%patch48 -p1
419%patch49 -p1
420%patch50 -p0
421%patch51 -p1
422%patch52 -p1
423%patch53 -p1
424%patch54 -p1
425%patch55 -p1
426
427%build
428## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
429## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
430./bootstrap.sh \
431        --prefix=%{_prefix} \
432        --libdir=%{_libdir} \
433        --includedir=%{_includedir} \
434        --with-icu=%{_prefix} \
435        --with-python-version=%{pyver}
436
437./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
438
439%install
440rm -rf $RPM_BUILD_ROOT
441## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
442
443./bjam \
444        --prefix=${RPM_BUILD_ROOT}%{_prefix} \
445        --libdir=${RPM_BUILD_ROOT}%{_libdir} \
446        --user-config=./user-config.jam \
447        link=shared \
448        install
449
450ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
451
452# remove unuse files
453rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
454
455# unnead for libboost-1.42
456## pushd $RPM_BUILD_ROOT/%{_libdir}
457## for i in libboost_*-mt.so
458## do
459##   ln -sf $i $(echo $i | cut -f1 -d-).so
460## done
461## popd
462
463## %post devel
464## if [ $1 = 2 ]; then
465##    rm -rf %{_includedir}/%{tarname}
466## fi
467## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
468##
469## %postun devel
470## if [ $1 = 0 ]; then
471##    rm -rf %{_includedir}/%{tarname}
472## fi
473
474%post atomic -p /sbin/ldconfig
475%post chrono -p /sbin/ldconfig
476%if %{with context}
477%post context -p /sbin/ldconfig
478%endif
479%post date-time -p /sbin/ldconfig
480%post filesystem -p /sbin/ldconfig
481%post graph -p /sbin/ldconfig
482%post iostreams -p /sbin/ldconfig
483%post locale -p /sbin/ldconfig
484%post log -p /sbin/ldconfig
485%post math -p /sbin/ldconfig
486%post program-options -p /sbin/ldconfig
487%post python -p /sbin/ldconfig
488%post regex -p /sbin/ldconfig
489%post serialization -p /sbin/ldconfig
490%post signals -p /sbin/ldconfig
491%post system -p /sbin/ldconfig
492%post test -p /sbin/ldconfig
493%post thread -p /sbin/ldconfig
494%post timer -p /sbin/ldconfig
495%post wave -p /sbin/ldconfig
496
497%postun atomic -p /sbin/ldconfig
498%postun chrono -p /sbin/ldconfig
499%if %{with context}
500%postun context -p /sbin/ldconfig
501%endif
502%postun date-time -p /sbin/ldconfig
503%postun filesystem -p /sbin/ldconfig
504%postun graph -p /sbin/ldconfig
505%postun iostreams -p /sbin/ldconfig
506%postun locale -p /sbin/ldconfig
507%postun log -p /sbin/ldconfig
508%postun math -p /sbin/ldconfig
509%postun program-options -p /sbin/ldconfig
510%postun python -p /sbin/ldconfig
511%postun regex -p /sbin/ldconfig
512%postun serialization -p /sbin/ldconfig
513%postun signals -p /sbin/ldconfig
514%postun system -p /sbin/ldconfig
515%postun test -p /sbin/ldconfig
516%postun thread -p /sbin/ldconfig
517%postun timer -p /sbin/ldconfig
518%postun wave -p /sbin/ldconfig
519
520%clean
521rm -rf $RPM_BUILD_ROOT
522
523%files
524%defattr(-,root,root)
525%doc LICENSE_1_0.txt
526
527%files atomic
528%defattr(-, root, root, -)
529%doc LICENSE_1_0.txt
530%{_libdir}/libboost_atomic.so*
531
532%files chrono
533%defattr(-, root, root, -)
534%doc LICENSE_1_0.txt
535%{_libdir}/libboost_chrono.so*
536
537%if %{with context}
538%files context
539%defattr(-, root, root, -)
540%doc LICENSE_1_0.txt
541%{_libdir}/libboost_context.so*
542%endif
543
544%files devel
545%defattr(-,root,root)
546%{_includedir}/boost/
547%{_includedir}/boost-%{lnkver}
548
549%files doc
550%doc index.htm index.html boost.css boost.png rst.css doc libs more
551
552%files date-time
553%doc LICENSE_1_0.txt
554%{_libdir}/%{name}_date_time*.so*
555
556%files filesystem
557%doc LICENSE_1_0.txt
558%{_libdir}/%{name}_filesystem*.so*
559
560%files graph
561%doc LICENSE_1_0.txt
562%{_libdir}/%{name}_graph*.so*
563%{_libdir}/%{name}_mpi*.so*
564%{_libdir}/mpi*.so*
565
566%files iostreams
567%doc LICENSE_1_0.txt
568%{_libdir}/%{name}_iostreams*.so*
569
570%files locale
571%defattr(-, root, root, -)
572%doc LICENSE_1_0.txt
573%{_libdir}/libboost_locale.so*
574
575%files log
576%defattr(-, root, root, -)
577%doc LICENSE_1_0.txt
578%{_libdir}/libboost_log.so*
579%{_libdir}/libboost_log_setup.so*
580
581%files math
582%doc LICENSE_1_0.txt
583%{_libdir}/%{name}_math_*.so*
584
585%files program-options
586%doc LICENSE_1_0.txt
587%{_libdir}/%{name}_program_options*.so*
588
589%files python
590%doc LICENSE_1_0.txt
591%{_libdir}/%{name}_python*.so*
592
593%files random
594%doc LICENSE_1_0.txt
595%{_libdir}/%{name}_random*.so*
596
597%files regex
598%doc LICENSE_1_0.txt
599%{_libdir}/%{name}_regex*.so*
600
601%files serialization
602%doc LICENSE_1_0.txt
603%{_libdir}/%{name}_serialization*.so*
604%{_libdir}/%{name}_wserialization*.so*
605
606%files signals
607%doc LICENSE_1_0.txt
608%{_libdir}/%{name}_signals*.so*
609
610%files system
611%doc LICENSE_1_0.txt
612%{_libdir}/%{name}_system*.so*
613
614%files test
615%doc LICENSE_1_0.txt
616%{_libdir}/%{name}_prg_exec_monitor*.so*
617%{_libdir}/%{name}_unit_test_framework*.so*
618
619%files thread
620%doc LICENSE_1_0.txt
621%{_libdir}/%{name}_thread*.so*
622
623%files timer
624%defattr(-, root, root, -)
625%doc LICENSE_1_0.txt
626%{_libdir}/libboost_timer.so*
627
628%files wave
629%doc LICENSE_1_0.txt
630%{_libdir}/%{name}_wave*.so*
631
632%changelog
633* Mon Nov 25 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.54.0-1
634- update tp boost_1_54_0
635- all package: including license file
636- drop boost_filesystem patch (Patch0)
637- sync Fedora boost-1.54.0-5.fc21
638 - new packages: atomic, chrono, context, locale, log, timer
639 - add patches
640  - Patch4, 5, 9, 15, 18..28, 31..38, 42..55
641
642* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.45.0-2
643- fixed crashing throwing exception
644  "std::runtime_error: locale::facet::_S_create_c_locale name not valid"
645  on some systems (FreeBSD and some linuxes) when current locale
646  (LANG,LC_ALL) is not "C"
647
648* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
649- updated to boost_1_45_0
650- added random sub-package
651
652* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
653- rebuilt again on ppc
654
655* Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
656- rebuilt with libicu-4.4
657
658* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
659- added "-licui18n" to bjam
660- added BR: lam
661
662* Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
663- updated to boost_1_42_0
664- rebuilt with new toolchain and python-2.6
665- added user-config.jam to make libboost_mpi
666- added BR: libaio-devel
667- added %%{post,postun} -p /sbin/ldconfig
668- dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
669- dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
670- dropt %%{post,postun} devel section
671
672* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
673- rebuilt with libicu-4.0.1
674- changed Group to System Environment/Libraries (except devel package)
675
676* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
677- new upstream release
678- add -math subpackage
679
680* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
681- build with python-2.5
682- add libboost_XXXX.so symlinks
683
684* Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
685- upstream release
686- applied new versioning policy
687- add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
688- add new package libboost-system
689- Obsolete: *-devel packages
690
691* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
692- rebuilt with libicu-3.6
693- changed doc Group to Applications/Documentation
694
695* Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
696- upstream release
697
698* Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
699- add --libdir=%%{_libdir} to cope with x86_64 environment
700
701* Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
702- upstream release
703- use Easy Build and Install process with ./configure
704- add BuildRequires: libicu-devel
705- remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
706- add new packages: libboost-graph, libboost-graph-devel, libboost-wave
707- add files to doc package
708
709* Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
710- rebuilt with new toolchain
711
712* Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
713- upstream release
714
715* Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
716- fixed typo in Groups:
717- devel packages also moved to Development/Libraries group
718
719* Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
720- spec modified to avoid errors on non-ix86 archtecture
721  (previously the path linuxx86 was explicitly used)
722
723* Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
724- initial release for Vine Linux
725
726* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
727- link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
728
729* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
730- change package name from boost to libboost
731- separated into sub-packages
732
733* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
734- upstream release
735- add BuildRequires: bzip2-devel zlib-devel
736
737* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
738- added so.* file
739
740* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
741- moved %post, %postun script to -devel package
742
743* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
744- moved doc/html to -devel package
745- make a symbolic link on %{_includedir}/boost
746
747* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
748- fixed character code to euc-jp
749
750* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
751- add %doc files
752
753* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
754- remove Requires
755- split -devel package
756
757* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
758- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.