source: projects/specs/trunk/lib/libb/libbonoboui/libbonoboui-vl.spec @ 4616

Revision 4616, 9.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define libxml2_version 2.7.7
2%define orbit2_version 2.14.19
3%define libbonobo_version 2.32.0
4%define libgnomecanvas_version 2.30.2
5%define libgnome_version 2.32.0
6%define libart_lgpl_version 2.3.12
7%define gtk2_version 2.22.0
8%define libglade2_version 2.6.0
9
10%define po_package libbonoboui-2.0
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Summary: Bonobo user interface components
15Summary(ja): Bonobo ユーザインタフェースコンポーネント
16Name: libbonoboui
17Version: 2.24.5
18Release: 1%{?_dist_release}
19URL: http://ftp.gnome.org/
20Source0: http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.24/%{name}-%{version}.tar.bz2
21Source2: bonoboui-fixed-ltmain.sh
22
23License: LGPL
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27Requires: libxml2 >= %{libxml2_version}
28Requires: ORBit2 >= %{orbit2_version}
29Requires: libbonobo >= %{libbonobo_version}
30Requires: libgnomecanvas >= %{libgnomecanvas_version}
31Requires: libgnome >= %{libgnome_version}
32Requires: libart_lgpl >= %{libart_lgpl_version}
33Requires: gtk2 >= %{gtk2_version}
34Requires: libglade2 >= %{libglade2_version}
35
36BuildRequires: libxml2-devel >= %{libxml2_version}
37BuildRequires: ORBit2-devel >= %{orbit2_version}
38BuildRequires: libbonobo-devel >= %{libbonobo_version}
39BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
40BuildRequires: libgnome-devel >= %{libgnome_version}
41BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
42BuildRequires: gtk2-devel >= %{gtk2_version}
43BuildRequires: libglade2-devel >= %{libglade2_version}
44BuildRequires: popt-devel
45BuildRequires: intltool >= 0.14-1
46BuildRequires: libtool >= 1.5
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52Bonobo is a component system based on CORBA, used by the GNOME
53desktop.  libbonoboui contains the user interface related components
54that come with Bonobo.
55
56%package devel
57Summary: Libraries and headers for libbonoboui
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: libxml2-devel >= %{libxml2_version}
61Requires: ORBit2-devel >= %{orbit2_version}
62Requires: libbonobo-devel >= %{libbonobo_version}
63Requires: libgnomecanvas-devel >= %{libgnomecanvas_version}
64Requires: libgnome-devel >= %{libgnome_version}
65Requires: libart_lgpl-devel >= %{libart_lgpl_version}
66Requires: gtk2-devel >= %{gtk2_version}
67Requires: libglade2-devel >= %{libglade2_version}
68Conflicts: bonobo-devel < 1.0.8
69
70%description devel
71Bonobo is a component system based on CORBA, used by the GNOME desktop.
72libbonoboui contains GUI components that come with Bonobo.
73
74This package contains header files used to compile programs that
75use libbonoboui.
76
77# compat32
78%package -n compat32-%{name}
79Summary: Bonobo user interface components
80Summary(ja): Bonobo ユーザインタフェースコンポーネント
81Group: System Environment/Libraries
82Requires: %{name} = %{version}-%{release}
83
84%description -n compat32-%{name}
85Bonobo is a component system based on CORBA, used by the GNOME
86desktop.  libbonoboui contains the user interface related components
87that come with Bonobo.
88
89%package -n compat32-%{name}-devel
90Summary: Libraries and headers for libbonoboui
91Group: Development/Libraries
92Requires: %{name}-devel = %{version}-%{release}
93Requires: compat32-%{name} = %{version}-%{release}
94Requires: compat32-libxml2-devel >= %{libxml2_version}
95Requires: compat32-ORBit2-devel >= %{orbit2_version}
96Requires: compat32-libbonobo-devel >= %{libbonobo_version}
97Requires: compat32-libgnomecanvas-devel >= %{libgnomecanvas_version}
98Requires: compat32-libgnome-devel >= %{libgnome_version}
99Requires: compat32-libart_lgpl-devel >= %{libart_lgpl_version}
100Requires: compat32-gtk2-devel >= %{gtk2_version}
101Requires: compat32-libglade2-devel >= %{libglade2_version}
102
103%description -n compat32-%{name}-devel
104Bonobo is a component system based on CORBA, used by the GNOME desktop.
105libbonoboui contains GUI components that come with Bonobo.
106
107This package contains header files used to compile programs that
108use libbonoboui.
109
110%prep
111%setup -q -n %{name}-%{version}
112
113%build
114%configure
115export tagname=CC
116%__make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121export tagname=CC
122make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
123
124rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
125rm -f $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.a
126rm -f $RPM_BUILD_ROOT%{_datadir}/applications/bonobo-browser.desktop
127
128%find_lang %{po_package}
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%post -n compat32-%{name} -p /sbin/ldconfig
138
139%postun -n compat32-%{name} -p /sbin/ldconfig
140
141%files -f %{po_package}.lang
142%defattr(-,root,root)
143%doc COPYING ChangeLog NEWS README
144%{_libdir}/lib*.so.*
145%{_libdir}/libglade/2.0/*.so
146%{_libdir}/libglade/2.0/*.la
147%{_libdir}/bonobo
148%{_datadir}/gnome-2.0
149
150%files devel
151%defattr(-,root,root)
152#{_libdir}/lib*.a
153%{_libdir}/lib*.so
154%{_libdir}/pkgconfig/*.pc
155%{_includedir}/*
156%{_bindir}/*
157%{_libdir}/bonobo-2.0
158%{_datadir}/gtk-doc
159
160# compat32
161%if %{build_compat32}
162%files -n compat32-%{name}
163%defattr(-,root,root)
164%{_libdir}/lib*.so.*
165%{_libdir}/libglade/2.0/*.so
166%{_libdir}/libglade/2.0/*.la
167%{_libdir}/bonobo
168
169%files -n compat32-%{name}-devel
170%defattr(-,root,root)
171#{_libdir}/lib*.a
172%{_libdir}/lib*.so
173%{_libdir}/pkgconfig/*.pc
174%{_libdir}/bonobo-2.0
175%endif
176
177%changelog
178* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.5-1
179- new upstream release
180
181* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.4-1
182- new upstream release
183
184* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
185- build with rpm-4.8.1-1 for pkg-config file
186
187* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
188- new upstream release
189
190* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
191- new upstream release
192
193* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
194- removed static libraries
195- added compat32 package for x86_64 arch support
196
197* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
198- new upstream release
199- added BuildRequires: popt-devel
200
201* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
202- new upstream release
203
204* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
205- new upstream release
206
207* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
208- new upstream release
209
210* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
211- new upstream release
212
213* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
214- new upstream release
215
216* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
217- new upstream release
218
219* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
220- new upstream release
221
222* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
223- new upstream release
224
225* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
226- remove bonobo-activation dependency
227
228* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
229- new upstream release
230
231* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
232- new upstream release
233
234* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
235- new upstream release
236
237* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
238- new upstream release
239- rebuild with new toolchains
240
241* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
242- new upstream release
243
244* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
245- new upstream release
246
247* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
248- new upstream release
249
250* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
251- new upstream release
252
253* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
254- new upstream release
255
256* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
257- build for Vine Linux
258
259* Thu Aug 29 2002 Havoc Pennington <hp@redhat.com>
260- libtoolize with our latest libtool to try fixing rpaths
261
262* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
263- 2.0.1
264
265* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
266- Fix find_lang
267
268* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
269- 2.0.0
270- include sample server in libdir
271- remove .a files from glade module dir
272
273* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
274- rebuild in different environment
275
276* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
277- 1.118.0
278- remove empty AUTHORS file
279
280* Sun May 26 2002 Tim Powers <timp@redhat.com>
281- automated rebuild
282
283* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
284- rebuild in different environment
285
286* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
287- 1.117.0
288
289* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
290- 1.116.0
291
292* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
293- 1.113.0
294
295* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
296- 1.111.0
297
298* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
299- Version 1.110.0
300- Reintoolize to fix DBM problems
301
302* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
303- rebuild in rawhide
304
305* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
306- 1.108.1.90 cvs snap
307
308* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
309- 1.107.0.90 snap, explicit requires lines for dependencies
310- add libtool hack to avoid relinking
311
312* Mon Oct 29 2001 Havoc Pennington <hp@redhat.com>
313- add glade dependency, add glade module to file list
314
315* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
316- rebuild with glib 1.3.10, new cvs snap
317
318* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
319- rebuild, hoping build root is fixed
320
321* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
322- grumble, build require newer gtk
323- require libart_lgpl-devel not the non-devel package
324
325* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
326- cvs snap with menu stuff fixed so gnome-terminal works
327
328* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
329- new tarball, rebuild for new glib
330
331* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
332- new cvs snap, fix up prereqs/requires a bit
333
334* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
335- Initial build.
336
337
Note: See TracBrowser for help on using the repository browser.