source: projects/specs/trunk/lib/libb/libbonoboui/libbonoboui-vl.spec @ 1858

Revision 1858, 9.5 KB checked in by iwaim, 14 years ago (diff)

build with rpm 4.8.1-1; see [VineSeed:21797]

Line 
1%define libxml2_version 2.7.6
2%define orbit2_version 2.14.17
3%define libbonobo_version 2.24.3
4%define libgnomecanvas_version 2.30.0
5%define libgnome_version 2.30.0
6%define libart_lgpl_version 2.3.12
7%define gtk2_version 2.20.0
8%define libglade2_version 2.6.0
9
10%define po_package libbonoboui-2.0
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Summary: Bonobo user interface components
15Summary(ja): Bonobo ユーザインタフェースコンポーネント
16Name: libbonoboui
17Version: 2.24.3
18Release: 2%{?_dist_release}
19URL: http://ftp.gnome.org/
20Source0: %{name}-%{version}.tar.bz2
21Source2: bonoboui-fixed-ltmain.sh
22License: LGPL
23Group: System Environment/Libraries
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25
26Requires: libxml2 >= %{libxml2_version}
27Requires: ORBit2 >= %{orbit2_version}
28Requires: libbonobo >= %{libbonobo_version}
29Requires: libgnomecanvas >= %{libgnomecanvas_version}
30Requires: libgnome >= %{libgnome_version}
31Requires: libart_lgpl >= %{libart_lgpl_version}
32Requires: gtk2 >= %{gtk2_version}
33Requires: libglade2 >= %{libglade2_version}
34
35BuildRequires: libxml2-devel >= %{libxml2_version}
36BuildRequires: ORBit2-devel >= %{orbit2_version}
37BuildRequires: libbonobo-devel >= %{libbonobo_version}
38BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
39BuildRequires: libgnome-devel >= %{libgnome_version}
40BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
41BuildRequires: gtk2-devel >= %{gtk2_version}
42BuildRequires: libglade2-devel >= %{libglade2_version}
43BuildRequires: popt-devel
44BuildRequires: intltool >= 0.14-1
45BuildRequires: libtool >= 1.5
46
47%description
48Bonobo is a component system based on CORBA, used by the GNOME
49desktop.  libbonoboui contains the user interface related components
50that come with Bonobo.
51
52%package devel
53Summary: Libraries and headers for libbonoboui
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: libxml2-devel >= %{libxml2_version}
57Requires: ORBit2-devel >= %{orbit2_version}
58Requires: libbonobo-devel >= %{libbonobo_version}
59Requires: libgnomecanvas-devel >= %{libgnomecanvas_version}
60Requires: libgnome-devel >= %{libgnome_version}
61Requires: libart_lgpl-devel >= %{libart_lgpl_version}
62Requires: gtk2-devel >= %{gtk2_version}
63Requires: libglade2-devel >= %{libglade2_version}
64Conflicts: bonobo-devel < 1.0.8
65
66%description devel
67Bonobo is a component system based on CORBA, used by the GNOME desktop.
68libbonoboui contains GUI components that come with Bonobo.
69
70This package contains header files used to compile programs that
71use libbonoboui.
72
73# compat32
74%package -n compat32-%{name}
75Summary: Bonobo user interface components
76Summary(ja): Bonobo ユーザインタフェースコンポーネント
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79
80%description -n compat32-%{name}
81Bonobo is a component system based on CORBA, used by the GNOME
82desktop.  libbonoboui contains the user interface related components
83that come with Bonobo.
84
85%package -n compat32-%{name}-devel
86Summary: Libraries and headers for libbonoboui
87Group: Development/Libraries
88Requires: %{name}-devel = %{version}-%{release}
89Requires: compat32-%{name} = %{version}-%{release}
90Requires: compat32-libxml2-devel >= %{libxml2_version}
91Requires: compat32-ORBit2-devel >= %{orbit2_version}
92Requires: compat32-libbonobo-devel >= %{libbonobo_version}
93Requires: compat32-libgnomecanvas-devel >= %{libgnomecanvas_version}
94Requires: compat32-libgnome-devel >= %{libgnome_version}
95Requires: compat32-libart_lgpl-devel >= %{libart_lgpl_version}
96Requires: compat32-gtk2-devel >= %{gtk2_version}
97Requires: compat32-libglade2-devel >= %{libglade2_version}
98
99%description -n compat32-%{name}-devel
100Bonobo is a component system based on CORBA, used by the GNOME desktop.
101libbonoboui contains GUI components that come with Bonobo.
102
103This package contains header files used to compile programs that
104use libbonoboui.
105
106%prep
107%setup -q -n %{name}-%{version}
108
109%build
110%configure
111export tagname=CC
112%__make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
113
114
115%install
116rm -rf $RPM_BUILD_ROOT
117export tagname=CC
118make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
121rm -f $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.a
122rm -f $RPM_BUILD_ROOT%{_datadir}/applications/bonobo-browser.desktop
123
124%find_lang %{po_package}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%post -n compat32-%{name} -p /sbin/ldconfig
134
135%postun -n compat32-%{name} -p /sbin/ldconfig
136
137%files -f %{po_package}.lang
138%defattr(-,root,root)
139%doc COPYING ChangeLog NEWS README
140%{_libdir}/lib*.so.*
141%{_libdir}/libglade/2.0/*.so
142%{_libdir}/libglade/2.0/*.la
143%{_libdir}/bonobo
144%{_datadir}/gnome-2.0
145
146%files devel
147%defattr(-,root,root)
148#{_libdir}/lib*.a
149%{_libdir}/lib*.so
150%{_libdir}/pkgconfig/*.pc
151%{_includedir}/*
152%{_bindir}/*
153%{_libdir}/bonobo-2.0
154%{_datadir}/gtk-doc
155
156# compat32
157%if %{build_compat32}
158%files -n compat32-%{name}
159%defattr(-,root,root)
160%{_libdir}/lib*.so.*
161%{_libdir}/libglade/2.0/*.so
162%{_libdir}/libglade/2.0/*.la
163%{_libdir}/bonobo
164
165%files -n compat32-%{name}-devel
166%defattr(-,root,root)
167#{_libdir}/lib*.a
168%{_libdir}/lib*.so
169%{_libdir}/pkgconfig/*.pc
170%{_libdir}/bonobo-2.0
171%endif
172
173%changelog
174* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
175- build with rpm-4.8.1-1 for pkg-config file
176
177* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
178- new upstream release
179
180* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
181- new upstream release
182
183* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
184- removed static libraries
185- added compat32 package for x86_64 arch support
186
187* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
188- new upstream release
189- added BuildRequires: popt-devel
190
191* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
192- new upstream release
193
194* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
195- new upstream release
196
197* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
198- new upstream release
199
200* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
201- new upstream release
202
203* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
204- new upstream release
205
206* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
207- new upstream release
208
209* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
210- new upstream release
211
212* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
213- new upstream release
214
215* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
216- remove bonobo-activation dependency
217
218* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
219- new upstream release
220
221* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
222- new upstream release
223
224* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
225- new upstream release
226
227* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
228- new upstream release
229- rebuild with new toolchains
230
231* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
232- new upstream release
233
234* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
235- new upstream release
236
237* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
238- new upstream release
239
240* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
241- new upstream release
242
243* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
244- new upstream release
245
246* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
247- build for Vine Linux
248
249* Thu Aug 29 2002 Havoc Pennington <hp@redhat.com>
250- libtoolize with our latest libtool to try fixing rpaths
251
252* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
253- 2.0.1
254
255* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
256- Fix find_lang
257
258* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
259- 2.0.0
260- include sample server in libdir
261- remove .a files from glade module dir
262
263* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
264- rebuild in different environment
265
266* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
267- 1.118.0
268- remove empty AUTHORS file
269
270* Sun May 26 2002 Tim Powers <timp@redhat.com>
271- automated rebuild
272
273* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
274- rebuild in different environment
275
276* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
277- 1.117.0
278
279* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
280- 1.116.0
281
282* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
283- 1.113.0
284
285* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
286- 1.111.0
287
288* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
289- Version 1.110.0
290- Reintoolize to fix DBM problems
291
292* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
293- rebuild in rawhide
294
295* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
296- 1.108.1.90 cvs snap
297
298* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
299- 1.107.0.90 snap, explicit requires lines for dependencies
300- add libtool hack to avoid relinking
301
302* Mon Oct 29 2001 Havoc Pennington <hp@redhat.com>
303- add glade dependency, add glade module to file list
304
305* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
306- rebuild with glib 1.3.10, new cvs snap
307
308* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
309- rebuild, hoping build root is fixed
310
311* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
312- grumble, build require newer gtk
313- require libart_lgpl-devel not the non-devel package
314
315* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
316- cvs snap with menu stuff fixed so gnome-terminal works
317
318* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
319- new tarball, rebuild for new glib
320
321* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
322- new cvs snap, fix up prereqs/requires a bit
323
324* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
325- Initial build.
326
327
Note: See TracBrowser for help on using the repository browser.