source: projects/specs/trunk/lib/libb/libbonoboui/libbonoboui-vl.spec @ 9559

Revision 9559, 9.8 KB checked in by Takemikaduchi, 9 years ago (diff)

cinnamon: new upstream release or rebuild
caja: fix typo
others: remove *.la files

Line 
1%define libxml2_version 2.7.7
2%define orbit2_version 2.14.19
3%define libbonobo_version 2.32.0
4%define libgnomecanvas_version 2.30.2
5%define libgnome_version 2.32.0
6%define libart_lgpl_version 2.3.12
7%define gtk2_version 2.22.0
8%define libglade2_version 2.6.0
9
10%define po_package libbonoboui-2.0
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Summary: Bonobo user interface components
15Summary(ja): Bonobo ユーザインタフェースコンポーネント
16Name: libbonoboui
17Version: 2.24.5
18Release: 3%{?_dist_release}
19URL: http://ftp.gnome.org/
20Source0: http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.24/%{name}-%{version}.tar.bz2
21Source2: bonoboui-fixed-ltmain.sh
22
23License: LGPL
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27Requires: libxml2 >= %{libxml2_version}
28Requires: ORBit2 >= %{orbit2_version}
29Requires: libbonobo >= %{libbonobo_version}
30Requires: libgnomecanvas >= %{libgnomecanvas_version}
31Requires: libgnome >= %{libgnome_version}
32Requires: libart_lgpl >= %{libart_lgpl_version}
33Requires: gtk2 >= %{gtk2_version}
34Requires: libglade2 >= %{libglade2_version}
35
36BuildRequires: libxml2-devel >= %{libxml2_version}
37BuildRequires: ORBit2-devel >= %{orbit2_version}
38BuildRequires: libbonobo-devel >= %{libbonobo_version}
39BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
40BuildRequires: libgnome-devel >= %{libgnome_version}
41BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
42BuildRequires: gtk2-devel >= %{gtk2_version}
43BuildRequires: libglade2-devel >= %{libglade2_version}
44BuildRequires: popt-devel
45BuildRequires: intltool >= 0.14-1
46BuildRequires: libtool >= 1.5
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52Bonobo is a component system based on CORBA, used by the GNOME
53desktop.  libbonoboui contains the user interface related components
54that come with Bonobo.
55
56%package devel
57Summary: Libraries and headers for libbonoboui
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: libxml2-devel >= %{libxml2_version}
61Requires: ORBit2-devel >= %{orbit2_version}
62Requires: libbonobo-devel >= %{libbonobo_version}
63Requires: libgnomecanvas-devel >= %{libgnomecanvas_version}
64Requires: libgnome-devel >= %{libgnome_version}
65Requires: libart_lgpl-devel >= %{libart_lgpl_version}
66Requires: gtk2-devel >= %{gtk2_version}
67Requires: libglade2-devel >= %{libglade2_version}
68Conflicts: bonobo-devel < 1.0.8
69
70%description devel
71Bonobo is a component system based on CORBA, used by the GNOME desktop.
72libbonoboui contains GUI components that come with Bonobo.
73
74This package contains header files used to compile programs that
75use libbonoboui.
76
77# compat32
78%package -n compat32-%{name}
79Summary: Bonobo user interface components
80Summary(ja): Bonobo ユーザインタフェースコンポーネント
81Group: System Environment/Libraries
82Requires: %{name} = %{version}-%{release}
83
84%description -n compat32-%{name}
85Bonobo is a component system based on CORBA, used by the GNOME
86desktop.  libbonoboui contains the user interface related components
87that come with Bonobo.
88
89%package -n compat32-%{name}-devel
90Summary: Libraries and headers for libbonoboui
91Group: Development/Libraries
92Requires: %{name}-devel = %{version}-%{release}
93Requires: compat32-%{name} = %{version}-%{release}
94Requires: compat32-libxml2-devel >= %{libxml2_version}
95Requires: compat32-ORBit2-devel >= %{orbit2_version}
96Requires: compat32-libbonobo-devel >= %{libbonobo_version}
97Requires: compat32-libgnomecanvas-devel >= %{libgnomecanvas_version}
98Requires: compat32-libgnome-devel >= %{libgnome_version}
99Requires: compat32-libart_lgpl-devel >= %{libart_lgpl_version}
100Requires: compat32-gtk2-devel >= %{gtk2_version}
101Requires: compat32-libglade2-devel >= %{libglade2_version}
102
103%description -n compat32-%{name}-devel
104Bonobo is a component system based on CORBA, used by the GNOME desktop.
105libbonoboui contains GUI components that come with Bonobo.
106
107This package contains header files used to compile programs that
108use libbonoboui.
109
110%prep
111%setup -q -n %{name}-%{version}
112
113%build
114%configure --disable-static
115export tagname=CC
116%__make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121export tagname=CC
122make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
123
124find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
125find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
126rm -f $RPM_BUILD_ROOT%{_datadir}/applications/bonobo-browser.desktop
127
128%find_lang %{po_package}
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%post -n compat32-%{name} -p /sbin/ldconfig
138
139%postun -n compat32-%{name} -p /sbin/ldconfig
140
141%files -f %{po_package}.lang
142%defattr(-,root,root)
143%doc COPYING ChangeLog NEWS README
144%{_libdir}/lib*.so.*
145%{_libdir}/libglade/2.0/*.so
146%{_libdir}/bonobo
147%{_datadir}/gnome-2.0
148
149%files devel
150%defattr(-,root,root)
151%{_libdir}/lib*.so
152%{_libdir}/pkgconfig/*.pc
153%{_includedir}/*
154%{_bindir}/*
155%{_libdir}/bonobo-2.0
156%{_datadir}/gtk-doc
157
158# compat32
159%if %{build_compat32}
160%files -n compat32-%{name}
161%defattr(-,root,root)
162%{_libdir}/lib*.so.*
163%{_libdir}/libglade/2.0/*.so
164%{_libdir}/bonobo
165
166%files -n compat32-%{name}-devel
167%defattr(-,root,root)
168%{_libdir}/lib*.so
169%{_libdir}/bonobo-2.0
170%endif
171
172%changelog
173* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.5-3
174- remove *.la files
175
176* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.5-2
177- rebuild with VineSeed environment
178
179* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.5-1
180- new upstream release
181
182* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.4-1
183- new upstream release
184
185* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
186- build with rpm-4.8.1-1 for pkg-config file
187
188* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
189- new upstream release
190
191* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
192- new upstream release
193
194* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
195- removed static libraries
196- added compat32 package for x86_64 arch support
197
198* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
199- new upstream release
200- added BuildRequires: popt-devel
201
202* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
203- new upstream release
204
205* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
206- new upstream release
207
208* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
209- new upstream release
210
211* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
212- new upstream release
213
214* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
215- new upstream release
216
217* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
218- new upstream release
219
220* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
221- new upstream release
222
223* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
224- new upstream release
225
226* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
227- remove bonobo-activation dependency
228
229* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
230- new upstream release
231
232* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
233- new upstream release
234
235* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
236- new upstream release
237
238* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
239- new upstream release
240- rebuild with new toolchains
241
242* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
243- new upstream release
244
245* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
246- new upstream release
247
248* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
249- new upstream release
250
251* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
252- new upstream release
253
254* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
255- new upstream release
256
257* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
258- build for Vine Linux
259
260* Thu Aug 29 2002 Havoc Pennington <hp@redhat.com>
261- libtoolize with our latest libtool to try fixing rpaths
262
263* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
264- 2.0.1
265
266* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
267- Fix find_lang
268
269* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
270- 2.0.0
271- include sample server in libdir
272- remove .a files from glade module dir
273
274* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
275- rebuild in different environment
276
277* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
278- 1.118.0
279- remove empty AUTHORS file
280
281* Sun May 26 2002 Tim Powers <timp@redhat.com>
282- automated rebuild
283
284* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
285- rebuild in different environment
286
287* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
288- 1.117.0
289
290* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
291- 1.116.0
292
293* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
294- 1.113.0
295
296* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
297- 1.111.0
298
299* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
300- Version 1.110.0
301- Reintoolize to fix DBM problems
302
303* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
304- rebuild in rawhide
305
306* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
307- 1.108.1.90 cvs snap
308
309* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
310- 1.107.0.90 snap, explicit requires lines for dependencies
311- add libtool hack to avoid relinking
312
313* Mon Oct 29 2001 Havoc Pennington <hp@redhat.com>
314- add glade dependency, add glade module to file list
315
316* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
317- rebuild with glib 1.3.10, new cvs snap
318
319* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
320- rebuild, hoping build root is fixed
321
322* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
323- grumble, build require newer gtk
324- require libart_lgpl-devel not the non-devel package
325
326* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
327- cvs snap with menu stuff fixed so gnome-terminal works
328
329* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
330- new tarball, rebuild for new glib
331
332* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
333- new cvs snap, fix up prereqs/requires a bit
334
335* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
336- Initial build.
337
338
Note: See TracBrowser for help on using the repository browser.