source: projects/specs/trunk/lib/libb/libbluray/libbluray-vl.spec @ 7926

Revision 7926, 8.5 KB checked in by shaolin, 11 years ago (diff)
  • libbluray: new package
Line 
1%global snapshot 0
2%global tarball_date 20130427
3%global git_hash 2b002fe52e8c2506ed52bf56c8b517d350dbb281
4%global git_short %(echo '%{git_hash}' | cut -c -13)
5%global build_pdf_doc 0
6
7%if %{?_dist_release} >= "vl7"
8%define jvmver 1.7.0
9%else
10%define jvmver 1.6.0
11%endif
12
13Name:           libbluray
14Version:        0.4.0
15%if %{snapshot}
16Release:        0.1.%{tarball_date}git%{git_short}%{?dist}
17%else
18Release:        1%{?_dist_release}
19%endif
20Summary:        Library to access Blu-Ray disks for video playback
21Summary(ja):    Blu-Ray ディスクにアクセスしてビデオ再生するためのライブラリ
22Group:          System Environment/Libraries
23License:        LGPLv2+
24URL:            http://www.videolan.org/developers/libbluray.html
25%if %{snapshot}
26# Use the commands below to generate a tarball.
27# git clone git://git.videolan.org/libbluray.git
28# cd libbluray
29# git archive --format=tar %{git_hash} --prefix=libbluray/ | bzip2 > ../libbluray-$( date +%Y%m%d )git%{git_short}.tar.bz2
30Source0:        %{name}-%{tarball_date}git%{git_short}.tar.bz2
31%else
32Source0:        ftp://ftp.videolan.org/pub/videolan/%{name}/%{version}/%{name}-%{version}.tar.bz2
33%endif
34Patch0:         libbluray-0.2.2-no_doxygen_timestamp.patch
35BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
36
37%if %{snapshot}
38BuildRequires:  autoconf
39BuildRequires:  automake
40BuildRequires:  libtool
41%endif
42%ifnarch ppc ppc64
43BuildRequires:  java-devel >= 1.6.0
44BuildRequires:  jpackage-utils
45BuildRequires:  ant
46%endif
47BuildRequires:  libxml2-devel
48BuildRequires:  doxygen
49BuildRequires:  texlive
50BuildRequires:  graphviz
51BuildRequires:  freetype2-devel
52
53
54%description
55This package is aiming to provide a full portable free open source bluray
56library, which can be plugged into popular media players to allow full bluray
57navigation and playback on Linux. It will eventually be compatible with all
58current titles, and will be easily portable and embeddable in standard players
59such as mplayer and vlc.
60
61%description -l ja
62このパッケージは完全にポータブルでオープンソースな bluray ライブラリの提供を
63目指しており、Linux 上でポピュラーなメディアプレーヤーに組み込んで bluray の
64ナビゲーションや再生を可能にするものです。現在入手可能な全タイトルとの互換性
65を目指し、移植性を高め、mplayer や vlc といった標準プレーヤーに組み込み可能に
66なるようにする予定です。
67
68
69%ifnarch ppc ppc64
70%package        java
71Summary:        BDJ support for %{name}
72Summary(ja):    %{name} 用 BDJ サポート
73Group:          Development/Libraries
74Requires:       %{name}%{?_isa} = %{version}-%{release}
75Requires:       java >= 1.6.0
76Requires:       jpackage-utils
77
78%description    java
79The %{name}-java package contains the jar file needed to add BDJ support to
80%{name}.
81
82%description    java -l ja
83%{name}-java パッケージには、%{name} に BDJ サポートを追加する jar ファイルが
84収録されています。
85%endif
86
87
88%package        devel
89Summary:        Development files for %{name}
90Summary(ja):    %{name} 用開発ファイル
91Group:          Development/Libraries
92Requires:       %{name}%{?_isa} = %{version}-%{release}
93
94%description    devel
95The %{name}-devel package contains libraries and header files for
96developing applications that use %{name}.
97
98%description    devel -l ja
99%{name}-devel パッケージには、%{name} を使うアプリケーションの開発に
100必要なライブラリとヘッダーファイルが収録されています。
101
102
103%prep
104%if %{snapshot}
105%setup -q -n %{name}
106%else
107%setup -q
108%endif
109%patch0 -p1 -b .no_timestamp
110
111
112%build
113%if %{snapshot}
114autoreconf -vif
115%endif
116export JDK_HOME="%{_jvmdir}/java-%{jvmver}"
117%configure --disable-static \
118%if %{build_pdf_doc}
119           --enable-doxygen-pdf \
120%else
121           --disable-doxygen-pdf \
122%endif
123           --disable-doxygen-ps \
124           --enable-doxygen-html \
125           --enable-examples \
126%ifnarch ppc ppc64
127           --enable-bdjava
128%endif
129
130# Fix rpath issue
131sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
132sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
133
134make %{?_smp_mflags}
135make doxygen-doc
136# Remove uneeded script
137rm -f doc/doxygen/html/installdox
138
139
140%install
141rm -rf %{buildroot}
142make install DESTDIR=%{buildroot}
143find %{buildroot} -name '*.la' -exec rm -f {} ';'
144
145# Install test utilities
146for i in clpi_dump index_dump mobj_dump mpls_dump sound_dump;
147do install -Dp -m 0755 src/examples/$i %{buildroot}%{_bindir}/$i; done;
148for i in bd_info bdsplice hdmv_test libbluray_test list_titles;
149do install -Dp -m 0755 src/examples/.libs/$i %{buildroot}%{_bindir}/$i; done;
150
151%ifnarch ppc ppc64
152install -Dp -m755 src/examples/.libs/bdj_test %{buildroot}%{_bindir}/bdj_test;
153%endif
154
155
156%clean
157rm -rf %{buildroot}
158
159
160%post -p /sbin/ldconfig
161
162%postun -p /sbin/ldconfig
163
164
165%files
166%defattr(-,root,root,-)
167%doc COPYING player_wrappers README.txt
168%{_libdir}/*.so.*
169%{_bindir}/*
170
171
172%ifnarch ppc ppc64
173%files java
174%defattr(-,root,root,-)
175%{_libdir}/libbluray/libbluray.jar
176%endif
177
178
179%files devel
180%defattr(-,root,root,-)
181%doc doc/doxygen/html
182%if %{build_pdf_doc}
183%doc doc/doxygen/libbluray.pdf
184%endif
185%{_includedir}/*
186%{_libdir}/*.so
187%{_libdir}/pkgconfig/libbluray.pc
188
189
190%changelog
191* Thu Oct 24 2013 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-1
192- initial build for Vine Linux
193
194* Fri Sep 20 2013 Xavier Bachelot <xavier@bachelot.org> 0.4.0-1
195- Update to 0.4.0.
196- Fix rpath issues with some test utilities.
197
198* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-3
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
200
201* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-2
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
203
204* Tue Aug 21 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.3-1
205- Update to 0.2.3.
206
207* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-3
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
209
210* Tue Jun 12 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-3
211- Don't build pdf doc, it breaks multilib (see RHBZ#835952).
212
213* Tue Jun 12 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-2
214- Fix multilib conflict in doxygen docs (RHBZ#831401).
215
216* Tue Mar 20 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-1
217- Update to 0.2.2.
218
219* Tue Mar 20 2012 Karsten Hopp <karsten@redhat.com> 0.2.1-4
220- ppc(64) has no java-1.7.0-open yet, disable java subpackage on both PPC archs
221
222* Thu Mar 15 2012 Rex Dieter <rdieter@fedoraproject.org> 0.2.1-3
223- make build non-fatal when using doxygen-1.8 (doesn't produce installdox anymore)
224
225* Wed Feb 01 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.1-2
226- Rebuild for openjdk 7.
227
228* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-1
229- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
230
231* Thu Dec 01 2011 Xavier Bachelot <xavier@bachelot.org> 0.2.1-1
232- First upstream official release.
233- Fix BD-J build (missing files in upstream tarball).
234- Have subpackages require an arch-specific base package.
235
236* Sun Oct 23 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.7.20111023gite037110f11e70
237- Update to latest snapshot.
238
239* Sat Jul 16 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.6.20110710git51d7d60a96d06
240- Don't build java subpackage on ppc64, no java-1.6.0-devel package.
241
242* Sun Jul 10 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.5.20110710git51d7d60a96d06
243- Update to latest snapshot.
244
245* Sat May 14 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.4.20110514git46ee2766038e9
246- Update to latest snapshot.
247- Drop -static subpackage.
248
249* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-0.3.20110126gitbbf11e43bd82e
250- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
251
252* Wed Jan 26 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.2.20110126gitbbf11e43bd82e
253- Update to latest snapshot.
254- Split the BDJ support to a -java subpackage.
255
256* Fri Jan 07 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.1.20110107git0e5902ff9a6f1
257- Update to latest snapshot.
258- Add BR: libxml2-devel for metadata parser.
259- Add BR: graphviz for doc generation.
260
261* Thu Oct 28 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.3.20101028gitc32862b77dea4
262- Update to latest snapshot.
263- Install BDJ jar.
264
265* Thu Oct 21 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.2.20101021git144a204c02687
266- Fix release tag.
267- Update to latest snapshot.
268
269* Thu Aug 19 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.1.20100819
270- Initial Fedora release.
Note: See TracBrowser for help on using the repository browser.