source: projects/specs/trunk/lib/liba/libatomic_ops/libatomic_ops-vl.spec @ 12197

Revision 12197, 6.6 KB checked in by tomop, 5 years ago (diff)

updated guile and requirements

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:         libatomic_ops
4Summary:      Atomic memory update operations
5Version:      7.6.10
6Release:      1%{?_dist_release}
7
8# libatomic_ops MIT, libatomic_ops_gpl GPLv2
9License: GPLv2 and MIT
10URL:          https://www.hboehm.info/gc/
11Vendor:       Project Vine
12Distribution: Vine Linux
13
14Source0: https://www.hboehm.info/gc/gc_source/libatomic_ops-%{version}.tar.gz
15# updated GPLv2 license text
16Source1: http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
17
18%description
19Provides implementations for atomic memory update operations on a
20number of architectures. This allows direct use of these in reasonably
21portable code. Unlike earlier similar packages, this one explicitly
22considers memory barrier semantics, and allows the construction of code
23that involves minimum overhead across a variety of architectures.
24
25%package devel
26Summary: Development files for %{name}
27Requires: %{name}%{?_isa} = %{version}-%{release}
28%description devel
29Files for developing with %{name}.
30
31%package static
32Summary: Static library files for %{name}
33Requires: %{name}-devel%{?_isa} = %{version}-%{release}
34%description static
35Files for developing with %{name} and linking statically.
36
37%package -n compat32-%{name}
38Summary:  Atomic memory update operations
39Group:    System Environment/Libraries
40Requires: %{name} = %{version}-%{release}
41%description -n compat32-%{name}
42Provides implementations for atomic memory update operations on a
43number of architectures. This allows direct use of these in reasonably
44portable code. Unlike earlier similar packages, this one explicitly
45considers memory barrier semantics, and allows the construction of code
46that involves minimum overhead across a variety of architectures.
47
48%package -n compat32-%{name}-devel
49Summary:  Development files for %{name}
50Group:    Development/Libraries
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53%description -n compat32-%{name}-devel
54Files for developing with %{name}.
55
56
57%prep
58%autosetup -p1
59
60install -m644 -p %{SOURCE1} ./COPYING
61
62
63%build
64%configure \
65  --enable-shared \
66  --disable-silent-rules
67
68make %{?_smp_mflags}
69
70
71%install
72make install DESTDIR=%{buildroot}
73
74## unpackaged files
75rm -fv %{buildroot}%{_libdir}/lib*.la
76# omit dup'd docs
77rm -fv %{buildroot}%{_datadir}/libatomic_ops/{COPYING,README*,*.txt}
78rm -rf %{buildroot}%{_docdir}/libatomic_ops
79
80
81%check
82## ignore failures on powerpc, atomic stack feature not working (#883748)
83#ifarch ppc ppc64 ppc64le aarch64
84#global arch_ignore ||:
85#endif
86make check %{?arch_ignore}
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%files
92%license COPYING doc/LICENSING.txt
93%doc AUTHORS ChangeLog README.md
94%{_libdir}/libatomic_ops.so.1*
95%{_libdir}/libatomic_ops_gpl.so.1*
96
97%files devel
98%doc doc/README*
99%{_includedir}/atomic_ops.h
100%{_includedir}/atomic_ops_malloc.h
101%{_includedir}/atomic_ops_stack.h
102%{_includedir}/atomic_ops/
103%{_libdir}/libatomic_ops.so
104%{_libdir}/libatomic_ops_gpl.so
105%{_libdir}/pkgconfig/atomic_ops.pc
106
107%files static
108%{_libdir}/libatomic_ops.a
109%{_libdir}/libatomic_ops_gpl.a
110
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root)
114%{_libdir}/libatomic_ops.so.1*
115%{_libdir}/libatomic_ops_gpl.so.1*
116
117%files -n compat32-%{name}-devel
118%defattr(-,root,root)
119%{_libdir}/libatomic_ops.so
120%{_libdir}/libatomic_ops_gpl.so
121%{_libdir}/pkgconfig/atomic_ops.pc
122%endif
123
124
125%changelog
126* Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.6.10-1
127- new upstream release.
128- dropped all patches.
129
130* Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-4
131- added compat32 packages.
132
133* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-3
134- fixed %%changelog.
135
136* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-2
137- imported all stuff from rawhide.
138
139  * Fri Jun 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.4-1
140  - libatomic_ops-7.4.4 (#1346524)
141
142  * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-9
143  - make check fails on test_stack for ppc64le arch (#1096574), drop reference to 0032.patch
144
145  * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.2-8
146  - pull in upstream (7.4 branch) fixes
147  - Add support for 64-bit MIPS (#1317509)
148  - use %%license
149
150  * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.2-7
151  - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
152
153  * Tue Jul  7 2015 Peter Robinson <pbrobinson@fedoraproject.org> 7.4.2-6
154  - Don't fail check on aarch64
155
156  * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-5
157  - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
158
159  * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-4
160  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
161
162  * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-3
163  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
164
165  * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-2
166  - link libatomic_ops_gpl against libatomic_ops for missing symbol(s)
167
168  * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-1
169  - libatomic_opts-7.4.2
170  - new upstream/source URLs
171  - %%check: skip ppc64le too
172  - License: MIT and GPLv2
173  - update/longer %%description
174  - updated GPLv2 license text (with correct address)
175
176  * Wed Dec 04 2013 Rex Dieter <rdieter@fedoraproject.org>  7.4.0-1
177  - separate libatomic_ops lives again!
178
179  * Fri Jul 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-8.gc
180  - use gc tarball, tag gc release
181
182  * Thu Jul 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-7
183  - devel: Provides: %%name-static ...
184  - consolidate %%doc's
185  - %%files: track libs
186
187  * Wed May 20 2009 Dan Horak <dan[t]danny.cz> - 1.2-6
188  - added fix for s390
189
190  * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
191  - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
192
193  * Thu May 22 2008 Jon Stanley <jonstanley@gmail.com> - 1.2-4
194  - Fix license tag
195
196* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
197- initial build for Vine Linux
198
199* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
200- Autorebuild for GCC 4.3
201
202* Tue May 29 2007 Pierre Ossman <drzeus@drzeus.cx> 1.2-2
203- Added fix for PPC AO_load_acquire.
204
205* Fri Nov 10 2006 Pierre Ossman <drzeus@drzeus.cx> 1.2-1
206- Update to 1.2.
207
208* Sat Sep  9 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-2
209- Fix naming of package.
210- General cleanup of spec file.
211
212* Wed Aug 30 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-1
213- Initial package for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.