source: projects/specs/trunk/lib/liba/libatomic_ops/libatomic_ops-vl.spec @ 10485

Revision 10485, 5.6 KB checked in by tomop, 8 years ago (diff)

libatomic_ops-7.4.4-3

Line 
1Name:         libatomic_ops
2Summary:      Atomic memory update operations
3Version:      7.4.4
4Release:      3%{?_dist_release}
5
6# libatomic_ops MIT, libatomic_ops_gpl GPLv2
7License: GPLv2 and MIT
8URL:          http://www.hboehm.info/gc/
9Vendor:       Project Vine
10Distribution: Vine Linux
11
12Source0: http://www.hboehm.info/gc/gc_source/libatomic_ops-%{version}.tar.gz
13# updated GPLv2 license text
14Source1: http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
15
16## upstream patches
17# 7.4 branch
18
19# master branch
20#Patch116: 0016-Use-LLD-and-SCD-instructions-on-mips64.patch
21## rebased for 7.4.4
22Patch116: libatomic_ops-7.4.4-Use-LLD-and-SCD-instructions-on-mips64.patch
23
24## upstreamable patches
25# https://bugzilla.redhat.com/show_bug.cgi?id=1096574
26Patch500: gc_ppc64le_force_AO_load.patch
27
28# re-autofoo for patch2 (and others)
29BuildRequires: automake libtool
30
31%description
32Provides implementations for atomic memory update operations on a
33number of architectures. This allows direct use of these in reasonably
34portable code. Unlike earlier similar packages, this one explicitly
35considers memory barrier semantics, and allows the construction of code
36that involves minimum overhead across a variety of architectures.
37
38%package devel
39Summary: Development files for %{name}
40Requires: %{name}%{?_isa} = %{version}-%{release}
41%description devel
42Files for developing with %{name}.
43
44%package static
45Summary: Static library files for %{name}
46Requires: %{name}-devel%{?_isa} = %{version}-%{release}
47%description static
48Files for developing with %{name} and linking statically.
49
50
51%prep
52%autosetup -p1
53
54# patch50 introduces rpath (probably due to older libtool), refresh stuff here
55autoreconf -fi
56
57install -m644 -p %{SOURCE1} ./COPYING
58
59
60%build
61%configure \
62  --enable-shared \
63  --disable-silent-rules
64
65make %{?_smp_mflags}
66
67
68%install
69make install DESTDIR=%{buildroot}
70
71## unpackaged files
72rm -fv %{buildroot}%{_libdir}/lib*.la
73# omit dup'd docs
74rm -fv %{buildroot}%{_datadir}/libatomic_ops/{COPYING,README*,*.txt}
75
76
77%check
78## ignore failures on powerpc, atomic stack feature not working (#883748)
79#ifarch ppc ppc64 ppc64le aarch64
80#global arch_ignore ||:
81#endif
82make check %{?arch_ignore}
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%files
88%license COPYING
89%doc doc/LICENSING.txt
90%doc AUTHORS ChangeLog README.md
91%{_libdir}/libatomic_ops.so.1*
92%{_libdir}/libatomic_ops_gpl.so.1*
93
94%files devel
95%doc doc/README*
96%{_includedir}/atomic_ops.h
97%{_includedir}/atomic_ops_malloc.h
98%{_includedir}/atomic_ops_stack.h
99%{_includedir}/atomic_ops/
100%{_libdir}/libatomic_ops.so
101%{_libdir}/libatomic_ops_gpl.so
102%{_libdir}/pkgconfig/atomic_ops.pc
103
104%files static
105%{_libdir}/libatomic_ops.a
106%{_libdir}/libatomic_ops_gpl.a
107
108
109%changelog
110* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-3
111- fixed %%changelog.
112
113* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.4.4-2
114- imported all atuff from rawhide.
115
116  * Fri Jun 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.4-1
117  - libatomic_ops-7.4.4 (#1346524)
118
119  * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-9
120  - make check fails on test_stack for ppc64le arch (#1096574), drop reference to 0032.patch
121
122  * Mon Mar 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 7.4.2-8
123  - pull in upstream (7.4 branch) fixes
124  - Add support for 64-bit MIPS (#1317509)
125  - use %%license
126
127  * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.2-7
128  - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
129
130  * Tue Jul  7 2015 Peter Robinson <pbrobinson@fedoraproject.org> 7.4.2-6
131  - Don't fail check on aarch64
132
133  * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-5
134  - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
135
136  * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-4
137  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
138
139  * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.4.2-3
140  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
141
142  * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-2
143  - link libatomic_ops_gpl against libatomic_ops for missing symbol(s)
144
145  * Tue May 13 2014 Rex Dieter <rdieter@fedoraproject.org> 7.4.2-1
146  - libatomic_opts-7.4.2
147  - new upstream/source URLs
148  - %%check: skip ppc64le too
149  - License: MIT and GPLv2
150  - update/longer %%description
151  - updated GPLv2 license text (with correct address)
152
153  * Wed Dec 04 2013 Rex Dieter <rdieter@fedoraproject.org>  7.4.0-1
154  - separate libatomic_ops lives again!
155
156  * Fri Jul 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-8.gc
157  - use gc tarball, tag gc release
158
159  * Thu Jul 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.2-7
160  - devel: Provides: %%name-static ...
161  - consolidate %%doc's
162  - %%files: track libs
163
164  * Wed May 20 2009 Dan Horak <dan[t]danny.cz> - 1.2-6
165  - added fix for s390
166
167  * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
168  - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
169
170  * Thu May 22 2008 Jon Stanley <jonstanley@gmail.com> - 1.2-4
171  - Fix license tag
172
173* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
174- initial build for Vine Linux
175
176* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
177- Autorebuild for GCC 4.3
178
179* Tue May 29 2007 Pierre Ossman <drzeus@drzeus.cx> 1.2-2
180- Added fix for PPC AO_load_acquire.
181
182* Fri Nov 10 2006 Pierre Ossman <drzeus@drzeus.cx> 1.2-1
183- Update to 1.2.
184
185* Sat Sep  9 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-2
186- Fix naming of package.
187- General cleanup of spec file.
188
189* Wed Aug 30 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-1
190- Initial package for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.