source: projects/specs/trunk/lib/liba/libaio/libaio-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Linux-native asynchronous I/O access library
2Name: libaio
3Version: 0.3.106
4Release: 2%{?_dist_release}
5License: LGPL
6Group:  System Environment/Libraries
7Source: %{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9ExclusiveArch: i386 x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6
10
11%description
12The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
13richer API and capability set than the simple POSIX async I/O facility.
14This library, libaio, provides the Linux-native API for async I/O.
15The POSIX async I/O facility requires this library in order to provide
16kernel-accelerated async I/O capabilities, as do applications which
17require the Linux-native async I/O API.
18
19%package devel
20Summary: Development files for Linux-native asynchronous I/O access
21Group: Development/Libraries
22Requires: libaio = %{version}-%{release}
23
24%description devel
25This package provides header files to include and libraries to link with
26for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
27
28%prep
29%setup -q -a 0
30mv %{name}-%{version} compat-%{name}-%{version}
31
32%build
33# A library with a soname of 1.0.0 was inadvertantly released.  This
34# build process builds a version of the library with the broken soname in
35# the compat-libaio-0.3.103 directory, and then builds the library again
36# with the correct soname.
37cd compat-%{name}-%{version}
38make soname='libaio.so.1.0.0' libname='libaio.so.1.0.0'
39cd ..
40make
41
42%install
43[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
44cd compat-%{name}-%{version}
45install -D -m 755 src/libaio.so.1.0.0 \
46  $RPM_BUILD_ROOT/%{_libdir}/libaio.so.1.0.0
47cd ..
48make install prefix=$RPM_BUILD_ROOT/usr \
49 libdir=$RPM_BUILD_ROOT/%{_libdir} \
50 root=$RPM_BUILD_ROOT
51
52
53%clean
54[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
55
56%post -p /sbin/ldconfig
57
58%postun -p /sbin/ldconfig
59
60%files
61%defattr(-,root,root)
62%attr(0755,root,root) %{_libdir}/libaio.so.*
63%doc COPYING TODO
64
65%files devel
66%defattr(-,root,root)
67%attr(0644,root,root) %{_includedir}/*
68%attr(0755,root,root) %{_libdir}/libaio.so
69%attr(0644,root,root) %{_libdir}/libaio.a
70
71%changelog
72* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-2
73- changed Group to Development/Libraries
74
75* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.106-1vl5
76- applied new versioning policy, spec in utf-8
77
78* Mon Nov 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.106-0vl1
79- initial build for Vine Linux
80
81* Mon Jul 17 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-3.2
82- rebuild
83
84* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-3.1
85- rebuild
86
87* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.3.106-3
88- rebuild for -devel deps
89
90* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.2
91- bump again for double-long bug on ppc(64)
92
93* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.1
94- rebuilt for new gcc4.1 snapshot and glibc changes
95
96* Wed Jan 04 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-2
97- Update to the latest sources, which contain the following change:
98  Add a .proc directive for the ia64_aio_raw_syscall macro.  This sounds a lot
99  like the previous entry, but that one fixed the __ia64_raw_syscall macro,
100  located in syscall-ia64.h.  This macro is in raw_syscall.c, which pretty much
101  only exists for ia64.  This bug prevented the package from building with
102  newer version of gcc.
103
104* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
105- rebuilt
106
107* Fri Apr  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-2
108- Add Alpha architecture support.  (Sergey Tikhonov <tsv@solvo.ru>)
109
110* Wed Mar 16 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-6
111- Rebuild with gcc 4.
112
113* Mon Feb 14 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-4
114- Build the library twice.  Once with the old SONAME and once with the new
115  one.  This fixes the wrong SONAME problem by keeping a library around with
116  the wrong name (libaio.so.1.0.0) and generating a new one (libaio.so.1.0.1).
117
118* Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
119- update to 102.  Fixes build errors on s390:
120  - S390 asm had a bug; I forgot to update the clobber list.  Lucky for me,
121    newer compilers complain about such things.
122  - Also update the s390 asm to look more like the new kernel variants.
123
124* Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
125- update to 101.  Fixes bz 133253 -  libaio backwards compatibility severely
126  broken.
127
128* Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
129- update to 100.  Fixes bz 129910.  Add pseries and iseries to
130  exclusivearch.
131
132* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
133- rebuilt
134
135* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
136- Apparently the 0.3.93 patch was not meant for 0.3.96.  Backed it out.
137
138* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
139- Fix compat calls.
140- make library .so.1.0.0 and make symlinks properly.
141- Fix header file for inclusion in c++ code.
142
143* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
144- bah.  fix version nr in changelog.
145
146* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
147- fix compiler warnings.
148
149* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
150- make srpm was using rpm to do a build.  changed that to use rpmbuild if
151  it exists, and fallback to rpm if it doesn't.
152
153* Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
154- Use libc syscall(2) instead of rolling our own calling mechanism.  This
155  change is inspired due to a failure to build with newer gcc, since clobber
156  lists were wrong.
157- Add -fpic to the CFLAGS for all architectures.  Should address bz #109457.
158- change a #include from <linux/types.h> to <sys/types.h>.  Fixes a build
159  issue on s390.
160
161* Wed Jul  7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
162- fix paths on lib64 arches
163
164* Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
165- optimization in io_getevents from Arjan van de Ven in 0.3.96-1
166- deal with ia64 in 0.3.96-2
167
168* Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
169- ppc bugfix from Julie DeWandel
170
171* Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
172- symbol versioning fix from Ulrich Drepper
173
174* Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
175- bump to 0.3.93-3 for rebuild.
176
177* Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
178- libaio 0.3.93 test release
179- add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
180- add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
181
182* Fri Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
183- libaio 0.3.92 test release
184- build on x86-64
185
186* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
187- libaio 0.3.91 test release
188- build on ia64
189- remove libredhat-kernel from the .spec file
190
191* Thu Sep  5 2002 Benjamin LaHaise <bcrl@redhat.com>
192- libaio 0.3.90 test release
193
194* Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
195- add requires initscripts >= 6.47-1 to get boot time libredhat-kernel
196  linkage correct.
197- typo fix
198
199* Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
200- make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
201
202* Mon Apr 15 2002 Tim Powers <timp@redhat.com>
203- make the post scriptlet not use /bin/sh
204
205* Sat Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
206- add /lib/libredhat-kernel* to %files.
207
208* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
209- make the dummy install as /lib/libredhat-kernel.so.1.0.0 so
210  that ldconfig will link against it if no other is installed.
211
212* Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
213- add io_getevents
214
215* Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
216- Make linker happy with /usr/lib symlink for libredhat-kernel.so
217
218* Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
219- Added stub library
220
221* Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
222- Initial packaging
Note: See TracBrowser for help on using the repository browser.