source: projects/specs/trunk/lib/liba/libaio/libaio-vl.spec @ 12206

Revision 12206, 9.1 KB checked in by tomop, 5 years ago (diff)

libaio-0.3.112-1

Line 
1Summary: Linux-native asynchronous I/O access library
2Name: libaio
3Version: 0.3.112
4Release: 1%{?_dist_release}
5
6License: LGPLv2+
7Group:  System Environment/Libraries
8
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Source: https://releases.pagure.org/libaio/%{name}-%{version}.tar.gz
13
14# patches from fedora
15Patch2: libaio-remove-nostartfiles-nostdlib-from-build-flags.patch
16
17# patches from debian
18Patch100: 0001-Fix-io_pgetevents-syscall-wrapper-on-32-bit-userland.patch
19Patch101: 02_libdevdir.patch
20Patch102: 0017-harness-Use-destination-strncpy-expression-for-sizeo.patch
21Patch103: 0020-harness-Make-the-test-exit-with-a-code-matching-the-.patch
22Patch104: 0021-harness-add-support-for-skipping-tests.patch
23Patch105: 0022-harness-Add-fallback-code-for-filesystems-not-suppor.patch
24Patch106: 0024-harness-skip-22.p-if-async_poll-isn-t-supported.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27ExclusiveArch: %{ix86} x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6
28
29%description
30The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
31richer API and capability set than the simple POSIX async I/O facility.
32This library, libaio, provides the Linux-native API for async I/O.
33The POSIX async I/O facility requires this library in order to provide
34kernel-accelerated async I/O capabilities, as do applications which
35require the Linux-native async I/O API.
36
37%package devel
38Summary: Development files for Linux-native asynchronous I/O access
39Group: Development/Libraries
40Requires: libaio = %{version}-%{release}
41
42%description devel
43This package provides header files to include and libraries to link with
44for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
45
46%prep
47%setup -q -a 0
48mv %{name}-%{version} compat-%{name}-%{version}
49
50%patch100 -p1
51%patch101 -p1
52%patch102 -p1
53%patch103 -p1
54%patch104 -p1
55%patch105 -p1
56%patch106 -p1
57
58pushd compat-%{name}-%{version}
59%patch100 -p1
60%patch101 -p1
61%patch102 -p1
62%patch103 -p1
63%patch104 -p1
64%patch105 -p1
65%patch106 -p1
66popd
67
68%build
69# A library with a soname of 1.0.0 was inadvertantly released.  This
70# build process builds a version of the library with the broken soname in
71# the compat-libaio-0.3.103 directory, and then builds the library again
72# with the correct soname.
73cd compat-%{name}-%{version}
74make soname='libaio.so.1.0.0' libname='libaio.so.1.0.0'
75cd ..
76make
77
78%install
79[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
80cd compat-%{name}-%{version}
81install -D -m 755 src/libaio.so.1.0.0 \
82  $RPM_BUILD_ROOT/%{_lib}/libaio.so.1.0.0
83cd ..
84make DESTDIR=$RPM_BUILD_ROOT prefix=/ libdir=/%{_lib} libdevdir=%{_libdir} \
85        includedir=%{_includedir} install
86
87rm -f %{buildroot}%{_libdir}/libaio.so
88ln -sf ../../%{_lib}/libaio.so.1 %{buildroot}%{_libdir}/libaio.so
89
90find %{buildroot} -name '*.a' -exec rm -f {} ';'
91
92%check
93make partcheck
94pushd compat-%{name}-%{version}
95make partcheck
96popd
97
98%clean
99[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%attr(0755,root,root) /%{_lib}/libaio.so.*
107%license COPYING
108%doc TODO
109
110%files devel
111%attr(0644,root,root) %{_includedir}/*
112%{_libdir}/libaio.so
113
114%changelog
115* Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.112-1
116- new upstream release.
117- dropped Patch1-2.
118- imported Patch100-105 from debian.
119
120* Tue Oct 28 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.110-1
121- new upstream release.
122
123* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.106-4
124- rebuild with VineSeed environment
125
126* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-3
127- rebuilt with current VineSeed
128
129* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-2
130- changed Group to Development/Libraries
131
132* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.106-1vl5
133- applied new versioning policy, spec in utf-8
134
135* Mon Nov 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.106-0vl1
136- initial build for Vine Linux
137
138* Mon Jul 17 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-3.2
139- rebuild
140
141* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-3.1
142- rebuild
143
144* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.3.106-3
145- rebuild for -devel deps
146
147* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.2
148- bump again for double-long bug on ppc(64)
149
150* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.1
151- rebuilt for new gcc4.1 snapshot and glibc changes
152
153* Wed Jan 04 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-2
154- Update to the latest sources, which contain the following change:
155  Add a .proc directive for the ia64_aio_raw_syscall macro.  This sounds a lot
156  like the previous entry, but that one fixed the __ia64_raw_syscall macro,
157  located in syscall-ia64.h.  This macro is in raw_syscall.c, which pretty much
158  only exists for ia64.  This bug prevented the package from building with
159  newer version of gcc.
160
161* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
162- rebuilt
163
164* Fri Apr  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-2
165- Add Alpha architecture support.  (Sergey Tikhonov <tsv@solvo.ru>)
166
167* Wed Mar 16 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-6
168- Rebuild with gcc 4.
169
170* Mon Feb 14 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-4
171- Build the library twice.  Once with the old SONAME and once with the new
172  one.  This fixes the wrong SONAME problem by keeping a library around with
173  the wrong name (libaio.so.1.0.0) and generating a new one (libaio.so.1.0.1).
174
175* Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
176- update to 102.  Fixes build errors on s390:
177  - S390 asm had a bug; I forgot to update the clobber list.  Lucky for me,
178    newer compilers complain about such things.
179  - Also update the s390 asm to look more like the new kernel variants.
180
181* Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
182- update to 101.  Fixes bz 133253 -  libaio backwards compatibility severely
183  broken.
184
185* Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
186- update to 100.  Fixes bz 129910.  Add pseries and iseries to
187  exclusivearch.
188
189* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
190- rebuilt
191
192* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
193- Apparently the 0.3.93 patch was not meant for 0.3.96.  Backed it out.
194
195* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
196- Fix compat calls.
197- make library .so.1.0.0 and make symlinks properly.
198- Fix header file for inclusion in c++ code.
199
200* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
201- bah.  fix version nr in changelog.
202
203* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
204- fix compiler warnings.
205
206* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
207- make srpm was using rpm to do a build.  changed that to use rpmbuild if
208  it exists, and fallback to rpm if it doesn't.
209
210* Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
211- Use libc syscall(2) instead of rolling our own calling mechanism.  This
212  change is inspired due to a failure to build with newer gcc, since clobber
213  lists were wrong.
214- Add -fpic to the CFLAGS for all architectures.  Should address bz #109457.
215- change a #include from <linux/types.h> to <sys/types.h>.  Fixes a build
216  issue on s390.
217
218* Mon Jul  7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
219- fix paths on lib64 arches
220
221* Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
222- optimization in io_getevents from Arjan van de Ven in 0.3.96-1
223- deal with ia64 in 0.3.96-2
224
225* Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
226- ppc bugfix from Julie DeWandel
227
228* Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
229- symbol versioning fix from Ulrich Drepper
230
231* Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
232- bump to 0.3.93-3 for rebuild.
233
234* Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
235- libaio 0.3.93 test release
236- add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
237- add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
238
239* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
240- libaio 0.3.92 test release
241- build on x86-64
242
243* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
244- libaio 0.3.91 test release
245- build on ia64
246- remove libredhat-kernel from the .spec file
247
248* Thu Sep  5 2002 Benjamin LaHaise <bcrl@redhat.com>
249- libaio 0.3.90 test release
250
251* Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
252- add requires initscripts >= 6.47-1 to get boot time libredhat-kernel
253  linkage correct.
254- typo fix
255
256* Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
257- make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
258
259* Mon Apr 15 2002 Tim Powers <timp@redhat.com>
260- make the post scriptlet not use /bin/sh
261
262* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
263- add /lib/libredhat-kernel* to %files.
264
265* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
266- make the dummy install as /lib/libredhat-kernel.so.1.0.0 so
267  that ldconfig will link against it if no other is installed.
268
269* Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
270- add io_getevents
271
272* Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
273- Make linker happy with /usr/lib symlink for libredhat-kernel.so
274
275* Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
276- Added stub library
277
278* Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
279- Initial packaging
Note: See TracBrowser for help on using the repository browser.