source: projects/specs/trunk/lib/liba/libaio/libaio-vl.spec @ 9036

Revision 9036, 8.0 KB checked in by tomop, 10 years ago (diff)

libaio-0.3.110-1

Line 
1Summary: Linux-native asynchronous I/O access library
2Name: libaio
3Version: 0.3.110
4Release: 1%{?_dist_release}
5
6License: LGPLv2+
7Group:  System Environment/Libraries
8
9Source: %{name}-%{version}.tar.gz
10Patch1: libaio-install-to-destdir-slash-usr.patch
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13ExclusiveArch: %{ix86} x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6
14
15%description
16The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
17richer API and capability set than the simple POSIX async I/O facility.
18This library, libaio, provides the Linux-native API for async I/O.
19The POSIX async I/O facility requires this library in order to provide
20kernel-accelerated async I/O capabilities, as do applications which
21require the Linux-native async I/O API.
22
23%package devel
24Summary: Development files for Linux-native asynchronous I/O access
25Group: Development/Libraries
26Requires: libaio = %{version}-%{release}
27
28%description devel
29This package provides header files to include and libraries to link with
30for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
31
32%prep
33%setup -q -a 0
34%patch1 -p0 -b .install-to-destdir-slash-usr
35%patch1 -p1 -b .install-to-destdir-slash-usr
36mv %{name}-%{version} compat-%{name}-%{version}
37
38%build
39# A library with a soname of 1.0.0 was inadvertantly released.  This
40# build process builds a version of the library with the broken soname in
41# the compat-libaio-0.3.103 directory, and then builds the library again
42# with the correct soname.
43cd compat-%{name}-%{version}
44make soname='libaio.so.1.0.0' libname='libaio.so.1.0.0'
45cd ..
46make
47
48%install
49[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
50cd compat-%{name}-%{version}
51install -D -m 755 src/libaio.so.1.0.0 \
52  $RPM_BUILD_ROOT/%{_libdir}/libaio.so.1.0.0
53cd ..
54make destdir=$RPM_BUILD_ROOT prefix=/ libdir=/%{_lib} usrlibdir=%{_libdir} \
55        includedir=%{_includedir} install
56
57find %{buildroot} -name '*.a' -exec rm -f {} ';'
58
59%clean
60[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66%files
67%attr(0755,root,root) %{_libdir}/libaio.so.*
68%doc COPYING TODO
69
70%files devel
71%attr(0644,root,root) %{_includedir}/*
72%attr(0755,root,root) %{_libdir}/libaio.so
73
74%changelog
75* Tue Oct 28 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.110-1
76- new upstream release.
77
78* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.106-4
79- rebuild with VineSeed environment
80
81* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-3
82- rebuilt with current VineSeed
83
84* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-2
85- changed Group to Development/Libraries
86
87* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.106-1vl5
88- applied new versioning policy, spec in utf-8
89
90* Mon Nov 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.106-0vl1
91- initial build for Vine Linux
92
93* Mon Jul 17 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-3.2
94- rebuild
95
96* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-3.1
97- rebuild
98
99* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.3.106-3
100- rebuild for -devel deps
101
102* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.2
103- bump again for double-long bug on ppc(64)
104
105* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.1
106- rebuilt for new gcc4.1 snapshot and glibc changes
107
108* Wed Jan 04 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-2
109- Update to the latest sources, which contain the following change:
110  Add a .proc directive for the ia64_aio_raw_syscall macro.  This sounds a lot
111  like the previous entry, but that one fixed the __ia64_raw_syscall macro,
112  located in syscall-ia64.h.  This macro is in raw_syscall.c, which pretty much
113  only exists for ia64.  This bug prevented the package from building with
114  newer version of gcc.
115
116* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
117- rebuilt
118
119* Fri Apr  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-2
120- Add Alpha architecture support.  (Sergey Tikhonov <tsv@solvo.ru>)
121
122* Wed Mar 16 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-6
123- Rebuild with gcc 4.
124
125* Mon Feb 14 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-4
126- Build the library twice.  Once with the old SONAME and once with the new
127  one.  This fixes the wrong SONAME problem by keeping a library around with
128  the wrong name (libaio.so.1.0.0) and generating a new one (libaio.so.1.0.1).
129
130* Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
131- update to 102.  Fixes build errors on s390:
132  - S390 asm had a bug; I forgot to update the clobber list.  Lucky for me,
133    newer compilers complain about such things.
134  - Also update the s390 asm to look more like the new kernel variants.
135
136* Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
137- update to 101.  Fixes bz 133253 -  libaio backwards compatibility severely
138  broken.
139
140* Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
141- update to 100.  Fixes bz 129910.  Add pseries and iseries to
142  exclusivearch.
143
144* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
145- rebuilt
146
147* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
148- Apparently the 0.3.93 patch was not meant for 0.3.96.  Backed it out.
149
150* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
151- Fix compat calls.
152- make library .so.1.0.0 and make symlinks properly.
153- Fix header file for inclusion in c++ code.
154
155* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
156- bah.  fix version nr in changelog.
157
158* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
159- fix compiler warnings.
160
161* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
162- make srpm was using rpm to do a build.  changed that to use rpmbuild if
163  it exists, and fallback to rpm if it doesn't.
164
165* Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
166- Use libc syscall(2) instead of rolling our own calling mechanism.  This
167  change is inspired due to a failure to build with newer gcc, since clobber
168  lists were wrong.
169- Add -fpic to the CFLAGS for all architectures.  Should address bz #109457.
170- change a #include from <linux/types.h> to <sys/types.h>.  Fixes a build
171  issue on s390.
172
173* Mon Jul  7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
174- fix paths on lib64 arches
175
176* Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
177- optimization in io_getevents from Arjan van de Ven in 0.3.96-1
178- deal with ia64 in 0.3.96-2
179
180* Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
181- ppc bugfix from Julie DeWandel
182
183* Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
184- symbol versioning fix from Ulrich Drepper
185
186* Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
187- bump to 0.3.93-3 for rebuild.
188
189* Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
190- libaio 0.3.93 test release
191- add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
192- add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
193
194* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
195- libaio 0.3.92 test release
196- build on x86-64
197
198* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
199- libaio 0.3.91 test release
200- build on ia64
201- remove libredhat-kernel from the .spec file
202
203* Thu Sep  5 2002 Benjamin LaHaise <bcrl@redhat.com>
204- libaio 0.3.90 test release
205
206* Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
207- add requires initscripts >= 6.47-1 to get boot time libredhat-kernel
208  linkage correct.
209- typo fix
210
211* Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
212- make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
213
214* Mon Apr 15 2002 Tim Powers <timp@redhat.com>
215- make the post scriptlet not use /bin/sh
216
217* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
218- add /lib/libredhat-kernel* to %files.
219
220* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
221- make the dummy install as /lib/libredhat-kernel.so.1.0.0 so
222  that ldconfig will link against it if no other is installed.
223
224* Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
225- add io_getevents
226
227* Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
228- Make linker happy with /usr/lib symlink for libredhat-kernel.so
229
230* Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
231- Added stub library
232
233* Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
234- Initial packaging
Note: See TracBrowser for help on using the repository browser.