source: projects/specs/trunk/lib/libX/libXxf86vm/libXxf86vm-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXxf86vm runtime library
4Summary(ja): X.Org X11 libXxf86vm ランタイムライブラリ
5Name: libXxf86vm
6Version: 1.1.0
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19Obsoletes: XFree86-libs, XOrg-libs
20
21%description
22X.Org X11 libXxf86vm runtime library
23
24%package devel
25Summary: X.Org X11 libXxf86vm development package
26Summary(ja): X.Org X11 libXxf86vm 開発パッケージ
27Group: Development/Libraries
28Requires(pre): xorg-x11-filesystem
29Requires: %{name} = %{version}-%{release}
30Requires: xorg-x11-proto-devel
31Obsoletes: XFree86-devel, XOrg-devel
32
33%description devel
34X.Org X11 libXxf86vm development package
35
36# compat32
37%package -n compat32-%{name}
38Summary: X.Org X11 libXxf86vm runtime library
39Summary(ja): X.Org X11 libXxf86vm ランタイムライブラリ
40Group: System Environment/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description -n compat32-%{name}
44X.Org X11 libXxf86vm runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXxf86vm development package
48Summary(ja): X.Org X11 libXxf86vm 開発パッケージ
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53
54%description -n compat32-%{name}-devel
55X.Org X11 libXxf86vm development package
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64%configure \
65%if ! %{with_static}
66        --disable-static
67%endif
68make
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75# We intentionally don't ship *.la files
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
84%post -n compat32-%{name} -p /sbin/ldconfig
85%postun -n compat32-%{name} -p /sbin/ldconfig
86
87%files
88%defattr(-,root,root,-)
89# FIXME: missing some of these files %doc AUTHORS COPYING README INSTALL ChangeLog
90%doc COPYING ChangeLog
91%{_libdir}/libXxf86vm.so.1
92%{_libdir}/libXxf86vm.so.1.*
93
94%files devel
95%defattr(-,root,root,-)
96%{_includedir}/X11/extensions/*.h
97%if %{with_static}
98%{_libdir}/libXxf86vm.a
99%endif
100%{_libdir}/libXxf86vm.so
101%{_libdir}/pkgconfig/xxf86vm.pc
102%{_mandir}/man3/*.3*
103
104# compat32
105%if %{build_compat32}
106%files -n compat32-%{name}
107%defattr(-,root,root,-)
108%{_libdir}/libXxf86vm.so.1
109%{_libdir}/libXxf86vm.so.1.*
110
111%files -n compat32-%{name}-devel
112%defattr(-,root,root,-)
113%if %{with_static}
114%{_libdir}/libXxf86vm.a
115%endif
116%{_libdir}/libXxf86vm.so
117%{_libdir}/pkgconfig/xxf86vm.pc
118%endif
119
120%changelog
121* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
122- add xf86vmode.h
123
124* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
125- new upstream release
126
127* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-2
128- added compat32 package for x86_64 arch support
129
130* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
131- new upstream release
132
133* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
134- new versioning policy
135
136* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
137- initial build for Vine Linux
138
139* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
140- Rebuild for build id
141
142* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
143- rebuild
144
145* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
146- Added "Requires: xorg-x11-proto-devel"
147- Remove package ownership of mandir/libdir/etc.
148
149* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
150- Added "BuildRequires: pkgconfig" for (#193509)
151- Use "make install DESTDIR=..." instead of makeinstall macro, to fix (#192731)
152
153* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
154- Update to 1.0.1
155
156* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
157- bump again for double-long bug on ppc(64)
158
159* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
160- rebuilt for new gcc4.1 snapshot and glibc changes
161
162* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
163- Bumped and rebuilt
164
165* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
166- Updated libXxf86vm to version 1.0.0 from X11R7 RC4
167
168* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
169- Updated libXxf86vm to version 0.99.2 from X11R7 RC3
170- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
171  that /usr/lib/X11 and /usr/include/X11 pre-exist.
172- Removed 'x' suffix from manpage directories to match RC3 upstream.
173
174* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
175- rebuilt
176
177* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
178- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
179- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
180
181* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
182- Bump release and rebuild to satiate beehive wonkiness.
183
184* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
185- Updated libXxf86vm to version 0.99.1 from X11R7 RC1
186- Updated file manifest to find manpages in "man3x"
187
188* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
189- Renamed package to remove xorg-x11 from the name due to unanimous decision
190  between developers.
191- Use Fedora Extras style BuildRoot tag.
192- Disable static library creation by default.
193- Add missing defattr to devel subpackage
194- Add missing documentation files to doc macro
195
196* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
197- Renamed package to prepend "xorg-x11" to the name for consistency with
198  the rest of the X11R7 packages.
199- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
200  subpackage to ensure the devel package matches the installed shared libs.
201- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
202  allow applications to use implementation agnostic dependencies.
203- Added post/postun scripts which call ldconfig.
204- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
205  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
206
207* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
208- Initial build.
Note: See TracBrowser for help on using the repository browser.