source: projects/specs/trunk/lib/libX/libXv/libXv-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXv runtime library
4Summary(ja): X.Org X11 libXv ランタイムライブラリ
5Name:    libXv
6Version: 1.0.5
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19Obsoletes: XFree86-libs, XOrg-libs
20
21%description
22X.Org X11 libXv runtime library
23
24%package devel
25Summary: X.Org X11 libXv development package
26Summary(ja): X.Org X11 libXv 開発パッケージ
27Group: Development/Libraries
28Requires(pre): xorg-x11-filesystem
29Requires: %{name} = %{version}-%{release}
30Requires: libXext-devel
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXv development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXv runtime library
40Summary(ja): X.Org X11 libXv ランタイムライブラリ
41Group: System Environment/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description -n compat32-%{name}
45X.Org X11 libXv runtime library
46
47%package -n compat32-%{name}-devel
48Summary: X.Org X11 libXv development package
49Summary(ja): X.Org X11 libXv 開発パッケージ
50Group: Development/Libraries
51Requires(pre): xorg-x11-filesystem
52Requires: %{name}-devel = %{version}-%{release}
53Requires: compat32-%{name} = %{version}-%{release}
54Requires: compat32-libXext-devel
55
56%description -n compat32-%{name}-devel
57X.Org X11 libXv development package
58
59%prep
60%setup -q
61
62# Disable static library creation by default.
63%define with_static 0
64
65%build
66%configure \
67%if ! %{with_static}
68        --disable-static
69%endif
70make
71
72%install
73
74rm -rf $RPM_BUILD_ROOT
75make install DESTDIR=$RPM_BUILD_ROOT
76
77# We intentionally don't ship *.la files
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%post -n compat32-%{name} -p /sbin/ldconfig
87%postun -n compat32-%{name} -p /sbin/ldconfig
88
89%files
90%defattr(-,root,root,-)
91%doc AUTHORS COPYING README ChangeLog
92%{_libdir}/libXv.so.1
93%{_libdir}/libXv.so.1.0.0
94
95%files devel
96%defattr(-,root,root,-)
97%dir %{_includedir}/X11
98%dir %{_includedir}/X11/extensions
99%{_includedir}/X11/extensions/Xvlib.h
100%if %{with_static}
101%{_libdir}/libXv.a
102%endif
103%{_libdir}/libXv.so
104%{_libdir}/pkgconfig/xv.pc
105%{_mandir}/man3/*.3*
106
107# compat32
108%if %{build_compat32}
109%files -n compat32-%{name}
110%defattr(-,root,root,-)
111%{_libdir}/libXv.so.1
112%{_libdir}/libXv.so.1.0.0
113
114%files -n compat32-%{name}-devel
115%defattr(-,root,root,-)
116%if %{with_static}
117%{_libdir}/libXv.a
118%endif
119%{_libdir}/libXv.so
120%{_libdir}/pkgconfig/xv.pc
121%endif
122
123%changelog
124* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
125- new upstream release
126
127* Wed Jul 08 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
128- added compat32 package for x86_64 arch support
129
130* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
131- new upstream release
132
133* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
134- new versioning policy
135
136* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
137- initial build for Vine Linux
138
139* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
140- Rebuild for build id
141
142* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
143- Don't install INSTALL
144
145* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
146- Update to 1.0.3
147
148* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1.fc7
149- Update to 1.0.2
150
151* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-4.1
152- rebuild
153
154* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-4
155- Added "Requires: xorg-x11-proto-devel" to devel package for xv.pc
156
157* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
158- Added "BuildRequires: pkgconfig" for (#193505)
159- Replace "makeinstall" with "make install DESTDIR=..."
160- Remove package ownership of mandir/libdir/etc.
161
162* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
163- Added "Requires: libXext-devel" to libXv-devel subpackage, to avoid all
164  packages that depend on libXv-devel from having to manually specify that
165  dependency themselves, as it is required by Xv.  (#192167)
166
167* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
168- bump again for double-long bug on ppc(64)
169
170* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
171- rebuilt for new gcc4.1 snapshot and glibc changes
172
173* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
174- Updated libXv to version 1.0.1 from X11R7.0
175
176* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
177- Updated libXv to version 0.99.2 from X11R7 RC3
178- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
179  that /usr/lib/X11 and /usr/include/X11 pre-exist.
180- Removed 'x' suffix from manpage directories to match RC3 upstream.
181
182* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
183- rebuilt
184
185* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
186- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
187- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
188
189* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
190- Updated libXv to version 0.99.1 from X11R7 RC1
191- Updated file manifest to find manpages in "man3x"
192
193* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
194- Renamed package to remove xorg-x11 from the name due to unanimous decision
195  between developers.
196- Use Fedora Extras style BuildRoot tag.
197- Disable static library creation by default.
198- Add missing defattr to devel subpackage
199- Add missing documentation files to doc macro
200
201* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
202- Renamed package to prepend "xorg-x11" to the name for consistency with
203  the rest of the X11R7 packages.
204- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
205  subpackage to ensure the devel package matches the installed shared libs.
206- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
207  allow applications to use implementation agnostic dependencies.
208- Added post/postun scripts which call ldconfig.
209- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
210  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
211
212* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
213- Initial build.
Note: See TracBrowser for help on using the repository browser.