source: projects/specs/trunk/lib/libX/libXv/libXv-vl.spec @ 8064

Revision 8064, 7.1 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXv runtime library
4Summary(ja): X.Org X11 libXv ランタイムライブラリ
5Name:    libXv
6Version: 1.0.10
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libXext-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27X.Org X11 libXv runtime library
28
29%package devel
30Summary: X.Org X11 libXv development package
31Summary(ja): X.Org X11 libXv 開発パッケージ
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem
34Requires: %{name} = %{version}-%{release}
35Requires: libXext-devel
36Requires: xorg-x11-proto-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXv development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXv runtime library
45Summary(ja): X.Org X11 libXv ランタイムライブラリ
46Group: System Environment/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description -n compat32-%{name}
50X.Org X11 libXv runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXv development package
54Summary(ja): X.Org X11 libXv 開発パッケージ
55Group: Development/Libraries
56Requires(pre): xorg-x11-filesystem
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: compat32-libXext-devel
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXv development package
63
64%prep
65%setup -q
66
67# Disable static library creation by default.
68%define with_static 0
69
70%build
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# We intentionally don't ship *.la files
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%post -n compat32-%{name} -p /sbin/ldconfig
92%postun -n compat32-%{name} -p /sbin/ldconfig
93
94%files
95%defattr(-,root,root,-)
96%doc AUTHORS COPYING README ChangeLog
97%{_libdir}/libXv.so.1
98%{_libdir}/libXv.so.1.0.0
99
100%files devel
101%defattr(-,root,root,-)
102%dir %{_includedir}/X11
103%dir %{_includedir}/X11/extensions
104%{_includedir}/X11/extensions/Xvlib.h
105%if %{with_static}
106%{_libdir}/libXv.a
107%endif
108%{_libdir}/libXv.so
109%{_libdir}/pkgconfig/xv.pc
110%{_mandir}/man3/*.3*
111
112# compat32
113%if %{build_compat32}
114%files -n compat32-%{name}
115%defattr(-,root,root,-)
116%{_libdir}/libXv.so.1
117%{_libdir}/libXv.so.1.0.0
118
119%files -n compat32-%{name}-devel
120%defattr(-,root,root,-)
121%if %{with_static}
122%{_libdir}/libXv.a
123%endif
124%{_libdir}/libXv.so
125%endif
126
127%changelog
128* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-2
129- rebuild with VineSeed environment
130
131* Mon Sep 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
132- new upstream release
133
134* Mon Aug 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
135- new upstream release
136
137* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
138- new upstream release
139  (including security fix for CVE-2013-1989,2066)
140
141* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
142- new upstream release
143- add BuildRequires: xorg-x11-util-macros
144
145* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
146- new upstream release
147
148* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
149- rebuild with rpm-4.8.1 for pkg-config file
150
151* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
152- new upstream release
153
154* Wed Jul 08 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
155- added compat32 package for x86_64 arch support
156
157* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
158- new upstream release
159
160* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
161- new versioning policy
162
163* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
164- initial build for Vine Linux
165
166* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
167- Rebuild for build id
168
169* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
170- Don't install INSTALL
171
172* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
173- Update to 1.0.3
174
175* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1.fc7
176- Update to 1.0.2
177
178* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-4.1
179- rebuild
180
181* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-4
182- Added "Requires: xorg-x11-proto-devel" to devel package for xv.pc
183
184* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
185- Added "BuildRequires: pkgconfig" for (#193505)
186- Replace "makeinstall" with "make install DESTDIR=..."
187- Remove package ownership of mandir/libdir/etc.
188
189* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
190- Added "Requires: libXext-devel" to libXv-devel subpackage, to avoid all
191  packages that depend on libXv-devel from having to manually specify that
192  dependency themselves, as it is required by Xv.  (#192167)
193
194* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
195- bump again for double-long bug on ppc(64)
196
197* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
198- rebuilt for new gcc4.1 snapshot and glibc changes
199
200* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
201- Updated libXv to version 1.0.1 from X11R7.0
202
203* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
204- Updated libXv to version 0.99.2 from X11R7 RC3
205- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
206  that /usr/lib/X11 and /usr/include/X11 pre-exist.
207- Removed 'x' suffix from manpage directories to match RC3 upstream.
208
209* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
210- rebuilt
211
212* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
213- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
214- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
215
216* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
217- Updated libXv to version 0.99.1 from X11R7 RC1
218- Updated file manifest to find manpages in "man3x"
219
220* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
221- Renamed package to remove xorg-x11 from the name due to unanimous decision
222  between developers.
223- Use Fedora Extras style BuildRoot tag.
224- Disable static library creation by default.
225- Add missing defattr to devel subpackage
226- Add missing documentation files to doc macro
227
228* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
229- Renamed package to prepend "xorg-x11" to the name for consistency with
230  the rest of the X11R7 packages.
231- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
232  subpackage to ensure the devel package matches the installed shared libs.
233- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
234  allow applications to use implementation agnostic dependencies.
235- Added post/postun scripts which call ldconfig.
236- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
237  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
238
239* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
240- Initial build.
Note: See TracBrowser for help on using the repository browser.