source: projects/specs/trunk/lib/libX/libXtst/libXtst-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXtst runtime library
4Summary(ja): X.Org X11 libXtst ランタイムライブラリ
5Name: libXtst
6Version: 1.1.0
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19
20Obsoletes: XFree86-libs, XOrg-libs
21
22%description
23X.Org X11 libXtst runtime library
24
25%package devel
26Summary: X.Org X11 libXtst development package
27Summary(ja): X.Org X11 libXtst 開発パッケージ
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXtst development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXtst runtime library
40Summary(ja): X.Org X11 libXtst ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXtst runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXtst development package
48Summary(ja): X.Org X11 libXtst 開発パッケージ
49Group: Development/Libraries
50Requires(pre): xorg-x11-filesystem
51Requires: compat32-%{name} = %{version}-%{release}
52Requires: %{name}-devel = %{version}-%{release}
53
54%description -n compat32-%{name}-devel
55X.Org X11 libXtst development package
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64
65%configure \
66%if ! %{with_static}
67        --disable-static
68%endif
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# We intentionally don't ship *.la files
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83%postun -p /sbin/ldconfig
84
85%post -n compat32-%{name} -p /sbin/ldconfig
86%postun -n compat32-%{name} -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root,-)
90%doc AUTHORS COPYING README ChangeLog
91%{_libdir}/libXtst.so.6
92%{_libdir}/libXtst.so.6.*
93
94%files devel
95%defattr(-,root,root,-)
96%{_includedir}/X11/extensions/*.h
97%if %{with_static}
98%{_libdir}/libXtst.a
99%endif
100%{_libdir}/libXtst.so
101%{_libdir}/pkgconfig/xtst.pc
102%{_mandir}/man3/XTest*.3*
103
104# compat32
105%if %{build_compat32}
106%files -n compat32-%{name}
107%defattr(-,root,root,-)
108%{_libdir}/libXtst.so.6
109%{_libdir}/libXtst.so.6.*
110
111%files -n compat32-%{name}-devel
112%defattr(-,root,root,-)
113%if %{with_static}
114%{_libdir}/libXtst.a
115%endif
116%{_libdir}/libXtst.so
117%{_libdir}/pkgconfig/xtst.pc
118%endif
119
120%changelog
121* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
122- add XTest.h/record.h to libXtst-devel
123
124* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
125- new upstream release
126
127* Sat May 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.3-3
128- added compat32 package for x86_64 arch support
129
130* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-2
131- spec in utf-8
132
133* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
134- new versioning policy
135
136* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
137- initial build for Vine Linux
138
139* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
140- libXtst 1.0.3
141
142* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-2
143- Rebuild for PPC toolchain bug
144
145* Sat Jun 23 2007 Adam Jackson <ajax@redhat.com> 1.0.2-1.
146- libXtst 1.0.2
147
148* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.0.1-4
149- Don't install INSTALL
150
151* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
152- rebuild
153
154* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
155- Added "Requires: xorg-x11-proto-devel" to devel package for xtst.pc
156
157* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
158- Added "BuildRequires: pkgconfig" for (#193504)
159- Replace "makeinstall" with "make install DESTDIR=..."
160- Remove package ownership of mandir/libdir/etc.
161
162* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
163- bump again for double-long bug on ppc(64)
164
165* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
166- rebuilt for new gcc4.1 snapshot and glibc changes
167
168* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
169- Updated libXtst to version 1.0.1 from X11R7.0
170
171* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
172- Updated libXtst to version 1.0.0 from X11R7 RC4
173
174* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
175- Updated libXtst to version 0.99.3 from X11R7 RC3
176- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
177  that /usr/lib/X11 and /usr/include/X11 pre-exist.
178- Removed 'x' suffix from manpage directories to match RC3 upstream.
179
180* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
181- rebuilt
182
183* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
184- Updated libXtst to version 0.99.2 from X11R7 RC2
185- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
186- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
187
188* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
189- Updated libXtst to version 0.99.1 from X11R7 RC1
190
191* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
192- Renamed package to remove xorg-x11 from the name due to unanimous decision
193  between developers.
194- Use Fedora Extras style BuildRoot tag.
195- Disable static library creation by default.
196- Add missing defattr to devel subpackage
197- Add missing documentation files to doc macro
198
199* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
200- Renamed package to prepend "xorg-x11" to the name for consistency with
201  the rest of the X11R7 packages.
202- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
203  subpackage to ensure the devel package matches the installed shared libs.
204- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
205  allow applications to use implementation agnostic dependencies.
206- Added post/postun scripts which call ldconfig.
207- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
208  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
209
210* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
211- Initial build.
Note: See TracBrowser for help on using the repository browser.