source: projects/specs/trunk/lib/libX/libXtst/libXtst-vl.spec @ 8064

Revision 8064, 7.1 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXtst runtime library
4Summary(ja): X.Org X11 libXtst ランタイムライブラリ
5Name: libXtst
6Version: 1.2.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libXext-devel
20BuildRequires: libXi-devel
21
22Obsoletes: XFree86-libs, XOrg-libs
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Takemikaduchi
27
28%description
29X.Org X11 libXtst runtime library
30
31%package devel
32Summary: X.Org X11 libXtst development package
33Summary(ja): X.Org X11 libXtst 開発パッケージ
34Group: Development/Libraries
35Requires(pre): xorg-x11-filesystem
36Requires: %{name} = %{version}-%{release}
37Requires: xorg-x11-proto-devel
38Requires: libXi-devel
39Obsoletes: XFree86-devel, XOrg-devel
40
41%description devel
42X.Org X11 libXtst development package
43
44# compat32
45%package -n compat32-%{name}
46Summary: X.Org X11 libXtst runtime library
47Summary(ja): X.Org X11 libXtst ランタイムライブラリ
48Group: System Environment/Libraries
49
50%description -n compat32-%{name}
51X.Org X11 libXtst runtime library
52
53%package -n compat32-%{name}-devel
54Summary: X.Org X11 libXtst development package
55Summary(ja): X.Org X11 libXtst 開発パッケージ
56Group: Development/Libraries
57Requires(pre): xorg-x11-filesystem
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: %{name}-devel = %{version}-%{release}
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXtst development package
63
64%prep
65%setup -q
66
67# Disable static library creation by default.
68%define with_static 0
69
70%build
71
72%configure \
73%if ! %{with_static}
74        --disable-static
75%endif
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81make install DESTDIR=$RPM_BUILD_ROOT
82
83# We intentionally don't ship *.la files
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85
86# remove xml and txt file
87rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
88rm -rf $RPM_BUILD_ROOT%{_mandir}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%doc AUTHORS COPYING README ChangeLog
102%{_libdir}/libXtst.so.6
103%{_libdir}/libXtst.so.6.*
104
105%files devel
106%defattr(-,root,root,-)
107%{_includedir}/X11/extensions/*.h
108%if %{with_static}
109%{_libdir}/libXtst.a
110%endif
111%{_libdir}/libXtst.so
112%{_libdir}/pkgconfig/xtst.pc
113
114# compat32
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root,-)
118%{_libdir}/libXtst.so.6
119%{_libdir}/libXtst.so.6.*
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root,-)
123%if %{with_static}
124%{_libdir}/libXtst.a
125%endif
126%{_libdir}/libXtst.so
127%endif
128
129%changelog
130* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
131- rebuild with VineSeed environment
132
133* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
134- new upstream release
135  (including security fix for CVE-2013-2063)
136
137* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
138- new upstream release
139- add BuildRequires: xorg-x11-util-macros
140
141* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
142- add Requires: libXi-devel (devel package)
143
144* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
145- new upstream release
146
147* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-3
148- rebuild with rpm-4.8.1 for pkg-config file
149- add BuildRequires: libXi-devel
150- fix %files (remove man3)
151
152* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
153- add XTest.h/record.h to libXtst-devel
154
155* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
156- new upstream release
157
158* Sat May 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.3-3
159- added compat32 package for x86_64 arch support
160
161* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-2
162- spec in utf-8
163
164* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
165- new versioning policy
166
167* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
168- initial build for Vine Linux
169
170* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
171- libXtst 1.0.3
172
173* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-2
174- Rebuild for PPC toolchain bug
175
176* Sat Jun 23 2007 Adam Jackson <ajax@redhat.com> 1.0.2-1.
177- libXtst 1.0.2
178
179* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.0.1-4
180- Don't install INSTALL
181
182* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
183- rebuild
184
185* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
186- Added "Requires: xorg-x11-proto-devel" to devel package for xtst.pc
187
188* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
189- Added "BuildRequires: pkgconfig" for (#193504)
190- Replace "makeinstall" with "make install DESTDIR=..."
191- Remove package ownership of mandir/libdir/etc.
192
193* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
194- bump again for double-long bug on ppc(64)
195
196* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
197- rebuilt for new gcc4.1 snapshot and glibc changes
198
199* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
200- Updated libXtst to version 1.0.1 from X11R7.0
201
202* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
203- Updated libXtst to version 1.0.0 from X11R7 RC4
204
205* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
206- Updated libXtst to version 0.99.3 from X11R7 RC3
207- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
208  that /usr/lib/X11 and /usr/include/X11 pre-exist.
209- Removed 'x' suffix from manpage directories to match RC3 upstream.
210
211* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
212- rebuilt
213
214* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
215- Updated libXtst to version 0.99.2 from X11R7 RC2
216- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
217- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
218
219* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
220- Updated libXtst to version 0.99.1 from X11R7 RC1
221
222* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
223- Renamed package to remove xorg-x11 from the name due to unanimous decision
224  between developers.
225- Use Fedora Extras style BuildRoot tag.
226- Disable static library creation by default.
227- Add missing defattr to devel subpackage
228- Add missing documentation files to doc macro
229
230* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
231- Renamed package to prepend "xorg-x11" to the name for consistency with
232  the rest of the X11R7 packages.
233- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
234  subpackage to ensure the devel package matches the installed shared libs.
235- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
236  allow applications to use implementation agnostic dependencies.
237- Added post/postun scripts which call ldconfig.
238- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
239  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
240
241* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
242- Initial build.
Note: See TracBrowser for help on using the repository browser.