source: projects/specs/trunk/lib/libX/libXt/libXt-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.0.7
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14Patch0:     libXt-1.0.2-libsm-fix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: pkgconfig
18BuildRequires: xorg-x11-proto-devel
19BuildRequires: libX11-devel
20BuildRequires: libSM-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23%description
24X.Org X11 libXt runtime library
25
26%package devel
27Summary: X.Org X11 libXt development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Requires: libX11-devel
33Requires: libSM-devel
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libXt development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libXt runtime library
42Summary(ja): X.Org X11 libXt ランタイムライブラリ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46X.Org X11 libXt runtime library
47
48%package -n compat32-%{name}-devel
49Summary: X.Org X11 libXt development package
50Group: Development/Libraries
51Requires(pre): xorg-x11-filesystem
52Requires: compat32-%{name} = %{version}-%{release}
53Requires: %{name}-devel = %{version}-%{release}
54Requires: compat32-libX11-devel
55Requires: compat32-libSM-devel
56
57%description -n compat32-%{name}-devel
58X.Org X11 libXt development package
59
60%prep
61%setup -q
62
63%patch0 -p1 -b .libsm-fix
64
65# Disable static library creation by default.
66%define with_static 0
67
68%build
69# FIXME: Work around pointer aliasing warnings from compiler for now
70export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
71%configure \
72%if ! %{with_static}
73        --disable-static \
74%endif
75        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
76
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83# NOTE: Create app-defaults directory so this package can be the canonical
84# owner of the directory.
85mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
86
87# We intentionally don't ship *.la files
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%doc AUTHORS COPYING README ChangeLog NEWS
102%{_libdir}/libXt.so.6
103%{_libdir}/libXt.so.6.0.0
104%dir %{_datadir}/X11/app-defaults
105
106%files devel
107%defattr(-,root,root,-)
108%{_bindir}/makestrs
109%dir %{_includedir}/X11
110# Listed explicitly instead of with glob, in order for rpm to autodetect
111# when any additions or removals happen.  ie: New Xprint support that we
112# do not want.
113%{_includedir}/X11/CallbackI.h
114%{_includedir}/X11/Composite.h
115%{_includedir}/X11/CompositeP.h
116%{_includedir}/X11/ConstrainP.h
117%{_includedir}/X11/Constraint.h
118%{_includedir}/X11/ConvertI.h
119%{_includedir}/X11/Core.h
120%{_includedir}/X11/CoreP.h
121%{_includedir}/X11/CreateI.h
122%{_includedir}/X11/EventI.h
123%{_includedir}/X11/HookObjI.h
124%{_includedir}/X11/InitialI.h
125%{_includedir}/X11/Intrinsic.h
126%{_includedir}/X11/IntrinsicI.h
127%{_includedir}/X11/IntrinsicP.h
128%{_includedir}/X11/Object.h
129%{_includedir}/X11/ObjectP.h
130%{_includedir}/X11/PassivGraI.h
131%{_includedir}/X11/RectObj.h
132%{_includedir}/X11/RectObjP.h
133%{_includedir}/X11/ResConfigP.h
134%{_includedir}/X11/ResourceI.h
135%{_includedir}/X11/SelectionI.h
136%{_includedir}/X11/Shell.h
137%{_includedir}/X11/ShellI.h
138%{_includedir}/X11/ShellP.h
139%{_includedir}/X11/StringDefs.h
140%{_includedir}/X11/ThreadsI.h
141%{_includedir}/X11/TranslateI.h
142%{_includedir}/X11/VarargsI.h
143%{_includedir}/X11/Vendor.h
144%{_includedir}/X11/VendorP.h
145%{_includedir}/X11/Xtos.h
146%if %{with_static}
147%{_libdir}/libXt.a
148%endif
149%{_libdir}/libXt.so
150%{_libdir}/pkgconfig/xt.pc
151%{_mandir}/man1/makestrs.1*
152%{_mandir}/man3/*.3*
153
154# compat32
155%if %{build_compat32}
156%files -n compat32-%{name}
157%defattr(-,root,root,-)
158%{_libdir}/libXt.so.6
159%{_libdir}/libXt.so.6.0.0
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root,-)
163%if %{with_static}
164%{_libdir}/libXt.a
165%endif
166%{_libdir}/libXt.so
167%{_libdir}/pkgconfig/xt.pc
168%endif
169
170%changelog
171* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
172- new upstream release
173
174* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
175- added compat32 package for x86_64 arch support
176
177* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
178- new upstream release
179
180* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
181- new versioning policy
182
183* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
184- initial build for Vine Linux
185
186* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
187- Rebuild for build id
188
189* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
190- Don't install INSTALL
191
192* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
193- Update to 1.0.4
194
195* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
196- rebuild
197
198* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
199- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
200  libXt is the canonical owner of the directory.  Discovered in (#198025).
201
202* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
203- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
204  in the installed pkgconfig file.  Apps should link against libSM if they
205  need it, but we shouldn't force them to link against it if they don't.
206
207* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
208- Updated libXt to version 1.0.2 from X11R7.1
209
210* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
211- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
212
213* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
214- Added "BuildRequires: pkgconfig" for (#193503)
215- Replace "makeinstall" with "make install DESTDIR=..."
216- Remove package ownership of mandir/libdir/etc.
217
218* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
219- Update to 1.0.1
220
221* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
222- bump again for double-long bug on ppc(64)
223
224* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
225- rebuilt for new gcc4.1 snapshot and glibc changes
226
227* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
228- Bumped and rebuilt
229
230* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
231- Updated libXt to version 1.0.0 from X11R7 RC4
232- Added makestrs and it's manpage to the devel subpackage.
233
234* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
235- Updated libXt to version 0.99.3 from X11R7 RC3
236- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
237  that /usr/lib/X11 and /usr/include/X11 pre-exist.
238- Removed 'x' suffix from manpage directories to match RC3 upstream.
239
240* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
241- rebuilt
242
243* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
244- Use the default value from configure.ac for --with-xfile-search-path
245  except with %%{_datadir} instead of $(libdir), so Xt can search for
246  app-default files as usual.
247- Move the --with-xfile-search-path outside the with_static condition.
248
249* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
250- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
251  to make sure Xt is looking in the right place for app-defaults files.
252
253* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
254- Updated libXt to version 0.99.2 from X11R7 RC2
255- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
256- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
257
258* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
259- Actually spell RPM_OPT_FLAGS correctly this time.
260
261* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
262- Build with -fno-strict-aliasing to work around possible pointer aliasing
263  issue
264
265* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
266- Updated libXt to version 0.99.1 from X11R7 RC1
267- Updated file manifest to find manpages in 'man3x'
268
269* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
270- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
271  include Xlib headers causing xterm and other things to fail to compile.
272
273* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
274- Renamed package to remove xorg-x11 from the name due to unanimous decision
275  between developers.
276- Use Fedora Extras style BuildRoot tag.
277- Disable static library creation by default.
278- Add missing defattr to devel subpackage
279- Add missing documentation files to doc macro
280- Fix BuildRequires to use new style X library package names
281
282* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
283- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
284  package names, as we want xorg-x11 libs to explicitly build against
285  X.Org supplied libs, rather than "any implementation", which is what the
286  virtual provides is intended for.
287
288* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
289- Renamed package to prepend "xorg-x11" to the name for consistency with
290  the rest of the X11R7 packages.
291- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
292  subpackage to ensure the devel package matches the installed shared libs.
293- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
294  allow applications to use implementation agnostic dependencies.
295- Added post/postun scripts which call ldconfig.
296- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
297  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
298
299* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
300- Initial build.
Note: See TracBrowser for help on using the repository browser.