source: projects/specs/trunk/lib/libX/libXt/libXt-vl.spec @ 2203

Revision 2203, 10.1 KB checked in by Takemikaduchi, 14 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.0.9
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18BuildRequires: libSM-devel
19Obsoletes: XFree86-libs, XOrg-libs
20
21%description
22X.Org X11 libXt runtime library
23
24%package devel
25Summary: X.Org X11 libXt development package
26Group: Development/Libraries
27Requires(pre): xorg-x11-filesystem
28Requires: %{name} = %{version}-%{release}
29Requires: xorg-x11-proto-devel
30Requires: libX11-devel
31Requires: libSM-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXt development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXt runtime library
40Summary(ja): X.Org X11 libXt ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXt runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXt development package
48Group: Development/Libraries
49Requires(pre): xorg-x11-filesystem
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52Requires: compat32-libX11-devel
53Requires: compat32-libSM-devel
54
55%description -n compat32-%{name}-devel
56X.Org X11 libXt development package
57
58%prep
59%setup -q
60
61# Disable static library creation by default.
62%define with_static 0
63
64%build
65# FIXME: Work around pointer aliasing warnings from compiler for now
66export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
67%configure \
68%if ! %{with_static}
69        --disable-static \
70%endif
71        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
72
73make
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78make install DESTDIR=$RPM_BUILD_ROOT
79# NOTE: Create app-defaults directory so this package can be the canonical
80# owner of the directory.
81mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
82
83# We intentionally don't ship *.la files
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%post -n compat32-%{name} -p /sbin/ldconfig
93%postun -n compat32-%{name} -p /sbin/ldconfig
94
95%files
96%defattr(-,root,root,-)
97%doc COPYING README ChangeLog
98%{_libdir}/libXt.so.*
99%dir %{_datadir}/X11/app-defaults
100
101%files devel
102%defattr(-,root,root,-)
103%dir %{_includedir}/X11
104# Listed explicitly instead of with glob, in order for rpm to autodetect
105# when any additions or removals happen.  ie: New Xprint support that we
106# do not want.
107%{_includedir}/X11/CallbackI.h
108%{_includedir}/X11/Composite.h
109%{_includedir}/X11/CompositeP.h
110%{_includedir}/X11/ConstrainP.h
111%{_includedir}/X11/Constraint.h
112%{_includedir}/X11/ConvertI.h
113%{_includedir}/X11/Core.h
114%{_includedir}/X11/CoreP.h
115%{_includedir}/X11/CreateI.h
116%{_includedir}/X11/EventI.h
117%{_includedir}/X11/HookObjI.h
118%{_includedir}/X11/InitialI.h
119%{_includedir}/X11/Intrinsic.h
120%{_includedir}/X11/IntrinsicI.h
121%{_includedir}/X11/IntrinsicP.h
122%{_includedir}/X11/Object.h
123%{_includedir}/X11/ObjectP.h
124%{_includedir}/X11/PassivGraI.h
125%{_includedir}/X11/RectObj.h
126%{_includedir}/X11/RectObjP.h
127%{_includedir}/X11/ResConfigP.h
128%{_includedir}/X11/ResourceI.h
129%{_includedir}/X11/SelectionI.h
130%{_includedir}/X11/Shell.h
131%{_includedir}/X11/ShellI.h
132%{_includedir}/X11/ShellP.h
133%{_includedir}/X11/StringDefs.h
134%{_includedir}/X11/ThreadsI.h
135%{_includedir}/X11/TranslateI.h
136%{_includedir}/X11/VarargsI.h
137%{_includedir}/X11/Vendor.h
138%{_includedir}/X11/VendorP.h
139%{_includedir}/X11/Xtos.h
140%if %{with_static}
141%{_libdir}/libXt.a
142%endif
143%{_libdir}/libXt.so
144%{_libdir}/pkgconfig/xt.pc
145%{_mandir}/man3/*.3*
146
147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root,-)
151%{_libdir}/libXt.so.6
152%{_libdir}/libXt.so.6.0.0
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root,-)
156%if %{with_static}
157%{_libdir}/libXt.a
158%endif
159%{_libdir}/libXt.so
160%{_libdir}/pkgconfig/xt.pc
161%endif
162
163%changelog
164* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
165- new upstream release
166- remove Patch0
167
168* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
169- rebuild with rpm-4.8.1 for pkg-config file
170
171* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
172- new upstream release
173
174* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
175- new upstream release
176
177* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
178- added compat32 package for x86_64 arch support
179
180* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
181- new upstream release
182
183* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
184- new versioning policy
185
186* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
187- initial build for Vine Linux
188
189* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
190- Rebuild for build id
191
192* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
193- Don't install INSTALL
194
195* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
196- Update to 1.0.4
197
198* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
199- rebuild
200
201* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
202- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
203  libXt is the canonical owner of the directory.  Discovered in (#198025).
204
205* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
206- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
207  in the installed pkgconfig file.  Apps should link against libSM if they
208  need it, but we shouldn't force them to link against it if they don't.
209
210* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
211- Updated libXt to version 1.0.2 from X11R7.1
212
213* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
214- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
215
216* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
217- Added "BuildRequires: pkgconfig" for (#193503)
218- Replace "makeinstall" with "make install DESTDIR=..."
219- Remove package ownership of mandir/libdir/etc.
220
221* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
222- Update to 1.0.1
223
224* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
225- bump again for double-long bug on ppc(64)
226
227* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
228- rebuilt for new gcc4.1 snapshot and glibc changes
229
230* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
231- Bumped and rebuilt
232
233* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
234- Updated libXt to version 1.0.0 from X11R7 RC4
235- Added makestrs and it's manpage to the devel subpackage.
236
237* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
238- Updated libXt to version 0.99.3 from X11R7 RC3
239- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
240  that /usr/lib/X11 and /usr/include/X11 pre-exist.
241- Removed 'x' suffix from manpage directories to match RC3 upstream.
242
243* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
244- rebuilt
245
246* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
247- Use the default value from configure.ac for --with-xfile-search-path
248  except with %%{_datadir} instead of $(libdir), so Xt can search for
249  app-default files as usual.
250- Move the --with-xfile-search-path outside the with_static condition.
251
252* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
253- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
254  to make sure Xt is looking in the right place for app-defaults files.
255
256* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
257- Updated libXt to version 0.99.2 from X11R7 RC2
258- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
259- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
260
261* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
262- Actually spell RPM_OPT_FLAGS correctly this time.
263
264* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
265- Build with -fno-strict-aliasing to work around possible pointer aliasing
266  issue
267
268* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
269- Updated libXt to version 0.99.1 from X11R7 RC1
270- Updated file manifest to find manpages in 'man3x'
271
272* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
273- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
274  include Xlib headers causing xterm and other things to fail to compile.
275
276* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
277- Renamed package to remove xorg-x11 from the name due to unanimous decision
278  between developers.
279- Use Fedora Extras style BuildRoot tag.
280- Disable static library creation by default.
281- Add missing defattr to devel subpackage
282- Add missing documentation files to doc macro
283- Fix BuildRequires to use new style X library package names
284
285* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
286- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
287  package names, as we want xorg-x11 libs to explicitly build against
288  X.Org supplied libs, rather than "any implementation", which is what the
289  virtual provides is intended for.
290
291* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
292- Renamed package to prepend "xorg-x11" to the name for consistency with
293  the rest of the X11R7 packages.
294- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
295  subpackage to ensure the devel package matches the installed shared libs.
296- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
297  allow applications to use implementation agnostic dependencies.
298- Added post/postun scripts which call ldconfig.
299- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
300  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
301
302* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
303- Initial build.
Note: See TracBrowser for help on using the repository browser.