source: projects/specs/trunk/lib/libX/libXt/libXt-vl.spec @ 12185

Revision 12185, 10.9 KB checked in by tomop, 5 years ago (diff)

updated X11 libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.1.5
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: xorg-x11-util-macros
18BuildRequires: libX11-devel
19BuildRequires: libSM-devel
20Obsoletes: XFree86-libs, XOrg-libs
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26X.Org X11 libXt runtime library
27
28%package devel
29Summary: X.Org X11 libXt development package
30Group: Development/Libraries
31Requires(pre): xorg-x11-filesystem
32Requires: %{name} = %{version}-%{release}
33Requires: xorg-x11-proto-devel
34Requires: libX11-devel
35Requires: libSM-devel
36Obsoletes: XFree86-devel, XOrg-devel
37
38%description devel
39X.Org X11 libXt development package
40
41# compat32
42%package -n compat32-%{name}
43Summary: X.Org X11 libXt runtime library
44Summary(ja): X.Org X11 libXt ランタイムライブラリ
45Group: System Environment/Libraries
46
47%description -n compat32-%{name}
48X.Org X11 libXt runtime library
49
50%package -n compat32-%{name}-devel
51Summary: X.Org X11 libXt development package
52Group: Development/Libraries
53Requires(pre): xorg-x11-filesystem
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: %{name}-devel = %{version}-%{release}
56Requires: compat32-libX11-devel
57Requires: compat32-libSM-devel
58
59%description -n compat32-%{name}-devel
60X.Org X11 libXt development package
61
62%prep
63%setup -q
64
65# Disable static library creation by default.
66%define with_static 0
67
68%build
69# FIXME: Work around pointer aliasing warnings from compiler for now
70export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
71%configure \
72%if ! %{with_static}
73        --disable-static \
74%endif
75        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
76
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83# NOTE: Create app-defaults directory so this package can be the canonical
84# owner of the directory.
85mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
86
87# We intentionally don't ship *.la files
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%license COPYING
102%doc README ChangeLog
103%{_libdir}/libXt.so.*
104%dir %{_datadir}/X11/app-defaults
105
106%files devel
107%defattr(-,root,root,-)
108%dir %{_includedir}/X11
109# Listed explicitly instead of with glob, in order for rpm to autodetect
110# when any additions or removals happen.  ie: New Xprint support that we
111# do not want.
112%{_includedir}/X11/CallbackI.h
113%{_includedir}/X11/Composite.h
114%{_includedir}/X11/CompositeP.h
115%{_includedir}/X11/ConstrainP.h
116%{_includedir}/X11/Constraint.h
117%{_includedir}/X11/ConvertI.h
118%{_includedir}/X11/Core.h
119%{_includedir}/X11/CoreP.h
120%{_includedir}/X11/CreateI.h
121%{_includedir}/X11/EventI.h
122%{_includedir}/X11/HookObjI.h
123%{_includedir}/X11/InitialI.h
124%{_includedir}/X11/Intrinsic.h
125%{_includedir}/X11/IntrinsicI.h
126%{_includedir}/X11/IntrinsicP.h
127%{_includedir}/X11/Object.h
128%{_includedir}/X11/ObjectP.h
129%{_includedir}/X11/PassivGraI.h
130%{_includedir}/X11/RectObj.h
131%{_includedir}/X11/RectObjP.h
132%{_includedir}/X11/ResConfigP.h
133%{_includedir}/X11/ResourceI.h
134%{_includedir}/X11/SelectionI.h
135%{_includedir}/X11/Shell.h
136%{_includedir}/X11/ShellI.h
137%{_includedir}/X11/ShellP.h
138%{_includedir}/X11/StringDefs.h
139%{_includedir}/X11/ThreadsI.h
140%{_includedir}/X11/TranslateI.h
141%{_includedir}/X11/VarargsI.h
142%{_includedir}/X11/Vendor.h
143%{_includedir}/X11/VendorP.h
144%{_includedir}/X11/Xtos.h
145%if %{with_static}
146%{_libdir}/libXt.a
147%endif
148%{_libdir}/libXt.so
149%{_libdir}/pkgconfig/xt.pc
150%{_datadir}/doc/%{name}
151%{_mandir}/man3/*.3*
152
153# compat32
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-,root,root,-)
157%{_libdir}/libXt.so.6
158%{_libdir}/libXt.so.6.0.0
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root,-)
162%if %{with_static}
163%{_libdir}/libXt.a
164%endif
165%{_libdir}/libXt.so
166%endif
167
168%changelog
169* Fri Sep 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.5-2
170- rebuilt with current environment.
171
172* Sun May 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-1
173- new upstream release
174
175* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-2
176- rebuild with VineSeed environment
177
178* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
179- new upstream release
180  (including security fix for CVE-2013-2002,2005)
181
182* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
183- new upstream release
184
185* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
186- new upstream release
187- add BuildRequires: xorg-x11-util-macros
188
189* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
190- new upstream release
191
192* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
193- new upstream release
194- remove Patch0
195
196* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
197- rebuild with rpm-4.8.1 for pkg-config file
198
199* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
200- new upstream release
201
202* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
203- new upstream release
204
205* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
206- added compat32 package for x86_64 arch support
207
208* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
209- new upstream release
210
211* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
212- new versioning policy
213
214* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
215- initial build for Vine Linux
216
217* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
218- Rebuild for build id
219
220* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
221- Don't install INSTALL
222
223* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
224- Update to 1.0.4
225
226* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
227- rebuild
228
229* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
230- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
231  libXt is the canonical owner of the directory.  Discovered in (#198025).
232
233* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
234- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
235  in the installed pkgconfig file.  Apps should link against libSM if they
236  need it, but we shouldn't force them to link against it if they don't.
237
238* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
239- Updated libXt to version 1.0.2 from X11R7.1
240
241* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
242- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
243
244* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
245- Added "BuildRequires: pkgconfig" for (#193503)
246- Replace "makeinstall" with "make install DESTDIR=..."
247- Remove package ownership of mandir/libdir/etc.
248
249* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
250- Update to 1.0.1
251
252* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
253- bump again for double-long bug on ppc(64)
254
255* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
256- rebuilt for new gcc4.1 snapshot and glibc changes
257
258* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
259- Bumped and rebuilt
260
261* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
262- Updated libXt to version 1.0.0 from X11R7 RC4
263- Added makestrs and it's manpage to the devel subpackage.
264
265* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
266- Updated libXt to version 0.99.3 from X11R7 RC3
267- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
268  that /usr/lib/X11 and /usr/include/X11 pre-exist.
269- Removed 'x' suffix from manpage directories to match RC3 upstream.
270
271* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
272- rebuilt
273
274* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
275- Use the default value from configure.ac for --with-xfile-search-path
276  except with %%{_datadir} instead of $(libdir), so Xt can search for
277  app-default files as usual.
278- Move the --with-xfile-search-path outside the with_static condition.
279
280* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
281- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
282  to make sure Xt is looking in the right place for app-defaults files.
283
284* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
285- Updated libXt to version 0.99.2 from X11R7 RC2
286- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
287- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
288
289* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
290- Actually spell RPM_OPT_FLAGS correctly this time.
291
292* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
293- Build with -fno-strict-aliasing to work around possible pointer aliasing
294  issue
295
296* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
297- Updated libXt to version 0.99.1 from X11R7 RC1
298- Updated file manifest to find manpages in 'man3x'
299
300* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
301- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
302  include Xlib headers causing xterm and other things to fail to compile.
303
304* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
305- Renamed package to remove xorg-x11 from the name due to unanimous decision
306  between developers.
307- Use Fedora Extras style BuildRoot tag.
308- Disable static library creation by default.
309- Add missing defattr to devel subpackage
310- Add missing documentation files to doc macro
311- Fix BuildRequires to use new style X library package names
312
313* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
314- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
315  package names, as we want xorg-x11 libs to explicitly build against
316  X.Org supplied libs, rather than "any implementation", which is what the
317  virtual provides is intended for.
318
319* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
320- Renamed package to prepend "xorg-x11" to the name for consistency with
321  the rest of the X11R7 packages.
322- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
323  subpackage to ensure the devel package matches the installed shared libs.
324- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
325  allow applications to use implementation agnostic dependencies.
326- Added post/postun scripts which call ldconfig.
327- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
328  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
329
330* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
331- Initial build.
Note: See TracBrowser for help on using the repository browser.