source: projects/specs/trunk/lib/libX/libXrender/libXrender-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXrender runtime library
4Summary(ja): X.Org X11 libXrender ランタイムライブラリ
5Name: libXrender
6Version: 0.9.5
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17BuildRequires: libX11-devel
18Obsoletes: XFree86-libs, XOrg-libs
19
20%description
21X.Org X11 libXrender runtime library
22
23%package devel
24Summary: X.Org X11 libXrender development package
25Summary(ja): X.Org X11 libXrender 開発パッケージ
26Group: Development/Libraries
27Requires(pre): xorg-x11-filesystem
28Requires: %{name} = %{version}-%{release}
29Requires: xorg-x11-proto-devel
30Requires: libX11-devel
31Obsoletes: XFree86-devel, XOrg-devel
32
33%description devel
34X.Org X11 libXrender development package
35
36# compat32
37%package -n compat32-%{name}
38Summary: X.Org X11 libXrender runtime library
39Summary(ja): X.Org X11 libXrender ランタイムライブラリ
40Group: System Environment/Libraries
41
42%description -n compat32-%{name}
43X.Org X11 libXrender runtime library
44
45%package -n compat32-%{name}-devel
46Summary: X.Org X11 libXrender development package
47Summary(ja): X.Org X11 libXrender 開発パッケージ
48Group: Development/Libraries
49Requires(pre): xorg-x11-filesystem
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52
53%description -n compat32-%{name}-devel
54X.Org X11 libXrender development package
55
56%prep
57%setup -q
58
59# Disable static library creation by default.
60%define with_static 0
61
62%build
63%configure \
64%if ! %{with_static}
65        --disable-static
66%endif
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install DESTDIR=$RPM_BUILD_ROOT
73
74# We intentionally don't ship *.la files
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%post -n compat32-%{name} -p /sbin/ldconfig
84%postun -n compat32-%{name} -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc AUTHORS COPYING README ChangeLog
89%{_libdir}/libXrender.so.1
90%{_libdir}/libXrender.so.1.3.0
91
92%files devel
93%defattr(-,root,root,-)
94%dir %{_includedir}/X11
95%dir %{_includedir}/X11/extensions
96%{_includedir}/X11/extensions/Xrender.h
97%if %{with_static}
98%{_libdir}/libXrender.a
99%endif
100%{_libdir}/libXrender.so
101%{_libdir}/pkgconfig/xrender.pc
102
103# compat32
104%if %{build_compat32}
105%files -n compat32-%{name}
106%defattr(-,root,root,-)
107%{_libdir}/libXrender.so.1
108%{_libdir}/libXrender.so.1.3.0
109
110%files -n compat32-%{name}-devel
111%defattr(-,root,root,-)
112%if %{with_static}
113%{_libdir}/libXrender.a
114%endif
115%{_libdir}/libXrender.so
116%{_libdir}/pkgconfig/xrender.pc
117%endif
118
119%changelog
120* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
121- new upstream release
122
123* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.4-3
124- added compat32 package for x86_64 arch support
125
126* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.4-2
127- spec in utf-8
128
129* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.4-1
130- new versioning policy
131
132* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.4-0vl1
133- initial build for Vine Linux
134
135* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 0.9.4-1
136- libXrender 0.9.4
137
138* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> 0.9.3-1
139- libXrender 0.9.3
140
141* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 0.9.2-2
142- Don't install INSTALL
143
144* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 0.9.2-1
145- Update to 0.9.2
146
147* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 0.9.1-3.1
148- rebuild
149
150* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 0.9.1-3
151- Added "Requires: libX11-devel" to devel package for xrender.pc
152
153* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 0.9.1-2
154- Added "BuildRequires: pkgconfig" for (#193429)
155- Replace "makeinstall" with "make install DESTDIR=..."
156- Remove package ownership of mandir/libdir/etc.
157
158* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 0.9.1-1
159- Update to 0.9.1
160
161* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.0.2-3.2
162- bump again for double-long bug on ppc(64)
163
164* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.0.2-3.1
165- rebuilt for new gcc4.1 snapshot and glibc changes
166
167* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 0.9.0.2-3
168- Bump and rebuild
169
170* Mon Jan 16 2006 Mike A. Harris <mharris@redhat.com> 0.9.0.2-2
171- Added "Requires: xorg-x11-proto-devel" to resolve bug (#176742)
172
173* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 0.9.0.2-1
174- Updated libXrender to version 0.9.0.2 from X11R7 RC4
175
176* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.9.0.1-1
177- Updated libXrender to version 0.9.0.1 from X11R7 RC3
178- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
179  that /usr/lib/X11 and /usr/include/X11 pre-exist.
180- Removed 'x' suffix from manpage directories to match RC3 upstream.
181
182* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
183- rebuilt
184
185* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.9.0-5
186- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
187- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
188
189* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.9.0-4
190- Updated libXrender to version 0.9.0 from X11R7 RC1
191
192* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.9.0-3
193- Renamed package to remove xorg-x11 from the name due to unanimous decision
194  between developers.
195- Use Fedora Extras style BuildRoot tag.
196- Disable static library creation by default.
197- Add missing defattr to devel subpackage
198- Add missing documentation files to doc macro
199
200* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.9.0-2
201- Renamed package to prepend "xorg-x11" to the name for consistency with
202  the rest of the X11R7 packages.
203- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
204  subpackage to ensure the devel package matches the installed shared libs.
205- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
206  allow applications to use implementation agnostic dependencies.
207- Added post/postun scripts which call ldconfig.
208- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
209  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
210
211* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.9.0-1
212- Initial build.
Note: See TracBrowser for help on using the repository browser.