source: projects/specs/trunk/lib/libX/libXpm/libXpm-vl.spec @ 2182

Revision 2182, 7.3 KB checked in by Takemikaduchi, 14 years ago (diff)

libXpm:create compat32 package, task-compiz: fix package version, others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXpm runtime library
4Summary(ja): X.Org X11 libXpm ランタイムライブラリ
5Name: libXpm
6Version: 3.5.8
7Release: 3%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: gettext
16BuildRequires: pkgconfig
17BuildRequires: xorg-x11-proto-devel
18BuildRequires: libX11-devel
19# FIXME: Although ./configure checks for libXt and libXext, and indicates
20# that they are missing, it continues to build anyway, and just does not
21# build sxpm if they are not present.  Therefore, libXt-devel and
22# libXext-devel are required build deps in order to get sxpm built.
23BuildRequires: libXt-devel
24BuildRequires: libXext-devel
25BuildRequires: libXau-devel
26
27Obsoletes: XFree86-libs, XOrg-libs
28
29%description
30X.Org X11 libXpm runtime library
31
32%package devel
33Summary: X.Org X11 libXpm development package
34Group: Development/Libraries
35Requires(pre): xorg-x11-filesystem
36Requires: %{name} = %{version}-%{release}
37Requires: libX11-devel
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXpm development package
42
43
44%if %{build_compat32}
45%package -n compat32-%{name}
46Summary: X.Org X11 libXpm runtime library
47Summary(ja): X.Org X11 libXpm ランタイムライブラリ
48Group: System Environment/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52X.Org X11 libXpm runtime library
53
54%package -n compat32-%{name}-devel
55Summary: X.Org X11 libXpm development package
56Group: Development/Libraries
57Requires(pre): xorg-x11-filesystem
58Requires: %{name}-devel = %{version}-%{release}
59Requires: compat32-libX11-devel
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXpm development package
63
64%endif
65
66%prep
67%setup -q
68
69# Disable static library creation by default.
70%define with_static 0
71
72%build
73%configure \
74%if ! %{with_static}
75        --disable-static
76%endif
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(-,root,root,-)
95%doc AUTHORS COPYING README ChangeLog
96%{_libdir}/libXpm.so.4
97%{_libdir}/libXpm.so.4.11.*
98
99%files devel
100%defattr(-,root,root,-)
101%{_bindir}/cxpm
102%{_bindir}/sxpm
103%dir %{_includedir}/X11
104%{_includedir}/X11/xpm.h
105%if %{with_static}
106%{_libdir}/libXpm.a
107%endif
108%{_libdir}/libXpm.so
109%{_libdir}/pkgconfig/xpm.pc
110#%dir %{_mandir}/man1x
111%{_mandir}/man1/*.1*
112#%{_mandir}/man1/*.1x*
113
114%if %{build_compat32}
115%files -n compat32-%{name}
116%defattr(-,root,root,-)
117%{_libdir}/libXpm.so.4
118%{_libdir}/libXpm.so.4.11.*
119
120%files -n compat32-%{name}-devel
121%defattr(-,root,root,-)
122%if %{with_static}
123%{_libdir}/libXpm.a
124%endif
125%{_libdir}/libXpm.so
126%{_libdir}/pkgconfig/xpm.pc
127
128%endif
129
130%changelog
131* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.8-3
132- create compat32-%%{name} and compat32-%%{name}-devel packages
133
134* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.8-2
135- rebuild with rpm-4.8.1 for pkg-config file
136
137* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.8-1
138- new upstream release
139
140* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.7-2
141- spec in utf-8
142
143* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.7-1
144- new versioning policy
145
146* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.7-0vl1
147- initial build for Vine Linux
148
149* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 3.5.7-1
150- libXpm 3.5.7
151
152* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 3.5.6-2
153- Rebuild for build id
154
155* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 3.5.6-2
156- Don't install INSTALL
157
158* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 3.5.6-1
159- Update to 3.5.6
160
161* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.5.5-3
162- rebuild
163
164* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 3.5.5-2
165- Added "BuildRequires: pkgconfig" for (#193427)
166- Replace "makeinstall" with "make install DESTDIR=..."
167- Remove package ownership of mandir/libdir/etc.
168
169* Thu Apr 26 2006 Adam Jackson <ajackson@redhat.com> 3.5.5-1
170- Update to 3.5.5
171
172* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 3.5.4.2-2.2
173- bump again for double-long bug on ppc(64)
174
175* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 3.5.4.2-2.1
176- rebuilt for new gcc4.1 snapshot and glibc changes
177
178* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 3.5.4.2-2
179- Bumped and rebuilt
180
181* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 3.5.4.2-1
182- Updated libXpm to version 3.5.4.2 from X11R7 RC4
183
184* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 3.5.4.1-1
185- Updated libXpm to version 3.5.4.1 from X11R7 RC3
186- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
187  that /usr/lib/X11 and /usr/include/X11 pre-exist.
188- Removed 'x' suffix from manpage directories to match RC3 upstream.
189- Added "Requires: libX11-devel" to devel subpackage as xpm.h includes various
190  X headers. (#174163)
191- Added missing build dep libXau-devel
192
193* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
194- rebuilt
195
196* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 3.5.4-1
197- Updated libXpm to version 3.5.4 from X11R7 RC2
198- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
199- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
200
201* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 3.5.3-1
202- Updated libXpm to version 3.5.3 from X11R7 RC1
203- Added manpages for sxpm, cxpm
204
205* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 3.5.2-5
206- Renamed package to remove xorg-x11 from the name due to unanimous decision
207  between developers.
208- Use Fedora Extras style BuildRoot tag.
209- Disable static library creation by default.
210- Add missing defattr to devel subpackage
211- Add missing documentation files to doc macro
212- Fix BuildRequires to use new style X library package names
213
214* Sun Sep 4 2005 Mike A. Harris <mharris@redhat.com> 3.5.2-4
215- Although ./configure checks for libXt and libXext, and indicates
216  that they are missing, it continues to build anyway, and just does not
217  build sxpm if they are not present.  Therefore, libXt-devel and
218  libXext-devel are required build deps in order to get sxpm built.
219- Added missing defattr to devel subpackage.
220
221* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 3.5.2-3
222- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
223  package names, as we want xorg-x11 libs to explicitly build against
224  X.Org supplied libs, rather than "any implementation", which is what the
225  virtual provides is intended for.
226
227* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 3.5.2-2
228- Renamed package to prepend "xorg-x11" to the name for consistency with
229  the rest of the X11R7 packages.
230- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
231  subpackage to ensure the devel package matches the installed shared libs.
232- Added missing sxpm binary to devel subpackage
233- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
234  allow applications to use implementation agnostic dependencies.
235- Added post/postun scripts which call ldconfig.
236- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
237  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
238
239* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 3.5.2-1
240- Initial build.
Note: See TracBrowser for help on using the repository browser.