source: projects/specs/trunk/lib/libX/libXmu/libXmu-vl.spec @ 8064

Revision 8064, 8.7 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXmu/libXmuu runtime libraries
4Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
5Name: libXmu
6Version: 1.1.2
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXt-devel
20BuildRequires: libXau-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: Takemikaduchi
26
27%description
28X.Org X11 libXmu/libXmuu runtime libraries
29
30%package devel
31Summary: X.Org X11 libXmu development package
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem
34Requires: %{name} = %{version}-%{release}
35Requires: pkgconfig
36Requires: xorg-x11-util-macros
37Requires: xorg-x11-proto-devel libX11-devel libXt-devel libXext-devel
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXmu development package
42
43# compat32
44%package -n compat32-%{name}
45Summary: X.Org X11 libXmu/libXmuu runtime libraries
46Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
47Group: System Environment/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description -n compat32-%{name}
51X.Org X11 libXmu/libXmuu runtime libraries
52
53%package -n compat32-%{name}-devel
54Summary: X.Org X11 libXmu development package
55Group: Development/Libraries
56Requires(pre): xorg-x11-filesystem
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: compat32-libX11-devel compat32-libXt-devel compat32-libXext-devel
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXmu development package
63
64%prep
65%setup -q
66
67# Disable static library creation by default.
68%define with_static 0
69
70%build
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# We intentionally don't ship *.la files
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85# remove xml and txt file
86rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97%files
98%defattr(-,root,root,-)
99%doc AUTHORS COPYING README ChangeLog
100%{_libdir}/libXmu.so.6
101%{_libdir}/libXmu.so.6.2.0
102%{_libdir}/libXmuu.so.1
103%{_libdir}/libXmuu.so.1.0.0
104
105%files devel
106%defattr(-,root,root,-)
107%dir %{_includedir}/X11
108%dir %{_includedir}/X11/Xmu
109%{_includedir}/X11/Xmu/Atoms.h
110%{_includedir}/X11/Xmu/CharSet.h
111%{_includedir}/X11/Xmu/CloseHook.h
112%{_includedir}/X11/Xmu/Converters.h
113%{_includedir}/X11/Xmu/CurUtil.h
114%{_includedir}/X11/Xmu/CvtCache.h
115%{_includedir}/X11/Xmu/DisplayQue.h
116%{_includedir}/X11/Xmu/Drawing.h
117%{_includedir}/X11/Xmu/Editres.h
118%{_includedir}/X11/Xmu/EditresP.h
119%{_includedir}/X11/Xmu/Error.h
120%{_includedir}/X11/Xmu/ExtAgent.h
121%{_includedir}/X11/Xmu/Initer.h
122%{_includedir}/X11/Xmu/Lookup.h
123%{_includedir}/X11/Xmu/Misc.h
124%{_includedir}/X11/Xmu/StdCmap.h
125%{_includedir}/X11/Xmu/StdSel.h
126%{_includedir}/X11/Xmu/SysUtil.h
127%{_includedir}/X11/Xmu/WhitePoint.h
128%{_includedir}/X11/Xmu/WidgetNode.h
129%{_includedir}/X11/Xmu/WinUtil.h
130%{_includedir}/X11/Xmu/Xct.h
131%{_includedir}/X11/Xmu/Xmu.h
132%if %{with_static}
133%{_libdir}/libXmu.a
134%{_libdir}/libXmuu.a
135%endif
136%{_libdir}/libXmu.so
137%{_libdir}/libXmuu.so
138%{_libdir}/pkgconfig/xmu.pc
139%{_libdir}/pkgconfig/xmuu.pc
140
141# compat32
142%if %{build_compat32}
143%files -n compat32-%{name}
144%defattr(-,root,root,-)
145%{_libdir}/libXmu.so.6
146%{_libdir}/libXmu.so.6.2.0
147%{_libdir}/libXmuu.so.1
148%{_libdir}/libXmuu.so.1.0.0
149
150%files -n compat32-%{name}-devel
151%defattr(-,root,root,-)
152%if %{with_static}
153%{_libdir}/libXmu.a
154%{_libdir}/libXmuu.a
155%endif
156%{_libdir}/libXmu.so
157%{_libdir}/libXmuu.so
158%endif
159
160%changelog
161* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
162- rebuild with VineSeed environment
163
164* Mon Sep 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
165- new upstream release
166
167* Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
168- new upstream release
169
170* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
171- new upstream release
172- fix %%install, %%files
173
174* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
175- rebuild with rpm-4.8.1 for pkg-config file
176
177* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
178- new upstream release
179
180* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
181- added compat32 package for x86_64 arch support
182
183* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
184- new upstream release
185
186* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
187- new versioning policy
188
189* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
190- initial build for Vine Linux
191
192* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
193- Rebuild for build id
194
195* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
196- Don't install INSTALL
197
198* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.3-1.fc7
199- Update to 1.0.3
200
201* Fri Oct 13 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-6.fc7
202- Also add Requires for libXext-devel for development package (#210123)
203- Add pkgconfig dependency for -devel package.
204
205* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.2-5
206- Add Requires on libXt (bug 202558)
207
208* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
209- rebuild
210
211* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-4
212- Rebuild, brew doesn't pick up buildroot changes fast enough.
213
214* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-3
215- Rebuild for libXt pkgconfig fixes.
216
217* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
218- Replace "makeinstall" with "make install DESTDIR=..."
219- Added "Requires: xorg-x11-proto-devel, libX11-devel, libXt-devel" to devel
220  subpackage needed by xmu.pc, xmuu.pc
221- Remove package ownership of mandir/libdir/etc.
222
223* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
224- Update to 1.0.2
225
226* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
227- Update to 1.0.1
228
229* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
230- bump again for double-long bug on ppc(64)
231
232* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
233- rebuilt for new gcc4.1 snapshot and glibc changes
234
235* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
236- Bumped and rebuilt
237
238* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
239- Updated libXmu to version 1.0.0 from X11R7 RC4
240
241* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
242- Updated libXmu to version 0.99.2 from X11R7 RC3
243- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
244  that /usr/lib/X11 and /usr/include/X11 pre-exist.
245- Removed 'x' suffix from manpage directories to match RC3 upstream.
246- Added "BuildRequires: pkgconfig, libXau-devel, xorg-x11-util-macros" to
247  fix build dependencies.
248
249* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
250- rebuilt
251
252* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
253- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
254- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
255
256* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
257- Updated libXmu to version 0.99.1 from X11R7 RC1
258
259* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
260- Renamed package to remove xorg-x11 from the name due to unanimous decision
261  between developers.
262- Use Fedora Extras style BuildRoot tag.
263- Disable static library creation by default.
264- Add missing defattr to devel subpackage
265- Add missing documentation files to doc macro
266- Fix BuildRequires to use new style X library package names
267
268* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
269- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
270  package names, as we want xorg-x11 libs to explicitly build against
271  X.Org supplied libs, rather than "any implementation", which is what the
272  virtual provides is intended for.
273
274* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
275- Renamed package to prepend "xorg-x11" to the name for consistency with
276  the rest of the X11R7 packages.
277- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
278  subpackage to ensure the devel package matches the installed shared libs.
279- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
280  allow applications to use implementation agnostic dependencies.
281- Added post/postun scripts which call ldconfig.
282- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
283  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
284
285* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
286- Initial build.
Note: See TracBrowser for help on using the repository browser.